aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-05-26 15:13:02 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-05-26 15:13:02 +0000
commit45bbf9c55e7a61067b1659ebbe03b5070bcfb50d (patch)
tree9da7cb18de163dd27ae5cee8a07e678c6d9c54b0 /converters
parente6cb85961dd46da24b91f2f326e937f165a530b1 (diff)
downloadports-45bbf9c55e7a61067b1659ebbe03b5070bcfb50d.tar.gz
ports-45bbf9c55e7a61067b1659ebbe03b5070bcfb50d.zip
String::SetUTF8 lets you directly set or unset the UTF-8 flag
for your strings. Sometimes you get binary data that Perl doesn't treat as UTF-8, so instead of doing a trick with pack and unpack you can just use this module. WWW: http://search.cpan.org/dist/String-SetUTF8/ Andrei V. Shetuhin <reki@reki.ru> PR: ports/134932 Submitted by: Andrei V. Shetuhin <reki@reki.ru>
Notes
Notes: svn path=/head/; revision=234583
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-String-SetUTF8/Makefile21
-rw-r--r--converters/p5-String-SetUTF8/distinfo3
-rw-r--r--converters/p5-String-SetUTF8/pkg-descr8
-rw-r--r--converters/p5-String-SetUTF8/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 4ec9fa2ba662..81d16123ac37 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -71,6 +71,7 @@
SUBDIR += p5-Number-RecordLocator
SUBDIR += p5-Storable-AMF
SUBDIR += p5-String-Multibyte
+ SUBDIR += p5-String-SetUTF8
SUBDIR += p5-Text-Bidi
SUBDIR += p5-Text-Iconv
SUBDIR += p5-Text-Unidecode
diff --git a/converters/p5-String-SetUTF8/Makefile b/converters/p5-String-SetUTF8/Makefile
new file mode 100644
index 000000000000..2953afd75d4a
--- /dev/null
+++ b/converters/p5-String-SetUTF8/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: String::SetUTF8
+# Date created: 25 May 2009
+# Whom: Andrei V. Shetuhin <reki@reki.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-SetUTF8
+PORTVERSION= 1.00
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= reki@reki.ru
+COMMENT= Perl module to manipulate internal UTF8 flag on strings
+
+PERL_CONFIGURE= yes
+
+MAN3= String::SetUTF8.3
+
+.include <bsd.port.mk>
diff --git a/converters/p5-String-SetUTF8/distinfo b/converters/p5-String-SetUTF8/distinfo
new file mode 100644
index 000000000000..2ff2a5ffc8f1
--- /dev/null
+++ b/converters/p5-String-SetUTF8/distinfo
@@ -0,0 +1,3 @@
+MD5 (String-SetUTF8-1.00.tar.gz) = abecdda64a1de21e88d238b7bac48db6
+SHA256 (String-SetUTF8-1.00.tar.gz) = ecb626df9de79c9d23dd230b178d1d8425f87615c4c25c0acf911a02a3374503
+SIZE (String-SetUTF8-1.00.tar.gz) = 3625
diff --git a/converters/p5-String-SetUTF8/pkg-descr b/converters/p5-String-SetUTF8/pkg-descr
new file mode 100644
index 000000000000..0732646009c6
--- /dev/null
+++ b/converters/p5-String-SetUTF8/pkg-descr
@@ -0,0 +1,8 @@
+String::SetUTF8 lets you directly set or unset the UTF-8 flag
+for your strings. Sometimes you get binary data that
+Perl doesn't treat as UTF-8, so instead of doing a trick
+with pack and unpack you can just use this module.
+
+WWW: http://search.cpan.org/dist/String-SetUTF8/
+
+Andrei V. Shetuhin <reki@reki.ru>
diff --git a/converters/p5-String-SetUTF8/pkg-plist b/converters/p5-String-SetUTF8/pkg-plist
new file mode 100644
index 000000000000..0c5cdaa755fa
--- /dev/null
+++ b/converters/p5-String-SetUTF8/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/String/SetUTF8.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/SetUTF8/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/SetUTF8/SetUTF8.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/SetUTF8/SetUTF8.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/SetUTF8
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/String