aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
commit741aa714833b9bb1e9afaaf5124d3f5c60b5e49c (patch)
treee9b79b363f2fc4a63535a25c71491fa49a79b556 /converters
parente6b2e4b3537ce43e377d2f4fe0ac46b6ab8c4395 (diff)
downloadports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.tar.gz
ports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=218938
Diffstat (limited to 'converters')
-rw-r--r--converters/ascii2binary/Makefile1
-rw-r--r--converters/enca/Makefile1
-rw-r--r--converters/fix-mime-charset/Makefile1
-rw-r--r--converters/psiconv/Makefile1
-rw-r--r--converters/shftool/Makefile1
-rw-r--r--converters/tnef/Makefile1
-rw-r--r--converters/ytnef/Makefile2
7 files changed, 0 insertions, 8 deletions
diff --git a/converters/ascii2binary/Makefile b/converters/ascii2binary/Makefile
index 250ea8f5b566..cec842dc0bd9 100644
--- a/converters/ascii2binary/Makefile
+++ b/converters/ascii2binary/Makefile
@@ -18,7 +18,6 @@ USE_BZIP2= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/converters/enca/Makefile b/converters/enca/Makefile
index 7156982a6098..20169f7d9b65 100644
--- a/converters/enca/Makefile
+++ b/converters/enca/Makefile
@@ -24,7 +24,6 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
--without-librecode \
--with-libiconv=${LOCALBASE}
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
diff --git a/converters/fix-mime-charset/Makefile b/converters/fix-mime-charset/Makefile
index 5f120415758a..e0da2a7b743c 100644
--- a/converters/fix-mime-charset/Makefile
+++ b/converters/fix-mime-charset/Makefile
@@ -22,7 +22,6 @@ PORTDOCS= README.koi8r README
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/converters/psiconv/Makefile b/converters/psiconv/Makefile
index 1628b8d947e1..54b243c8c4ef 100644
--- a/converters/psiconv/Makefile
+++ b/converters/psiconv/Makefile
@@ -19,7 +19,6 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-imagemagick=no
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= psiconv.1 psiconv-config.1
diff --git a/converters/shftool/Makefile b/converters/shftool/Makefile
index 75e85f6b4856..3c0d2c78bd56 100644
--- a/converters/shftool/Makefile
+++ b/converters/shftool/Makefile
@@ -17,7 +17,6 @@ COMMENT= Converter for the Standard Hex Format (SHF)
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
post-patch:
${REINPLACE_CMD} -e 's,^LIBLOC_LIST=.*,LIBLOC_LIST=${LOCALBASE},' \
diff --git a/converters/tnef/Makefile b/converters/tnef/Makefile
index 8eb364c53eda..c3a7b0b8ecfd 100644
--- a/converters/tnef/Makefile
+++ b/converters/tnef/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= Unpack data in MS Outlook TNEF format
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= tnef.1
PORTDOCS= AUTHORS NEWS README THANKS TODO
diff --git a/converters/ytnef/Makefile b/converters/ytnef/Makefile
index b6689cec4443..48ed5b2ace43 100644
--- a/converters/ytnef/Makefile
+++ b/converters/ytnef/Makefile
@@ -25,8 +25,6 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
PLIST_FILES= bin/ytnef bin/ytnefprocess.pl bin/ytnefprint
PORTDOCS= AUTHORS NEWS README