aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
commitdca255c3cec21c0c66003eb626763c7fdc2cb59a (patch)
treee6eac391e081f99a997be8b0d8e036d22d5fe2a9 /converters
parent4973e5b396de5fdc84495adcdcb1f40854c8ebcd (diff)
downloadports-dca255c3cec21c0c66003eb626763c7fdc2cb59a.tar.gz
ports-dca255c3cec21c0c66003eb626763c7fdc2cb59a.zip
Convert USE_PHP*=yes into USES=php*
PR: 210529 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6936
Notes
Notes: svn path=/head/; revision=417719
Diffstat (limited to 'converters')
-rw-r--r--converters/pecl-fribidi/Makefile4
-rw-r--r--converters/pecl-igbinary/Makefile7
-rw-r--r--converters/php5-bsdconv/Makefile6
3 files changed, 4 insertions, 13 deletions
diff --git a/converters/pecl-fribidi/Makefile b/converters/pecl-fribidi/Makefile
index 5f2e2e4f8123..0e5b0f62049e 100644
--- a/converters/pecl-fribidi/Makefile
+++ b/converters/pecl-fribidi/Makefile
@@ -14,9 +14,7 @@ COMMENT= PECL extension for the Unicode Bidi algorithm
LIB_DEPENDS= libfribidi.so:converters/fribidi
-USES= pkgconfig tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext pkgconfig tar:tgz
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --with-fribidi=${LOCALBASE}
diff --git a/converters/pecl-igbinary/Makefile b/converters/pecl-igbinary/Makefile
index 3d215f05b8ac..de7f81c71e2f 100644
--- a/converters/pecl-igbinary/Makefile
+++ b/converters/pecl-igbinary/Makefile
@@ -18,10 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= does not build
IGNORE_WITH_PHP=70
-USE_PHP= session
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
-USE_PHPIZE= yes
-USES= tar:tgz
+USE_PHP= session:build
+USES= php:ext tar:tgz
.include <bsd.port.mk>
diff --git a/converters/php5-bsdconv/Makefile b/converters/php5-bsdconv/Makefile
index 305907469e52..567693f9fffd 100644
--- a/converters/php5-bsdconv/Makefile
+++ b/converters/php5-bsdconv/Makefile
@@ -17,11 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= buganini
GH_PROJECT= php-${PORTNAME}
-USE_PHP= yes
-USE_PHPEXT= yes
-USE_PHPIZE= yes
-USE_PHP_BUILD= yes
-PHP_MODNAME= ${PORTNAME}
+USES= php:ext
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --with-bsdconv=${LOCALBASE}