aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
commitf23aed7bde4b7e82cbb2943a38f6f60f51038567 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /converters
parentb3f383ce848e6d547e583f3f4ce764dd3c400cb6 (diff)
downloadports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.tar.gz
ports-f23aed7bde4b7e82cbb2943a38f6f60f51038567.zip
Import PHP 5.6 branch!
Notes
Notes: svn path=/head/; revision=367268
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile3
-rw-r--r--converters/php56-iconv/Makefile10
-rw-r--r--converters/php56-mbstring/Makefile10
-rw-r--r--converters/php56-mbstring/files/patch-config.m451
-rw-r--r--converters/php56-recode/Makefile10
5 files changed, 84 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 9370aa9aad75..ab504061d18d 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -134,6 +134,9 @@
SUBDIR += php55-iconv
SUBDIR += php55-mbstring
SUBDIR += php55-recode
+ SUBDIR += php56-iconv
+ SUBDIR += php56-mbstring
+ SUBDIR += php56-recode
SUBDIR += psiconv
SUBDIR += py-bencode
SUBDIR += py-bsdconv
diff --git a/converters/php56-iconv/Makefile b/converters/php56-iconv/Makefile
new file mode 100644
index 000000000000..8aa0617cb215
--- /dev/null
+++ b/converters/php56-iconv/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -iconv
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php56-mbstring/Makefile b/converters/php56-mbstring/Makefile
new file mode 100644
index 000000000000..4d11593b0ba6
--- /dev/null
+++ b/converters/php56-mbstring/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -mbstring
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php56-mbstring/files/patch-config.m4 b/converters/php56-mbstring/files/patch-config.m4
new file mode 100644
index 000000000000..026798f26a5a
--- /dev/null
+++ b/converters/php56-mbstring/files/patch-config.m4
@@ -0,0 +1,51 @@
+--- config.m4.orig 2009-11-25 02:30:06.000000000 +0100
++++ config.m4 2010-04-12 09:59:54.000000000 +0200
+@@ -43,6 +43,30 @@
+ PHP_ADD_INCLUDE([$ext_builddir/$dir])
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$ext_shared" = "no"; then
+ PHP_ADD_SOURCES(PHP_EXT_DIR(mbstring), $PHP_MBSTRING_BASE_SOURCES)
+ out="php_config.h"
+@@ -80,7 +104,6 @@
+ int foo(int x, ...) {
+ va_list va;
+ va_start(va, x);
+- va_arg(va, int);
+ va_arg(va, char *);
+ va_arg(va, double);
+ return 0;
+@@ -347,6 +370,9 @@
+ [ --with-onig[=DIR] MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
+ If DIR is not set, the bundled oniguruma will be used], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
++
+ if test "$PHP_MBSTRING" != "no"; then
+ AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
+
diff --git a/converters/php56-recode/Makefile b/converters/php56-recode/Makefile
new file mode 100644
index 000000000000..f3358a590ad7
--- /dev/null
+++ b/converters/php56-recode/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -recode
+
+.include "${MASTERDIR}/Makefile"