aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /converters
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'converters')
-rw-r--r--converters/enca/Makefile2
-rw-r--r--converters/fribidi/Makefile2
-rw-r--r--converters/libiconv/Makefile2
-rw-r--r--converters/mimelib/Makefile2
-rw-r--r--converters/psiconv/Makefile2
-rw-r--r--converters/recode/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/converters/enca/Makefile b/converters/enca/Makefile
index db730f987e17..e2b462f56029 100644
--- a/converters/enca/Makefile
+++ b/converters/enca/Makefile
@@ -17,7 +17,7 @@ USE_GNOME= pkgconfig
USE_ICONV= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13:inc
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
diff --git a/converters/fribidi/Makefile b/converters/fribidi/Makefile
index 7dda5d636957..8983a147c452 100644
--- a/converters/fribidi/Makefile
+++ b/converters/fribidi/Makefile
@@ -17,7 +17,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A Free Implementation of the Unicode Bidirectional Algorithm
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack pkgconfig
INSTALLS_SHLIB= yes
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 624fd55b54ef..76cbb125139e 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A character set conversion library
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget
LIBTOOLFILES= configure libcharset/configure
CONFIGURE_ARGS= --enable-static \
diff --git a/converters/mimelib/Makefile b/converters/mimelib/Makefile
index d582bbb0b054..b600cdc0d640 100644
--- a/converters/mimelib/Makefile
+++ b/converters/mimelib/Makefile
@@ -16,7 +16,7 @@ COMMENT= C++ class library for manipulating messages in MIME format
CONFLICTS= kdenetwork-3.1.*
-USE_INC_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/converters/psiconv/Makefile b/converters/psiconv/Makefile
index 7e03df219db7..d015172d62f1 100644
--- a/converters/psiconv/Makefile
+++ b/converters/psiconv/Makefile
@@ -16,7 +16,7 @@ COMMENT= A conversion utility to convert Psion 5(MX) files into other formats
USE_GETOPT_LONG=yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-imagemagick=no
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index 433b0a43a835..7a7c4eddc7e0 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Converts files between character sets and usages
USE_GETTEXT= yes
-USE_INC_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13:inc
USE_PERL5= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --without-included-gettext