aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-08 22:57:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-08 22:57:37 +0000
commit2fd906090039534cc803dfc36e555bd192119ac0 (patch)
tree14e2d58f444a0ad13a6a13c4b62b3163cd65ebac /converters
parente8f9ba53bd9fe5a7e2ba3ad59d99b19c7f5b9c2b (diff)
downloadports-2fd906090039534cc803dfc36e555bd192119ac0.tar.gz
ports-2fd906090039534cc803dfc36e555bd192119ac0.zip
Add a check for USE_ICONV, and if found, error out. This will avoid fork
bombs on systems where USE_ICONV has been incorrectly defined in make.conf or in the environment. Submittd by: trevor
Notes
Notes: svn path=/head/; revision=100427
Diffstat (limited to 'converters')
-rw-r--r--converters/libiconv/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 4a1f86e49cc4..13c6fbc9847e 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -26,6 +26,11 @@ INSTALLS_SHLIB= yes
MAN1= iconv.1
MAN3= iconv.3 iconv_open.3 iconv_close.3
+.ifdef USE_ICONV
+.error USE_ICONV is defined as an environment variable, or in the arguments \
+ to "make". Please unset it and restart the build.
+.endif
+
.if !defined(WITHOUT_EXTRA_ENCODINGS)
CONFIGURE_ARGS+= --enable-extra-encodings
.endif