aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-10-01 17:54:16 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-10-01 17:54:16 +0000
commitd477a683ffd13602daa6068a775706811f3b1bdf (patch)
tree790daf3a37446fec38abb3effc001c58a2a72983 /converters
parentff706b78a95a3f97ec67996e5c1176ba52a001e2 (diff)
downloadports-d477a683ffd13602daa6068a775706811f3b1bdf.tar.gz
ports-d477a683ffd13602daa6068a775706811f3b1bdf.zip
Import of mmencode.
mmencode is actually part of metamail, but at least one port, bgrab, requires this to run. bgrab is a console application, and metamail requires X (not good). mmencode simply converts a byte stream into (or out of) one of one of the standard encoding formats defined by MIME. PR: 14054 Submitted by: Kelly Yancey <kbyanc@posi.net>
Notes
Notes: svn path=/head/; revision=22101
Diffstat (limited to 'converters')
-rw-r--r--converters/mmencode/Makefile28
-rw-r--r--converters/mmencode/distinfo1
-rw-r--r--converters/mmencode/files/patch-aa60
-rw-r--r--converters/mmencode/files/patch-ab11
-rw-r--r--converters/mmencode/pkg-comment1
-rw-r--r--converters/mmencode/pkg-descr17
-rw-r--r--converters/mmencode/pkg-plist2
7 files changed, 120 insertions, 0 deletions
diff --git a/converters/mmencode/Makefile b/converters/mmencode/Makefile
new file mode 100644
index 000000000000..25f113d03d7c
--- /dev/null
+++ b/converters/mmencode/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: mmencode
+# Version required: 2.7
+# Date created: 30 September 1999
+# Whom: kbyanc
+#
+# $FreeBSD$
+#
+
+DISTNAME= mm2.7
+PKGNAME= mmencode-2.7
+CATEGORIES= converters
+MASTER_SITES= ftp://thumper.bellcore.com/pub/nsb/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= kbyanc@posi.net
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/metamail
+
+MAN1= mmencode.1
+
+ALL_TARGET= mmencode
+
+do-install:
+ @cd ${WRKSRC} && ${INSTALL_PROGRAM} mmencode ${PREFIX}/bin
+ @cd ${WRKSRC}/../man && ${CP} mmencode.1 ${PREFIX}/man/man1
+ @cd ${PREFIX}/bin && ${LN} -s mmencode mimencode
+
+.include <bsd.port.mk>
diff --git a/converters/mmencode/distinfo b/converters/mmencode/distinfo
new file mode 100644
index 000000000000..f3ecde59a2b2
--- /dev/null
+++ b/converters/mmencode/distinfo
@@ -0,0 +1 @@
+MD5 (mm2.7.tar.Z) = fd5617ea87e20d7f2fa839e1d1fede60
diff --git a/converters/mmencode/files/patch-aa b/converters/mmencode/files/patch-aa
new file mode 100644
index 000000000000..530d946849d1
--- /dev/null
+++ b/converters/mmencode/files/patch-aa
@@ -0,0 +1,60 @@
+--- ../man/mmencode.1.orig Thu Sep 30 10:50:02 1999
++++ ../man/mmencode.1 Thu Sep 30 10:53:37 1999
+@@ -1,44 +1,42 @@
+-.TH MIMENCODE 1 "Release 1" "Bellcore Prototype"
++.TH MMENCODE 1 "Release 1" "Bellcore Prototype"
+ .SH NAME
+-mimencode - Translate to and from mail-oriented encoding formats
++mmencode - Translate to and from mail-oriented encoding formats
+
+-(Same program also installed as "mmencode".)
++(Same program also installed as "mimencode".)
+ .SH SYNOPSIS
+ .ta 8n
+-\fBmimencode\fP [-u] [-b] [-q] [-p] [file name] [-o outputfile]
++\fBmmencode\fP [-u] [-b] [-q] [-p] [file name] [-o outputfile]
+ .br
+ .SH DESCRIPTION
+ The
+-.I mimencode
+-program simply converts a byte stream into (or out of) one of the standard mail encoding formats defined by MIME, the proposed standard for internet multimedia mail formats. Such an encoding is necessary because binary data cannot be sent through the mail. The encodings understood by mimencode are preferable to the use of the uuencode/uudecode programs, for use in mail, in several respects that were important to the authors of MIME.
++.I mmencode
++program simply converts a byte stream into (or out of) one of the standard mail encoding formats defined by MIME, the proposed standard for internet multimedia mail formats. Such an encoding is necessary because binary data cannot be sent through the mail. The encodings understood by mmencode are preferable to the use of the uuencode/uudecode programs, for use in mail, in several respects that were important to the authors of MIME.
+
+-By default, mimencode reads standard input, and sends a "base64" encoded version of the input to standard output.
++By default, mmencode reads standard input, and sends a "base64" encoded version of the input to standard output.
+
+-The (really not necessary) "-b" option tells mimencode to use the "base64" encoding.
++The (really not necessary) "-b" option tells mmencode to use the "base64" encoding.
+
+-The "-q" option tells mimencode to use the "quoted-printable" encoding instead of base64.
++The "-q" option tells mmencode to use the "quoted-printable" encoding instead of base64.
+
+-The "-u" option tells mimencode to
++The "-u" option tells mmencode to
+ .I
+ decode
+ the standard input rather than encode it.
+
+-The "-p" option tells mimencode to translate decoded CRLF sequences into the local newline convention during decoding and to do the reverse during encoding. This option is only meaningful when -b (base64 encoding) is in effect.
++The "-p" option tells mmencode to translate decoded CRLF sequences into the local newline convention during decoding and to do the reverse during encoding. This option is only meaningful when -b (base64 encoding) is in effect.
+
+ If a file name argument is given, input is read from that file rather than from standard input.
+
+ The "-o" option, which must be followed by a file name, sends output to the named file rather than to standard output.
+ .SH RATIONALE
+ .I
+-Mimencode
++Mmencode
+ is intended to be a replacement for
+ .I
+ uuencode
+-for mail and news use. The reason is simple: uuencode doesn't work very well in a number of circumstances and ways. In particular, uuencode uses characters that don't translate well across all mail gateways (particularly ASCII <-> EBCDIC gateways). Also, uuencode is not standard -- there are several variants floating around, encoding and decoding things in different and incompatible ways, with no "standard" on which to base an implementation. Finally, uuencode does not generally work well in a pipe, although some variants have been modified to do so. Mimencode implements the encodings which were defined for MIME as uuencode replacements, and should be considerably more robust for email use.
++for mail and news use. The reason is simple: uuencode doesn't work very well in a number of circumstances and ways. In particular, uuencode uses characters that don't translate well across all mail gateways (particularly ASCII <-> EBCDIC gateways). Also, uuencode is not standard -- there are several variants floating around, encoding and decoding things in different and incompatible ways, with no "standard" on which to base an implementation. Finally, uuencode does not generally work well in a pipe, although some variants have been modified to do so. Mmencode implements the encodings which were defined for MIME as uuencode replacements, and should be considerably more robust for email use.
+ .SH SEE ALSO
+ metamail(1), mailto(1)
+-.SH BUGS
+-This program was originally distributed as "mmencode". That name turns out to conflict with a program of the same name that is part of the Slate software from BBN, but totally changing the name to mimencode would create other problems (notably with portability to systems where the left half of file names is limited to 8 characters). Currently, it is being distributed with links under BOTH names. The programs in the distribution that call the program all call it as "mimencode", so the "mmencode" version may be deleted at sites where it causes a problem. (The source files are still named "mmencode" rather than "mimencode".)
+ .SH COPYRIGHT
+ Copyright (c) 1991 Bell Communications Research, Inc. (Bellcore)
+
diff --git a/converters/mmencode/files/patch-ab b/converters/mmencode/files/patch-ab
new file mode 100644
index 000000000000..5507abf91392
--- /dev/null
+++ b/converters/mmencode/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.orig Fri Oct 1 10:30:36 1999
++++ Makefile Fri Oct 1 10:30:42 1999
+@@ -15,7 +15,7 @@
+
+ STATICFLAG=FOOBAR${HOST_ARCH}
+
+-CFLAGS = -g -I. ${$(STATICFLAG)}
++CFLAGS += -g -I. ${$(STATICFLAG)}
+
+ LDLIBS =
+
diff --git a/converters/mmencode/pkg-comment b/converters/mmencode/pkg-comment
new file mode 100644
index 000000000000..b80de6f2a2a6
--- /dev/null
+++ b/converters/mmencode/pkg-comment
@@ -0,0 +1 @@
+Translate to and from mail-oriented encoding formats
diff --git a/converters/mmencode/pkg-descr b/converters/mmencode/pkg-descr
new file mode 100644
index 000000000000..7a627d641a68
--- /dev/null
+++ b/converters/mmencode/pkg-descr
@@ -0,0 +1,17 @@
+From the man page:
+
+ The mimencode program simply converts a byte stream into (or out of) one of
+ the standard mail encoding formats defined by MIME, the proposed standard
+ for internet multimedia mail formats. Such an encoding is necessary
+ because binary data cannot be sent through the mail. The encodings under-
+ stood by mimencode are preferable to the use of the uuencode/uudecode pro-
+ grams, for use in mail, in several respects that were important to the
+ authors of MIME.
+
+Mmencode is part of metamail, and can be installed as part of that package.
+It is provided here as an independent package since some programs require
+mmencode only and hence you can avoid having to install the entire metalmail
+package when not required.
+
+ -Kelly
+ ~kbyanc@posi.net~
diff --git a/converters/mmencode/pkg-plist b/converters/mmencode/pkg-plist
new file mode 100644
index 000000000000..0ee15cce241c
--- /dev/null
+++ b/converters/mmencode/pkg-plist
@@ -0,0 +1,2 @@
+bin/mmencode
+bin/mimencode