aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-30 17:37:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-30 17:37:26 +0000
commit296c381b708db53914e30f5ccffd28ba78cab7c3 (patch)
tree583d39de248fd302aded30a75698150f5314077e /converters
parenta05795c77e91d0f296555645e9540110142ec95a (diff)
downloadports-296c381b708db53914e30f5ccffd28ba78cab7c3.tar.gz
ports-296c381b708db53914e30f5ccffd28ba78cab7c3.zip
add utf8conv
Convert hexadecimal Unicode character values to UTF-8
Notes
Notes: svn path=/head/; revision=45633
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/utf8conv/Makefile26
-rw-r--r--converters/utf8conv/distinfo1
-rw-r--r--converters/utf8conv/pkg-comment1
-rw-r--r--converters/utf8conv/pkg-descr1
-rw-r--r--converters/utf8conv/pkg-plist1
6 files changed, 31 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 37666e3e42f5..ec51868e4a5c 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -43,6 +43,7 @@
SUBDIR += trans
SUBDIR += tuc
SUBDIR += unix2dos
+ SUBDIR += utf8conv
SUBDIR += uudeview
SUBDIR += uudx
SUBDIR += uulib
diff --git a/converters/utf8conv/Makefile b/converters/utf8conv/Makefile
new file mode 100644
index 000000000000..2ba322dc17bb
--- /dev/null
+++ b/converters/utf8conv/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: utf8conv
+# Date created: Jul 30, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= utf8conv
+PORTVERSION= 1.0.1
+CATEGORIES= converters
+MASTER_SITES= http://www.fibrespeed.net/~mbabcock/code/
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0
+ALL_TARGET= ${PORTNAME}
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; \
+ s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/utf8conv ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/converters/utf8conv/distinfo b/converters/utf8conv/distinfo
new file mode 100644
index 000000000000..83e048826643
--- /dev/null
+++ b/converters/utf8conv/distinfo
@@ -0,0 +1 @@
+MD5 (utf8conv-1.0.1.tar.gz) = 1687031b756ab14d00c722dffac15abd
diff --git a/converters/utf8conv/pkg-comment b/converters/utf8conv/pkg-comment
new file mode 100644
index 000000000000..9d7230382852
--- /dev/null
+++ b/converters/utf8conv/pkg-comment
@@ -0,0 +1 @@
+Convert hexadecimal Unicode character values to UTF-8
diff --git a/converters/utf8conv/pkg-descr b/converters/utf8conv/pkg-descr
new file mode 100644
index 000000000000..9d7230382852
--- /dev/null
+++ b/converters/utf8conv/pkg-descr
@@ -0,0 +1 @@
+Convert hexadecimal Unicode character values to UTF-8
diff --git a/converters/utf8conv/pkg-plist b/converters/utf8conv/pkg-plist
new file mode 100644
index 000000000000..c2773029fad0
--- /dev/null
+++ b/converters/utf8conv/pkg-plist
@@ -0,0 +1 @@
+bin/utf8conv