aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2010-12-10 00:39:46 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2010-12-10 00:39:46 +0000
commit6eb04215e4476ab82414f76a0196afa10f507433 (patch)
treea9fa5ffee0ae78696661c8a94eb5b7360a63db28 /converters
parent59e3db8519e6282628adf177bcf36620b089dc2f (diff)
downloadports-6eb04215e4476ab82414f76a0196afa10f507433.tar.gz
ports-6eb04215e4476ab82414f76a0196afa10f507433.zip
A new port p5-Unicode-Stringprep is added:
Unicode::Normalize - Unicode Normalization Forms
Notes
Notes: svn path=/head/; revision=265952
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-Unicode-Stringprep/Makefile26
-rw-r--r--converters/p5-Unicode-Stringprep/distinfo2
-rw-r--r--converters/p5-Unicode-Stringprep/pkg-descr12
-rw-r--r--converters/p5-Unicode-Stringprep/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index e453d0a98ed0..7c28e32a82dc 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -98,6 +98,7 @@
SUBDIR += p5-Unicode-MapUTF8
SUBDIR += p5-Unicode-RecursiveDowngrade
SUBDIR += p5-Unicode-String
+ SUBDIR += p5-Unicode-Stringprep
SUBDIR += p5-Unicode-UTF8simple
SUBDIR += p5-WAP-wbxml
SUBDIR += p5-XML-WBXML
diff --git a/converters/p5-Unicode-Stringprep/Makefile b/converters/p5-Unicode-Stringprep/Makefile
new file mode 100644
index 000000000000..b599c3141872
--- /dev/null
+++ b/converters/p5-Unicode-Stringprep/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Unicode-Stringprep
+# Date created: 10 Dec 2010
+# Whom: Timur Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Unicode-Stringprep
+PORTVERSION= 1.103
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Preparation of Internationalized Strings (RFC 3454)
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/Normalize.pm:${PORTSDIR}/textproc/p5-Unicode-Normalize
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Unicode::Stringprep.3 Unicode::Stringprep::_Common.3 \
+ Unicode::Stringprep::Prohibited.3 Unicode::Stringprep::Unassigned.3 \
+ Unicode::Stringprep::Mapping.3 Unicode::Stringprep::BiDi.3
+
+.include <bsd.port.mk>
diff --git a/converters/p5-Unicode-Stringprep/distinfo b/converters/p5-Unicode-Stringprep/distinfo
new file mode 100644
index 000000000000..94f6552d0e95
--- /dev/null
+++ b/converters/p5-Unicode-Stringprep/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Unicode-Stringprep-1.103.tar.gz) = e583bec0a5272e7294b250557da905368bed2137078a1b749ea7fa52c995aadd
+SIZE (Unicode-Stringprep-1.103.tar.gz) = 47337
diff --git a/converters/p5-Unicode-Stringprep/pkg-descr b/converters/p5-Unicode-Stringprep/pkg-descr
new file mode 100644
index 000000000000..7dcb0c4cddc7
--- /dev/null
+++ b/converters/p5-Unicode-Stringprep/pkg-descr
@@ -0,0 +1,12 @@
+This module implements the stringprep framework for preparing
+Unicode text strings in order to increase the likelihood that
+for typical users throughout the world. The stringprep protocol
+is useful for protocol identifier values, company and personal
+names, internationalized domain names, and other text strings.
+string input and string comparison work in ways that make sense
+
+The stringprep framework does not specify how protocols should
+prepare text strings. Protocols must create profiles of
+stringprep in order to fully specify the processing options.
+
+WWW: http://search.cpan.org/dist/Unicode-Stringprep/
diff --git a/converters/p5-Unicode-Stringprep/pkg-plist b/converters/p5-Unicode-Stringprep/pkg-plist
new file mode 100644
index 000000000000..da26601f8dcd
--- /dev/null
+++ b/converters/p5-Unicode-Stringprep/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Unicode/Stringprep.pm
+%%SITE_PERL%%/Unicode/Stringprep/BiDi.pm
+%%SITE_PERL%%/Unicode/Stringprep/Mapping.pm
+%%SITE_PERL%%/Unicode/Stringprep/Prohibited.pm
+%%SITE_PERL%%/Unicode/Stringprep/Unassigned.pm
+%%SITE_PERL%%/Unicode/Stringprep/_Common.pm
+@dirrm %%SITE_PERL%%/Unicode/Stringprep
+@dirrmtry %%SITE_PERL%%/Unicode