aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-05-05 17:15:30 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-05-05 17:15:30 +0000
commit6ee38b0568978e3465ada58b60dc1e9d372e1573 (patch)
tree7d925f810f1f6b53e60f4b23faac4f2f8b168d78 /converters
parentf5c14e590c1ad2f5bb4a1e9f80340f3ccecc9097 (diff)
downloadports-6ee38b0568978e3465ada58b60dc1e9d372e1573.tar.gz
ports-6ee38b0568978e3465ada58b60dc1e9d372e1573.zip
PR: ports/9866
Submitted by: obonilla@mailhub.fisicc-ufm.edu translate ASCII files from DOS (cr/lf) to UNIX (lf)
Notes
Notes: svn path=/head/; revision=18514
Diffstat (limited to 'converters')
-rw-r--r--converters/unix2dos/Makefile24
-rw-r--r--converters/unix2dos/distinfo1
-rw-r--r--converters/unix2dos/pkg-comment1
-rw-r--r--converters/unix2dos/pkg-descr6
-rw-r--r--converters/unix2dos/pkg-plist2
5 files changed, 34 insertions, 0 deletions
diff --git a/converters/unix2dos/Makefile b/converters/unix2dos/Makefile
new file mode 100644
index 000000000000..82f9fe2e20f2
--- /dev/null
+++ b/converters/unix2dos/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: unix2dos
+# Version required: 1.0
+# Date created: 1 February 1999
+# Whom: obonilla@fisicc-ufm.edu
+#
+# $Id$
+#
+
+DISTNAME= unix2dos-1.0
+CATEGORIES= converters
+MASTER_SITES= http://www.fisicc-ufm.edu/~obonilla/files/
+
+MAINTAINER= obonilla@fisicc-ufm.edu
+
+MAN1= unix2dos.1 dos2unix.1
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/unix2dos ${PREFIX}/bin/unix2dos
+ ${INSTALL_PROGRAM} ${WRKDIR}/dos2unix ${PREFIX}/bin/dos2unix
+ ${INSTALL_MAN} ${WRKDIR}/man1/unix2dos.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/man1/dos2unix.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/converters/unix2dos/distinfo b/converters/unix2dos/distinfo
new file mode 100644
index 000000000000..686c779a9430
--- /dev/null
+++ b/converters/unix2dos/distinfo
@@ -0,0 +1 @@
+MD5 (unix2dos-1.0.tar.gz) = b550c0dae307eb301f6e9a1cc0e3e503
diff --git a/converters/unix2dos/pkg-comment b/converters/unix2dos/pkg-comment
new file mode 100644
index 000000000000..6a798cf6dcf6
--- /dev/null
+++ b/converters/unix2dos/pkg-comment
@@ -0,0 +1 @@
+translate ASCII files from DOS (cr/lf) to UNIX (lf)
diff --git a/converters/unix2dos/pkg-descr b/converters/unix2dos/pkg-descr
new file mode 100644
index 000000000000..77ea11b85505
--- /dev/null
+++ b/converters/unix2dos/pkg-descr
@@ -0,0 +1,6 @@
+unix2dos and dos2unix are utilities that convert
+ASCII files from the DOS cr/lf format to the UNIX
+lf format
+
+-Oscar Bonilla
+obonilla@fisicc-ufm.edu
diff --git a/converters/unix2dos/pkg-plist b/converters/unix2dos/pkg-plist
new file mode 100644
index 000000000000..ed50e68230c3
--- /dev/null
+++ b/converters/unix2dos/pkg-plist
@@ -0,0 +1,2 @@
+bin/unix2dos
+bin/dos2unix