aboutsummaryrefslogtreecommitdiff
path: root/databases/Makefile
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2010-11-21 11:52:42 +0000
committerAndrej Zverev <az@FreeBSD.org>2010-11-21 11:52:42 +0000
commit90fa387e9a76718a5e2d5f75fefac129dde78965 (patch)
treeeaf1960d76a51187402efae7e2393fb80d19a41d /databases/Makefile
parentfe2d21704cd7f92e6d7267cb7f7c86765bdf0da6 (diff)
downloadports-90fa387e9a76718a5e2d5f75fefac129dde78965.tar.gz
ports-90fa387e9a76718a5e2d5f75fefac129dde78965.zip
This module allows you to put the arguments to "add_column" in
DBIx::Class::ResultSource right into your attribute definitions and will automatically call it when it finds an add_column attribute option. It also replaces the DBIx::Class-generated accessor methods (these are Class::Accessor::Grouped-generated accessor methods under the hood) with the Moose-generated accessor methods so that you can use more of the wonderful powers of Moose (eg. type constraints, triggers, ...).
Notes
Notes: svn path=/head/; revision=264865
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7148a4a97638..3d1bcec0b833 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -342,6 +342,7 @@
SUBDIR += p5-DBIx-Class-InflateColumn-IP
SUBDIR += p5-DBIx-Class-IntrospectableM2M
SUBDIR += p5-DBIx-Class-Loader
+ SUBDIR += p5-DBIx-Class-MooseColumns
SUBDIR += p5-DBIx-Class-QueryLog
SUBDIR += p5-DBIx-Class-QueryProfiler
SUBDIR += p5-DBIx-Class-ResultSet-HashRef