aboutsummaryrefslogtreecommitdiff
path: root/databases/couchdb/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-08-18 00:08:12 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-08-18 00:08:12 +0000
commit9683442a4f5dc9179d8244a416e1f840a3f2a3eb (patch)
treefe7858b2e0dba0d064035e1386ce425ebb19c0b0 /databases/couchdb/Makefile
parent5200de3ae3a649c68707195ed41e981bfdcd4ec8 (diff)
downloadports-9683442a4f5dc9179d8244a416e1f840a3f2a3eb.tar.gz
ports-9683442a4f5dc9179d8244a416e1f840a3f2a3eb.zip
[1]: Update to 1.0.0
[2]: Fix bug in RC script [3]: Add pre-fetch message about possibly needing to rebuild the views PR: [1]: ports/148803 [2]: ports/149028 [3]: ports/149030 Submitted by: [1]: Tomas Sedovic <tomas@sedovic.cz> [2]: Till Klampaeckel <till@php.net> (maintainer) [3]: Till Klampaeckel <till@php.net> (maintainer) Approved by: [1]: Till Klampaeckel <till@php.net> (maintainer)
Notes
Notes: svn path=/head/; revision=259457
Diffstat (limited to 'databases/couchdb/Makefile')
-rw-r--r--databases/couchdb/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
index 647c974432f9..535fbb0efa5f 100644
--- a/databases/couchdb/Makefile
+++ b/databases/couchdb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= couchdb
-PORTVERSION= 0.10.1
-PORTREVISION= 1
+PORTVERSION= 1.0.0
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_APACHE}
@@ -26,6 +25,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
COUCH_VARDIR?= /var
COUCH_DBDIR?= ${COUCH_VARDIR}/db/couchdb
COUCH_LOGDIR?= ${COUCH_VARDIR}/log/couchdb
+COUCH_LIBDIR?= ${COUCH_VARDIR}/lib/couchdb
COUCH_USER?= couchdb
USE_RC_SUBR= couchdb
@@ -44,10 +44,11 @@ MAN1= couchdb.1 couchjs.1
pre-fetch:
@${ECHO_MSG} ""
@${ECHO_MSG} "If you are upgrading CouchDB, please double-check that the datafile is compatible."
+ @${ECHO_MSG} "Upgrading also might require you to rebuild your views entirely."
@${ECHO_MSG} ""
post-patch:
- ${REINPLACE_CMD} -e '117s|@INSTALL_PROGRAM@|@INSTALL_SCRIPT@|' ${WRKSRC}/src/couchdb/priv/Makefile.in
+ ${REINPLACE_CMD} -e '169s|@INSTALL_PROGRAM@|@INSTALL_SCRIPT@|' ${WRKSRC}/src/couchdb/priv/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's/install-data-am$$//' ${WRKSRC}/Makefile.in
.endif
@@ -60,5 +61,6 @@ post-install:
${MKDIR} ${COUCH_DBDIR}
${CHOWN} ${COUCH_USER} ${COUCH_DBDIR}
${CHOWN} ${COUCH_USER} ${COUCH_LOGDIR}
+ ${CHOWN} ${COUCH_USER} ${COUCH_LIBDIR}
.include <bsd.port.mk>