aboutsummaryrefslogtreecommitdiff
path: root/databases/db47
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-12-05 03:03:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-12-05 03:03:15 +0000
commitbd4698ebe279cb66842f7afe56268083cbba3d9a (patch)
tree26b82462bb2c3a6f5762a78c63e96870f28829ae /databases/db47
parent7aedc5ee6d75dd279042310c5190d7cae413cc57 (diff)
downloadports-bd4698ebe279cb66842f7afe56268083cbba3d9a.tar.gz
ports-bd4698ebe279cb66842f7afe56268083cbba3d9a.zip
- repocopied from databases/db42 (via portmgr)
- Description as follows Version 4.3 of the Berkeley Data Base library which offers (key/value) storage with optional concurrent access or transactions interface. Utilities are included in the distribution to convert v1.85 databases to v4.3 databases, and a backwards compatible API is provided to maintain compatibility with programs using the v1.85 interface. For details on compatibility with other DB versions, see: http://www.sleepycat.com/download/patchlogs.shtml PR: ports/73790 Submitted by: Matthias Andree <matthias dot andree at gmx dot de>
Notes
Notes: svn path=/head/; revision=123162
Diffstat (limited to 'databases/db47')
-rw-r--r--databases/db47/Makefile13
-rw-r--r--databases/db47/Makefile.db5
-rw-r--r--databases/db47/distinfo8
-rw-r--r--databases/db47/files/patch-dist::configure4
-rw-r--r--databases/db47/pkg-descr7
-rw-r--r--databases/db47/pkg-plist96
6 files changed, 61 insertions, 72 deletions
diff --git a/databases/db47/Makefile b/databases/db47/Makefile
index 58cf0978ff5b..9effbba5707d 100644
--- a/databases/db47/Makefile
+++ b/databases/db47/Makefile
@@ -1,20 +1,17 @@
-# ports collection makefile for: Berkeley DB v4.2
-# Date created: 2003-11-26
+# ports collection makefile for: Berkeley DB v4.3
+# Date created: 2004-11-10
# Whom: Matthias Andree <matthias.andree@gmx.de>
#
# $FreeBSD$
#
-PORTNAME= db42
-PORTVERSION= 4.2.52
-PORTREVISION= 3
+PORTNAME= db43
+PORTVERSION= 4.3.21
CATEGORIES= databases
PKGNAMESUFFIX?=
-PATCHFILES= patch.${PORTVERSION}.1 patch.${PORTVERSION}.2
-
MAINTAINER= matthias.andree@gmx.de
-COMMENT= The Berkeley DB package, revision 4.2
+COMMENT= The Berkeley DB package, revision 4.3
MASTERDIR?= ${.CURDIR}
diff --git a/databases/db47/Makefile.db b/databases/db47/Makefile.db
index 5d60152179e4..ed169e664a96 100644
--- a/databases/db47/Makefile.db
+++ b/databases/db47/Makefile.db
@@ -19,7 +19,6 @@ BDBDIR= BerkeleyDB.${BDBVER}
CONFIGURE_ARGS= --enable-compat185 --enable-dump185 \
--enable-cxx --enable-dynamic \
--enable-rpc \
- --with-uniquename \
--includedir=${PREFIX}/include/${PORTNAME} \
--libdir=${PREFIX}/lib/${PORTNAME} \
--bindir=${PREFIX}/bin/${PORTNAME}
@@ -37,8 +36,8 @@ pre-configure:
post-install:
.for i in libdb libdb_cxx
- ${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.${BDBMINOR} ${PREFIX}/lib
- ${LN} -s -f ${i}-${BDBVER}.so.${BDBMINOR} ${PREFIX}/lib/${i}-${BDBVER}.so
+ ${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.0 ${PREFIX}/lib
+ ${LN} -s -f ${i}-${BDBVER}.so.0 ${PREFIX}/lib/${i}-${BDBVER}.so
.endfor
.if !defined(NOPORTDOCS)
@${RMDIR} ${DOCSDIR}/ref/splash 2>/dev/null || :
diff --git a/databases/db47/distinfo b/databases/db47/distinfo
index 5c40c56586f7..7f8d401bbd5d 100644
--- a/databases/db47/distinfo
+++ b/databases/db47/distinfo
@@ -1,6 +1,2 @@
-MD5 (bdb/db-4.2.52.tar.gz) = cbc77517c9278cdb47613ce8cb55779f
-SIZE (bdb/db-4.2.52.tar.gz) = 4073147
-MD5 (bdb/patch.4.2.52.1) = 1227f5f9ff43d48b5b1759e113a1c2d7
-SIZE (bdb/patch.4.2.52.1) = 988
-MD5 (bdb/patch.4.2.52.2) = 3da7efd8d29919a9113e2f6f5166f5b7
-SIZE (bdb/patch.4.2.52.2) = 1433
+MD5 (bdb/db-4.3.21.tar.gz) = 014950aaadd531f6f9064c81a2018423
+SIZE (bdb/db-4.3.21.tar.gz) = 5916550
diff --git a/databases/db47/files/patch-dist::configure b/databases/db47/files/patch-dist::configure
index f5fd795067be..c048a06fe8f3 100644
--- a/databases/db47/files/patch-dist::configure
+++ b/databases/db47/files/patch-dist::configure
@@ -5,11 +5,11 @@
MAKEFILE_CC="\$(LIBTOOL) --mode=compile ${MAKEFILE_CC}"
-MAKEFILE_SOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} -avoid-version"
-+MAKEFILE_SOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} -version-info ${DB_VERSION_MINOR}"
++MAKEFILE_SOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} -version-info 0:0:0"
MAKEFILE_CCLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK}"
MAKEFILE_CXX="\$(LIBTOOL) --mode=compile ${MAKEFILE_CXX}"
-MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -avoid-version"
-+MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -version-info ${DB_VERSION_MINOR}"
++MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -version-info 0:0:0"
MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK}"
# Configure for shared libraries, static libraries, or both. If both are
diff --git a/databases/db47/pkg-descr b/databases/db47/pkg-descr
index 9bc7ada3c509..c99b54437029 100644
--- a/databases/db47/pkg-descr
+++ b/databases/db47/pkg-descr
@@ -1,13 +1,10 @@
-Version 4.2 of the Berkeley Data Base library which offers (key/value) storage
+Version 4.3 of the Berkeley Data Base library which offers (key/value) storage
with optional concurrent access or transactions interface.
-Utilities are included in the distribution to convert v1.85 databases to v4.2
+Utilities are included in the distribution to convert v1.85 databases to v4.3
databases, and a backwards compatible API is provided to maintain
compatibility with programs using the v1.85 interface.
-Note that this port has a different layout than the 3.3, 4.0 and 4.1 ports,
-it does not rename libraries.
-
For details on compatibility with other DB versions, see:
http://www.sleepycat.com/download/patchlogs.shtml
diff --git a/databases/db47/pkg-plist b/databases/db47/pkg-plist
index d52927a1e023..8d51f88a0b49 100644
--- a/databases/db47/pkg-plist
+++ b/databases/db47/pkg-plist
@@ -1,48 +1,48 @@
-bin/db42/berkeley_db_svc
-bin/db42/db_archive
-bin/db42/db_checkpoint
-bin/db42/db_deadlock
-bin/db42/db_dump
-bin/db42/db_dump185
-bin/db42/db_load
-bin/db42/db_printlog
-bin/db42/db_recover
-bin/db42/db_stat
-bin/db42/db_upgrade
-bin/db42/db_verify
-bin/berkeley_db_svc-4.2
-bin/db_archive-4.2
-bin/db_checkpoint-4.2
-bin/db_deadlock-4.2
-bin/db_dump-4.2
-bin/db_dump185-4.2
-bin/db_load-4.2
-bin/db_printlog-4.2
-bin/db_recover-4.2
-bin/db_stat-4.2
-bin/db_upgrade-4.2
-bin/db_verify-4.2
-include/db42/db.h
-include/db42/db_185.h
-include/db42/db_cxx.h
-lib/db42/libdb-4.2.a
-lib/db42/libdb-4.2.la
-lib/db42/libdb-4.2.so
-lib/db42/libdb-4.2.so.2
-lib/db42/libdb-4.so
-lib/db42/libdb.a
-lib/db42/libdb.so
-lib/db42/libdb_cxx-4.2.a
-lib/db42/libdb_cxx-4.2.la
-lib/db42/libdb_cxx-4.2.so
-lib/db42/libdb_cxx-4.2.so.2
-lib/db42/libdb_cxx-4.so
-lib/db42/libdb_cxx.a
-lib/db42/libdb_cxx.so
-lib/libdb-4.2.so
-lib/libdb-4.2.so.2
-lib/libdb_cxx-4.2.so
-lib/libdb_cxx-4.2.so.2
-@dirrm lib/db42
-@dirrm include/db42
-@dirrm bin/db42
+bin/db43/berkeley_db_svc
+bin/db43/db_archive
+bin/db43/db_checkpoint
+bin/db43/db_deadlock
+bin/db43/db_dump
+bin/db43/db_dump185
+bin/db43/db_load
+bin/db43/db_printlog
+bin/db43/db_recover
+bin/db43/db_stat
+bin/db43/db_upgrade
+bin/db43/db_verify
+bin/berkeley_db_svc-4.3
+bin/db_archive-4.3
+bin/db_checkpoint-4.3
+bin/db_deadlock-4.3
+bin/db_dump-4.3
+bin/db_dump185-4.3
+bin/db_load-4.3
+bin/db_printlog-4.3
+bin/db_recover-4.3
+bin/db_stat-4.3
+bin/db_upgrade-4.3
+bin/db_verify-4.3
+include/db43/db.h
+include/db43/db_185.h
+include/db43/db_cxx.h
+lib/db43/libdb-4.3.a
+lib/db43/libdb-4.3.la
+lib/db43/libdb-4.3.so
+lib/db43/libdb-4.3.so.0
+lib/db43/libdb-4.so
+lib/db43/libdb.a
+lib/db43/libdb.so
+lib/db43/libdb_cxx-4.3.a
+lib/db43/libdb_cxx-4.3.la
+lib/db43/libdb_cxx-4.3.so
+lib/db43/libdb_cxx-4.3.so.0
+lib/db43/libdb_cxx-4.so
+lib/db43/libdb_cxx.a
+lib/db43/libdb_cxx.so
+lib/libdb-4.3.so
+lib/libdb-4.3.so.0
+lib/libdb_cxx-4.3.so
+lib/libdb_cxx-4.3.so.0
+@dirrm lib/db43
+@dirrm include/db43
+@dirrm bin/db43