aboutsummaryrefslogtreecommitdiff
path: root/databases/evolution-data-server/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /databases/evolution-data-server/files
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Notes
Notes: svn path=/head/; revision=130972
Diffstat (limited to 'databases/evolution-data-server/files')
-rw-r--r--databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c52
-rw-r--r--databases/evolution-data-server/files/patch-calendar_libical_configure11
-rw-r--r--databases/evolution-data-server/files/patch-camel_Makefile.in11
-rw-r--r--databases/evolution-data-server/files/patch-camel_camel-net-utils.c24
-rw-r--r--databases/evolution-data-server/files/patch-configure38
-rw-r--r--databases/evolution-data-server/files/patch-libedataserverui_e-source-option-menu.c11
-rw-r--r--databases/evolution-data-server/files/patch-servers_groupwise_e-gw-connection.c12
-rw-r--r--databases/evolution-data-server/files/patch-servers_groupwise_e-gw-item.c22
8 files changed, 177 insertions, 4 deletions
diff --git a/databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c b/databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c
new file mode 100644
index 000000000000..7383f939f4cd
--- /dev/null
+++ b/databases/evolution-data-server/files/extra-patch-libedataserver_e-msgport.c
@@ -0,0 +1,52 @@
+--- libedataserver/e-msgport.c.orig Thu Dec 2 22:33:06 2004
++++ libedataserver/e-msgport.c Wed Mar 9 14:31:46 2005
+@@ -921,9 +921,18 @@
+ void e_thread_put(EThread *e, EMsg *msg)
+ {
+ pthread_t id;
++ pthread_attr_t attr;
+ EMsg *dmsg = NULL;
+
+ pthread_mutex_lock(&e->mutex);
++ pthread_attr_init(&attr);
++ /* Give us a 1 MB thread stacksize on 32-bit architectures, and
++ * a 2 MB thread stacksize on 64-bit architectures. */
++ if (sizeof (void *) == 8) {
++ pthread_attr_setstacksize(&attr, 0x200000);
++ } else {
++ pthread_attr_setstacksize(&attr, 0x100000);
++ }
+
+ /* the caller forgot to tell us what to do, well, we can't do anything can we */
+ if (e->received == NULL) {
+@@ -962,13 +971,14 @@
+ e_msgport_put(e->server_port, msg);
+ if (e->waiting == 0
+ && g_list_length(e->id_list) < e->queue_limit
+- && pthread_create(&id, NULL, thread_dispatch, e) == 0) {
++ && pthread_create(&id, &attr, thread_dispatch, e) == 0) {
+ struct _thread_info *info = g_malloc0(sizeof(*info));
+ t(printf("created NEW thread %ld\n", id));
+ info->id = id;
+ info->busy = TRUE;
+ e->id_list = g_list_append(e->id_list, info);
+ }
++ pthread_attr_destroy(&attr);
+ pthread_mutex_unlock(&e->mutex);
+ return;
+ }
+@@ -977,12 +987,13 @@
+ if (e->id == E_THREAD_NONE) {
+ int err;
+
+- if ((err = pthread_create(&e->id, NULL, thread_dispatch, e)) != 0) {
++ if ((err = pthread_create(&e->id, &attr, thread_dispatch, e)) != 0) {
+ g_warning("Could not create dispatcher thread, message queued?: %s", strerror(err));
+ e->id = E_THREAD_NONE;
+ }
+ }
+
++ pthread_attr_destroy(&attr);
+ pthread_mutex_unlock(&e->mutex);
+
+ if (dmsg) {
diff --git a/databases/evolution-data-server/files/patch-calendar_libical_configure b/databases/evolution-data-server/files/patch-calendar_libical_configure
new file mode 100644
index 000000000000..19028e5d49fc
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-calendar_libical_configure
@@ -0,0 +1,11 @@
+--- calendar/libical/configure.orig Sun Dec 26 16:54:57 2004
++++ calendar/libical/configure Sun Dec 26 16:55:23 2004
+@@ -19736,7 +19736,7 @@
+
+
+
+-if test "x$USE_MAINTAINER_MODE" == xyes; then
++if test "x$USE_MAINTAINER_MODE" = xyes; then
+ DEV="yes"
+ echo "$as_me:$LINENO: result: Setting up for development: -Wall, flex, bison" >&5
+ echo "${ECHO_T}Setting up for development: -Wall, flex, bison" >&6
diff --git a/databases/evolution-data-server/files/patch-camel_Makefile.in b/databases/evolution-data-server/files/patch-camel_Makefile.in
new file mode 100644
index 000000000000..dfd4f33f61e2
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-camel_Makefile.in
@@ -0,0 +1,11 @@
+--- camel/Makefile.in.orig Tue Dec 21 13:46:00 2004
++++ camel/Makefile.in Tue Dec 21 13:46:01 2004
+@@ -299,7 +299,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+
+-SUBDIRS = . providers tests
++SUBDIRS = . providers
+
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_in_files = camel.pc.in camel-provider.pc.in
diff --git a/databases/evolution-data-server/files/patch-camel_camel-net-utils.c b/databases/evolution-data-server/files/patch-camel_camel-net-utils.c
new file mode 100644
index 000000000000..17bddca39e31
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-camel_camel-net-utils.c
@@ -0,0 +1,24 @@
+--- camel/camel-net-utils.c.orig Tue Dec 21 13:38:52 2004
++++ camel/camel-net-utils.c Tue Dec 21 13:40:34 2004
+@@ -143,12 +143,21 @@
+ case EAI_SERVICE:
+ return NO_DATA;
+ break;
++#ifdef EAI_ADDRFAMILY
+ case EAI_ADDRFAMILY:
+ return NO_ADDRESS;
+ break;
++#endif
++#if defined(EAI_NODATA) && EAI_NODATA != EAI_NONAME
+ case EAI_NODATA:
+ return NO_DATA;
+ break;
++#endif
++#ifdef EAI_NOFAMILY
++ case EAI_NOFAMILY:
++ return NO_ADDRESS;
++ break;
++#endif
+ case EAI_MEMORY:
+ return ENOMEM;
+ break;
diff --git a/databases/evolution-data-server/files/patch-configure b/databases/evolution-data-server/files/patch-configure
index 4959297daf85..7bc7a9cdfb65 100644
--- a/databases/evolution-data-server/files/patch-configure
+++ b/databases/evolution-data-server/files/patch-configure
@@ -1,6 +1,36 @@
---- configure.orig Thu Jan 29 16:02:10 2004
-+++ configure Thu Jan 29 16:02:39 2004
-@@ -23783,7 +23783,7 @@
+--- configure.orig Tue Dec 21 13:46:01 2004
++++ configure Tue Dec 21 13:50:02 2004
+@@ -7894,10 +7894,10 @@
+ Example: --with-nspr-libs=/usr/lib" >&2;}
+ { (exit 1); exit 1; }; }
+ else
+- nsprlibs="-ldl $with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
++ nsprlibs="$with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
+ fi
+ else
+- nsprlibs="-ldl -lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
++ nsprlibs="-lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
+ fi
+
+ echo "$as_me:$LINENO: checking for Mozilla nspr libraries" >&5
+@@ -10011,6 +10011,7 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
++ #include <stdio.h>
+
+
+ int
+@@ -10777,7 +10778,7 @@
+ LDFLAGS_save="$LDFLAGS"
+
+ mitlibs="-lkrb5 -lk5crypto -lcom_err -lgssapi_krb5"
+- heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi"
++ heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi -lcrypt"
+ echo "$as_me:$LINENO: checking for Kerberos 5" >&5
+ echo $ECHO_N "checking for Kerberos 5... $ECHO_C" >&6
+ if test "${ac_cv_lib_kerberos5+set}" = set; then
+@@ -29833,7 +29834,7 @@
idldir="$datadir/idl/evolution-data-server-$BASE_VERSION"
@@ -8,4 +38,4 @@
+serverdir="$prefix/libdata/bonobo/servers"
-
+ extensiondir='${privlibdir}'/extensions
diff --git a/databases/evolution-data-server/files/patch-libedataserverui_e-source-option-menu.c b/databases/evolution-data-server/files/patch-libedataserverui_e-source-option-menu.c
new file mode 100644
index 000000000000..62532da02471
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-libedataserverui_e-source-option-menu.c
@@ -0,0 +1,11 @@
+--- libedataserverui/e-source-option-menu.c.orig Tue Nov 23 13:50:14 2004
++++ libedataserverui/e-source-option-menu.c Tue Nov 23 13:50:33 2004
+@@ -24,6 +24,8 @@
+ #include <config.h>
+ #endif
+
++#include <sys/types.h>
++
+ #include <gtk/gtkmenu.h>
+ #include <gtk/gtkmenuitem.h>
+
diff --git a/databases/evolution-data-server/files/patch-servers_groupwise_e-gw-connection.c b/databases/evolution-data-server/files/patch-servers_groupwise_e-gw-connection.c
new file mode 100644
index 000000000000..576ecea6ae3c
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-servers_groupwise_e-gw-connection.c
@@ -0,0 +1,12 @@
+--- servers/groupwise/e-gw-connection.c.orig Tue Mar 8 03:50:29 2005
++++ servers/groupwise/e-gw-connection.c Tue Mar 8 03:50:40 2005
+@@ -1764,8 +1764,8 @@
+ EGwConnectionPrivate *priv;
+ SoupSoapParameter *param, *subparam, *second_level_child;
+ char *id, *name;
+- g_return_val_if_fail (E_IS_GW_CONNECTION (cnc), E_GW_CONNECTION_STATUS_INVALID_OBJECT);
+ static GStaticMutex connecting = G_STATIC_MUTEX_INIT;
++ g_return_val_if_fail (E_IS_GW_CONNECTION (cnc), E_GW_CONNECTION_STATUS_INVALID_OBJECT);
+
+ priv = cnc->priv;
+ g_static_mutex_lock (&connecting);
diff --git a/databases/evolution-data-server/files/patch-servers_groupwise_e-gw-item.c b/databases/evolution-data-server/files/patch-servers_groupwise_e-gw-item.c
new file mode 100644
index 000000000000..c865775dae15
--- /dev/null
+++ b/databases/evolution-data-server/files/patch-servers_groupwise_e-gw-item.c
@@ -0,0 +1,22 @@
+--- servers/groupwise/e-gw-item.c.orig Tue Jan 25 20:31:45 2005
++++ servers/groupwise/e-gw-item.c Tue Jan 25 20:32:28 2005
+@@ -2604,8 +2604,8 @@
+
+ /*attachments*/
+ if (priv->attach_list) {
+- soup_soap_message_start_element (msg, "attachments", NULL, NULL) ;
+ GSList *al ;
++ soup_soap_message_start_element (msg, "attachments", NULL, NULL) ;
+ for (al = priv->attach_list ; al != NULL ; al = al->next) {
+ EGwItemAttachment *attachment = (EGwItemAttachment *)al->data ;
+ add_attachment_to_soap_message (attachment, msg) ;
+@@ -2669,8 +2669,8 @@
+
+ /*attachments*/
+ if (priv->attach_list) {
+- soup_soap_message_start_element (msg, "attachments", NULL, NULL) ;
+ GSList *al ;
++ soup_soap_message_start_element (msg, "attachments", NULL, NULL) ;
+ for (al = priv->attach_list ; al != NULL ; al = al->next) {
+ EGwItemAttachment *attachment = (EGwItemAttachment *)al->data ;
+ add_attachment_to_soap_message (attachment, msg) ;