aboutsummaryrefslogtreecommitdiff
path: root/databases/evolution-data-server
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-05-11 07:33:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-05-11 07:33:40 +0000
commit1cdb9d59bbbaaf5cef847bd6e8a04253cee94347 (patch)
tree3dcc5b59f412153ad2682d88dbbe11cc8f3325dc /databases/evolution-data-server
parent3e6500f6d20c07fea4113e6bfa6c0477a4a153b6 (diff)
downloadports-1cdb9d59bbbaaf5cef847bd6e8a04253cee94347.tar.gz
ports-1cdb9d59bbbaaf5cef847bd6e8a04253cee94347.zip
* Fix the build with the new Heimdal on -CURRENT [1]
* Allow other BDD versions to be used, but display a warning if BDB 41 is not used [2] Submitted by: mezz [1] Requested by: ade [2]
Notes
Notes: svn path=/head/; revision=212897
Diffstat (limited to 'databases/evolution-data-server')
-rw-r--r--databases/evolution-data-server/Makefile16
-rw-r--r--databases/evolution-data-server/files/patch-configure9
2 files changed, 13 insertions, 12 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 2f26c333a914..93bec89d9eba 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -27,7 +27,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack gnometarget libgnomeui \
ltverhack
USE_OPENLDAP= yes
USE_AUTOTOOLS= libtool:15
-USE_BDB= 41
+USE_BDB= 41+
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-static \
--enable-nss=yes \
@@ -50,8 +50,10 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libedataserver_e-msgport.c
HEIMDAL_HOME?= ${LOCALBASE}
LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --with-krb5-includes=${HEIMDAL_HOME}/include
+KRB5_LIB= `${HEIMDAL_HOME}/bin/krb5-config --libs`
.elif !defined(NO_KERBEROS)
CONFIGURE_ARGS+= --with-krb5=/usr
+KRB5_LIB= `/usr/bin/krb5-config gssapi --libs`
.endif
.if defined(WITH_IMAP4) || defined(PACKAGE_BUILDING)
@@ -61,8 +63,16 @@ PLIST_SUB+= IMAP4=""
PLIST_SUB+= IMAP4="@comment "
.endif
+EDS_BDB_MSG= "!!!WARNING!!!: Berkeley Database version is ${BDB_VER}. If this is an upgrade, you may experience problems if you or any other Evolution-data-server users were previously using BDB_VER 41."
+
+pre-everything::
+ @if [ x"${BDB_VER}" != x"41" ]; then \
+ ${ECHO_MSG} ${EDS_BDB_MSG} | ${FMT} 75 79 ; \
+ fi
+
post-patch:
- @${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-ldb|-l${BDB_LIB_NAME}|g ; \
+ s|heimlibs=".*"|heimlibs="${KRB5_LIB}"|g' \
+ ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/databases/evolution-data-server/files/patch-configure b/databases/evolution-data-server/files/patch-configure
index 1ef8d776b127..3fac0e9046c9 100644
--- a/databases/evolution-data-server/files/patch-configure
+++ b/databases/evolution-data-server/files/patch-configure
@@ -24,15 +24,6 @@
int
main ()
-@@ -28982,7 +28990,7 @@ if test "x${with_krb5}" != "xno"; then
- LDFLAGS_save="$LDFLAGS"
-
- mitlibs="-lkrb5 -lk5crypto -lcom_err -lgssapi_krb5"
-- heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi"
-+ heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi -lcrypt"
- sunlibs="-lkrb5 -lgss"
- { echo "$as_me:$LINENO: checking for Kerberos 5" >&5
- echo $ECHO_N "checking for Kerberos 5... $ECHO_C" >&6; }
@@ -33825,7 +33833,7 @@ idldir='${datadir}'/idl/evolution-data-s
imagesdir='${datadir}'/pixmaps/evolution-data-server