aboutsummaryrefslogtreecommitdiff
path: root/databases/galera
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2017-06-30 15:24:17 +0000
committerVasil Dimov <vd@FreeBSD.org>2017-06-30 15:24:17 +0000
commit55c1a72fe5410ce7db9c3951b7227f2fbbc19ec9 (patch)
tree0df3271efa55d03b86e870ec546a6dabfe3bb59b /databases/galera
parent8857a2980faceafed92ccc7564987ae58db4a4aa (diff)
downloadports-55c1a72fe5410ce7db9c3951b7227f2fbbc19ec9.tar.gz
ports-55c1a72fe5410ce7db9c3951b7227f2fbbc19ec9.zip
databases/galera: Split compilation from tests run
Previously tests were ran intermixed with compilation commands in parallel (scons -jN). Running tests in parallel produces some sporadic failures which would make the compilation fail. With this change, when compiling ("make" in the ports directory) "scons -j8 ... tests=0" is used to request compilation only. To run the tests do "make test" in the ports directory. It will run "scons ... tests=1" (without -jN) and will only run the tests.
Notes
Notes: svn path=/head/; revision=444766
Diffstat (limited to 'databases/galera')
-rw-r--r--databases/galera/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index 410ffa267b21..bb6c4dcb3f4f 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -37,13 +37,16 @@ GH_ACCOUNT= codership
GH_TAGNAME?= release_${DISTVERSION}
LDFLAGS+= -lboost_program_options -lboost_system
-MAKE_ARGS+= --config=force \
- deterministic_tests=1 \
- revno=${GH_TAGNAME} \
- system_asio=0
+MAKE_ARGS+= revno=${GH_TAGNAME} system_asio=0 tests=0
USE_RC_SUBR= garb.sh
+# Abuse TEST_TARGET to append tests=1 (which is not a target, strictly
+# speaking) at the end of the "scons ..." command so that it overrides
+# tests=0 from ${MAKE_ARGS}. To rerun the tests a second time, remove
+# all *.passed files: find ./work -name *.passed -print -delete
+TEST_TARGET= deterministic_tests=1 tests=1
+
PLIST_FILES= bin/garbd \
lib/libgalera.so \
lib/libgalera_smm.so