aboutsummaryrefslogtreecommitdiff
path: root/databases/gnome-db
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-06-19 08:12:14 +0000
committerAde Lovett <ade@FreeBSD.org>2001-06-19 08:12:14 +0000
commita5382b9c17e04397dc5b47ee07cdab1ca34f60b4 (patch)
tree29dddbc0d2bcabf7bf000084905ce01373ae5534 /databases/gnome-db
parentfbeacc4f75e689053e4f4ed132af3b00ab81e5da (diff)
downloadports-a5382b9c17e04397dc5b47ee07cdab1ca34f60b4.tar.gz
ports-a5382b9c17e04397dc5b47ee07cdab1ca34f60b4.zip
Add gnome-db 0.2.10, a GNOME front-end to libgda, and a whole load more.
Notes
Notes: svn path=/head/; revision=44208
Diffstat (limited to 'databases/gnome-db')
-rw-r--r--databases/gnome-db/Makefile36
-rw-r--r--databases/gnome-db/distinfo1
-rw-r--r--databases/gnome-db/files/patch-configure39
-rw-r--r--databases/gnome-db/files/patch-po::Makefile.in.in7
-rw-r--r--databases/gnome-db/pkg-comment1
-rw-r--r--databases/gnome-db/pkg-descr8
-rw-r--r--databases/gnome-db/pkg-plist72
7 files changed, 164 insertions, 0 deletions
diff --git a/databases/gnome-db/Makefile b/databases/gnome-db/Makefile
new file mode 100644
index 000000000000..6636a06c844c
--- /dev/null
+++ b/databases/gnome-db/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gnomedb
+# Date created: 19th June 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomedb
+PORTVERSION= 0.2.10
+CATEGORIES= databases gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= stable/sources/gnome-db
+DISTNAME= gnome-db-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= bonobo.2:${PORTSDIR}/devel/bonobo \
+ gda-client.0:${PORTSDIR}/databases/libgda
+
+USE_X_PREFIX= yes
+USE_GNOMECTRL= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lintl"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/databases/gnome-db/distinfo b/databases/gnome-db/distinfo
new file mode 100644
index 000000000000..d12cd618c0a1
--- /dev/null
+++ b/databases/gnome-db/distinfo
@@ -0,0 +1 @@
+MD5 (gnome-db-0.2.10.tar.gz) = f3a0480659ce671961909714a74ea4bf
diff --git a/databases/gnome-db/files/patch-configure b/databases/gnome-db/files/patch-configure
new file mode 100644
index 000000000000..f9c35b7dfc9b
--- /dev/null
+++ b/databases/gnome-db/files/patch-configure
@@ -0,0 +1,39 @@
+--- configure.orig Fri Jun 15 15:39:00 2001
++++ configure Tue Jun 19 02:24:00 2001
+@@ -5687,4 +5687,19 @@
+
+-
+-
++# Actually configure libtool. ac_aux_dir is where install-sh is found.
++CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
++LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
++LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
++DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
++${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
++$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
++|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
++
++# Reload cache, that may have been modified by ltconfig
++if test -r "$cache_file"; then
++ echo "loading cache $cache_file"
++ . $cache_file
++else
++ echo "creating cache $cache_file"
++ > $cache_file
++fi
+
+@@ -5692,3 +5707,3 @@
+ # This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
+
+@@ -8823,3 +8838,3 @@
+
+-if test $perl_val == true; then
++if [ $perl_val = true ]; then
+ WITH_PERL_TRUE=
+@@ -8833,3 +8848,3 @@
+ GNOMEDB_LIBS="`gda-config --libs client` `gnome-config --libs xml oaf bonobox print`"
+-GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${datadir}/locale\\\""
++GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${prefix}/share/locale\\\""
+
diff --git a/databases/gnome-db/files/patch-po::Makefile.in.in b/databases/gnome-db/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..490f48af9f3f
--- /dev/null
+++ b/databases/gnome-db/files/patch-po::Makefile.in.in
@@ -0,0 +1,7 @@
+--- po/Makefile.in.in.orig Fri Jun 15 15:38:54 2001
++++ po/Makefile.in.in Tue Jun 19 02:37:06 2001
+@@ -25,3 +25,3 @@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = $(prefix)/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
diff --git a/databases/gnome-db/pkg-comment b/databases/gnome-db/pkg-comment
new file mode 100644
index 000000000000..ce1aae1e6b38
--- /dev/null
+++ b/databases/gnome-db/pkg-comment
@@ -0,0 +1 @@
+Provide uniform access to data sources for the GNOME environment
diff --git a/databases/gnome-db/pkg-descr b/databases/gnome-db/pkg-descr
new file mode 100644
index 000000000000..58ac273f4c90
--- /dev/null
+++ b/databases/gnome-db/pkg-descr
@@ -0,0 +1,8 @@
+gnome-db can be considered as an extension of the libgda project.
+
+Its aims are the same: to provide universal data source access for
+client applications, as well as development tools and libraries
+for doing so. gnome-db; is an extension to libgda; because it adds
+support to the architecture for the GNOME project.
+
+WWW: http://www.gnome.org/projects/gnome-db/
diff --git a/databases/gnome-db/pkg-plist b/databases/gnome-db/pkg-plist
new file mode 100644
index 000000000000..ea728fa3943a
--- /dev/null
+++ b/databases/gnome-db/pkg-plist
@@ -0,0 +1,72 @@
+bin/gnomedb-builder
+bin/gnomedb-components
+bin/gnomedb-config
+bin/gnomedb-fe
+bin/gnomedb-mgr
+include/gnome-db/GnomeDB.h
+include/gnome-db/gnome-db-browser.h
+include/gnome-db/gnome-db-combo.h
+include/gnome-db/gnome-db-component.h
+include/gnome-db/gnome-db-config.h
+include/gnome-db/gnome-db-control-defprops.h
+include/gnome-db/gnome-db-control-widget.h
+include/gnome-db/gnome-db-control.h
+include/gnome-db/gnome-db-dataset.h
+include/gnome-db/gnome-db-designer.h
+include/gnome-db/gnome-db-dsn-config-druid.h
+include/gnome-db/gnome-db-dsn-config.h
+include/gnome-db/gnome-db-embeddable.h
+include/gnome-db/gnome-db-entry.h
+include/gnome-db/gnome-db-error-dlg.h
+include/gnome-db/gnome-db-error.h
+include/gnome-db/gnome-db-export.h
+include/gnome-db/gnome-db-grid.h
+include/gnome-db/gnome-db-icon-list.h
+include/gnome-db/gnome-db-label.h
+include/gnome-db/gnome-db-list.h
+include/gnome-db/gnome-db-log-viewer.h
+include/gnome-db/gnome-db-login-dlg.h
+include/gnome-db/gnome-db-login.h
+include/gnome-db/gnome-db-moniker.h
+include/gnome-db/gnome-db-report.h
+include/gnome-db/gnome-db-shortcut.h
+include/gnome-db/gnome-db-util.h
+include/gnome-db/gnome-db-window.h
+include/gnome-db/gnome-db.h
+lib/bonobo/monikers/libdatabase_moniker.a
+lib/bonobo/monikers/libdatabase_moniker.so
+lib/bonobo/monikers/libdatabase_moniker.so.0
+lib/libgnomedb.a
+lib/libgnomedb.so
+lib/libgnomedb.so.0
+share/gnome/html/libgnomedb-decl.txt
+share/gnome/html/libgnomedb-sections.txt
+share/gnome/html/libgnomedb.args
+share/gnome/html/libgnomedb.hierarchy
+share/gnome/html/libgnomedb.signals
+share/gnome/html/libgnomedb.types
+share/idl/GnomeDB.idl
+share/locale/ca/LC_MESSAGES/gnome-db.mo
+share/locale/da/LC_MESSAGES/gnome-db.mo
+share/locale/de/LC_MESSAGES/gnome-db.mo
+share/locale/el/LC_MESSAGES/gnome-db.mo
+share/locale/es/LC_MESSAGES/gnome-db.mo
+share/locale/fi/LC_MESSAGES/gnome-db.mo
+share/locale/fr/LC_MESSAGES/gnome-db.mo
+share/locale/ga/LC_MESSAGES/gnome-db.mo
+share/locale/gl/LC_MESSAGES/gnome-db.mo
+share/locale/hu/LC_MESSAGES/gnome-db.mo
+share/locale/it/LC_MESSAGES/gnome-db.mo
+share/locale/ja/LC_MESSAGES/gnome-db.mo
+share/locale/ko/LC_MESSAGES/gnome-db.mo
+share/locale/nl/LC_MESSAGES/gnome-db.mo
+share/locale/no/LC_MESSAGES/gnome-db.mo
+share/locale/pl/LC_MESSAGES/gnome-db.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-db.mo
+share/locale/ru/LC_MESSAGES/gnome-db.mo
+share/locale/sk/LC_MESSAGES/gnome-db.mo
+share/locale/sl/LC_MESSAGES/gnome-db.mo
+share/locale/sv/LC_MESSAGES/gnome-db.mo
+share/locale/tr/LC_MESSAGES/gnome-db.mo
+share/locale/uk/LC_MESSAGES/gnome-db.mo
+@dirrm include/gnome-db