aboutsummaryrefslogtreecommitdiff
path: root/databases/gnomedb/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-26 14:13:05 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-26 14:13:05 +0000
commit3d9708732d72f44a1c7a57dc2897182e3bcb1ecf (patch)
tree1d37aa02f9d0e84c7a941f8487c04e07d3524dfd /databases/gnomedb/files
parent172e6a529db97c8f0582e6cdcbe57d595d19f56b (diff)
downloadports-3d9708732d72f44a1c7a57dc2897182e3bcb1ecf.tar.gz
ports-3d9708732d72f44a1c7a57dc2897182e3bcb1ecf.zip
- Add number of missed files into pkg-plist;
- remove useless USE_LIBTOOL; - hack port to install files properly into GNOME tree.
Notes
Notes: svn path=/head/; revision=45510
Diffstat (limited to 'databases/gnomedb/files')
-rw-r--r--databases/gnomedb/files/patch-configure51
-rw-r--r--databases/gnomedb/files/patch-idl::Makefile.in14
-rw-r--r--databases/gnomedb/files/patch-ltmain.sh18
3 files changed, 52 insertions, 31 deletions
diff --git a/databases/gnomedb/files/patch-configure b/databases/gnomedb/files/patch-configure
index f9c35b7dfc9b..4c28f6fa60f3 100644
--- a/databases/gnomedb/files/patch-configure
+++ b/databases/gnomedb/files/patch-configure
@@ -1,39 +1,28 @@
---- configure.orig Fri Jun 15 15:39:00 2001
-+++ configure Tue Jun 19 02:24:00 2001
-@@ -5687,4 +5687,19 @@
-
--
--
-+# Actually configure libtool. ac_aux_dir is where install-sh is found.
-+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
-+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-+
-+# Reload cache, that may have been modified by ltconfig
-+if test -r "$cache_file"; then
-+ echo "loading cache $cache_file"
-+ . $cache_file
-+else
-+ echo "creating cache $cache_file"
-+ > $cache_file
-+fi
-
-@@ -5692,3 +5707,3 @@
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
-
-@@ -8823,3 +8838,3 @@
+
+$FreeBSD$
+
+--- configure.orig Thu Jul 26 16:38:59 2001
++++ configure Thu Jul 26 16:50:40 2001
+@@ -8821,7 +8836,7 @@
+
+
-if test $perl_val == true; then
+if [ $perl_val = true ]; then
WITH_PERL_TRUE=
-@@ -8833,3 +8848,3 @@
+ WITH_PERL_FALSE='#'
+ else
+@@ -8831,11 +8846,11 @@
+
+ GNOMEDB_CFLAGS="`gda-config --cflags client` `gnome-config --cflags xml oaf bonobox print`"
GNOMEDB_LIBS="`gda-config --libs client` `gnome-config --libs xml oaf bonobox print`"
-GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${datadir}/locale\\\""
+GNOMEDB_CFLAGS="${GNOMEDB_CFLAGS} -DGNOMELOCALEDIR=\\\"${prefix}/share/locale\\\""
+
+
+-GNOMEDB_oafdir=`oaf-config --prefix`/share/oaf
++GNOMEDB_oafdir=`oaf-config --prefix`/share/gnome/oaf
+
+
+
diff --git a/databases/gnomedb/files/patch-idl::Makefile.in b/databases/gnomedb/files/patch-idl::Makefile.in
new file mode 100644
index 000000000000..da60a4cfbf63
--- /dev/null
+++ b/databases/gnomedb/files/patch-idl::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- idl/Makefile.in 2001/07/26 14:06:24 1.1
++++ idl/Makefile.in 2001/07/26 14:06:37
+@@ -153,7 +153,7 @@
+ EXTRA_DIST = $(IDL_FILES)
+
+
+-idldir = $(prefix)/share/idl
++idldir = $(prefix)/share/gnome/idl
+ idl_DATA = $(IDL_FILES)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
diff --git a/databases/gnomedb/files/patch-ltmain.sh b/databases/gnomedb/files/patch-ltmain.sh
new file mode 100644
index 000000000000..0c594216b0e1
--- /dev/null
+++ b/databases/gnomedb/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/07/23 09:45:58 1.1
++++ ltmain.sh 2001/07/23 09:46:28
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"