aboutsummaryrefslogtreecommitdiff
path: root/databases/gqlplus
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2002-11-07 17:36:47 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2002-11-07 17:36:47 +0000
commite1ab150f4b9620d10a2c7281face68d62d27cecd (patch)
treeddb64bc4694471d49484bcf9aac7d1ed8cdfc5da /databases/gqlplus
parent03f838e65e7e807ab19e77c112aefba9f14e5c24 (diff)
downloadports-e1ab150f4b9620d10a2c7281face68d62d27cecd.tar.gz
ports-e1ab150f4b9620d10a2c7281face68d62d27cecd.zip
add gqlplus, the SQL*PLUS with commandline editing, history, and
table/column name completion Reviewed by: ijliao (mentor) Approved by: ijliao (mentor)
Notes
Notes: svn path=/head/; revision=69674
Diffstat (limited to 'databases/gqlplus')
-rw-r--r--databases/gqlplus/Makefile22
-rw-r--r--databases/gqlplus/distinfo1
-rw-r--r--databases/gqlplus/pkg-comment1
-rw-r--r--databases/gqlplus/pkg-descr15
-rw-r--r--databases/gqlplus/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/databases/gqlplus/Makefile b/databases/gqlplus/Makefile
new file mode 100644
index 000000000000..fce885c30153
--- /dev/null
+++ b/databases/gqlplus/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: gqlplus
+# Date created: 06 November 2002
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gqlplus
+PORTVERSION= 1.5
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= leeym@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKEFILE= makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/databases/gqlplus/distinfo b/databases/gqlplus/distinfo
new file mode 100644
index 000000000000..c98b17ba6ffc
--- /dev/null
+++ b/databases/gqlplus/distinfo
@@ -0,0 +1 @@
+MD5 (gqlplus-1.5.tar.gz) = 024d5de3d6555f811ae0bd2f990bdfdc
diff --git a/databases/gqlplus/pkg-comment b/databases/gqlplus/pkg-comment
new file mode 100644
index 000000000000..d24886b5dc88
--- /dev/null
+++ b/databases/gqlplus/pkg-comment
@@ -0,0 +1 @@
+SQL*PLUS with commandline editing, history, and name completion
diff --git a/databases/gqlplus/pkg-descr b/databases/gqlplus/pkg-descr
new file mode 100644
index 000000000000..abaa7c8f3660
--- /dev/null
+++ b/databases/gqlplus/pkg-descr
@@ -0,0 +1,15 @@
+gqlplus is a drop-in replacement for sqlplus, an Oracle SQL client, for
+UNIX platforms. The difference between gqlplus and sqlplus is command-line
+editing and history, plus tablename completion. As you know if you have
+used sqlplus, it is notoriously difficult to correct typing errors and
+other mistakes in your SQL statements. sqlplus does give you ability to
+use external editor to edit a statement, but only the last statement you
+typed. gqlplus solves this problem by providing the familiar command-line
+editing and history as in tcsh or bash shells, and tablename completion,
+while otherwise retaining compatibility with sqlplus. Thus, no user training
+is needed - simply use gqlplus instead of sqlplus. In addition,
+configuration/installation is trivial: gqlplus is a single binary compiled
+executable (written in C), so all you need is download it and put it anywhere
+in your PATH. After that, you'll be ready to use it.
+
+WWW: http://gqlplus.sourceforge.net/
diff --git a/databases/gqlplus/pkg-plist b/databases/gqlplus/pkg-plist
new file mode 100644
index 000000000000..812b97b468cd
--- /dev/null
+++ b/databases/gqlplus/pkg-plist
@@ -0,0 +1 @@
+bin/gqlplus