aboutsummaryrefslogtreecommitdiff
path: root/databases/hbase
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-07-29 12:13:59 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-07-29 12:13:59 +0000
commitbd7f40e53ff97456ec3e2f761240f107fc7fa16f (patch)
treea41074ccb1da011ac9f11743e43ce5cb74672025 /databases/hbase
parent77ae1bd03b75c06c71975bad6f5c28ccbe9670a2 (diff)
downloadports-bd7f40e53ff97456ec3e2f761240f107fc7fa16f.tar.gz
ports-bd7f40e53ff97456ec3e2f761240f107fc7fa16f.zip
Install sample configs in EXAMPLESDIR;
Minor tweaks.
Notes
Notes: svn path=/head/; revision=363309
Diffstat (limited to 'databases/hbase')
-rw-r--r--databases/hbase/Makefile6
-rw-r--r--databases/hbase/files/hbase-env-dist.sh.in4
-rw-r--r--databases/hbase/files/pkg-message.in4
-rw-r--r--databases/hbase/pkg-plist15
4 files changed, 19 insertions, 10 deletions
diff --git a/databases/hbase/Makefile b/databases/hbase/Makefile
index 27c14a11a074..901435778014 100644
--- a/databases/hbase/Makefile
+++ b/databases/hbase/Makefile
@@ -36,7 +36,7 @@ HBASE_GROUP= hbase
USERS= ${HBASE_USER}
GROUPS= ${HBASE_GROUP}
-SUB_FILES= hbase-env-dist.sh
+SUB_FILES= hbase-env-dist.sh pkg-message
USE_RC_SUBR= hbase_master hbase_regionserver
SUB_LIST= HBASE_USER="${HBASE_USER}" \
JAVA_HOME="${JAVA_HOME}" \
@@ -63,8 +63,8 @@ post-build:
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/hbase/bin
cd ${HBASE_DIST}/bin && ${INSTALL_SCRIPT} *.sh hbase ${STAGEDIR}${PREFIX}/hbase/bin/
- ${MKDIR} ${STAGEDIR}${ETCDIR}
- cd ${HBASE_DIST} && ${COPYTREE_SHARE} conf ${STAGEDIR}${PREFIX}/hbase/
+ ${MKDIR} ${STAGEDIR}${ETCDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${HBASE_DIST} && ${COPYTREE_SHARE} conf ${STAGEDIR}${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKDIR}/hbase-env-dist.sh ${STAGEDIR}${ETCDIR}/
cd ${HBASE_DIST}/docs && ${COPYTREE_SHARE} "*" ${STAGEDIR}${DOCSDIR}/
cd ${HBASE_DIST} && ${COPYTREE_SHARE} hbase-webapps ${STAGEDIR}${PREFIX}/hbase/
diff --git a/databases/hbase/files/hbase-env-dist.sh.in b/databases/hbase/files/hbase-env-dist.sh.in
index d4aa5979a6d1..24053cef3dcd 100644
--- a/databases/hbase/files/hbase-env-dist.sh.in
+++ b/databases/hbase/files/hbase-env-dist.sh.in
@@ -1,3 +1,7 @@
+# This file contains FreeBSD-specific configuration parameters.
+# It is not supposed to be edited. It will be overwritten during upgrades.
+# Edit hbase-env.sh instead.
+
export JAVA_HOME=%%JAVA_HOME%%
export HBASE_LOG_DIR=%%HBASE_LOG_DIR%%
export HBASE_PID_DIR=%%HBASE_PID_DIR%%
diff --git a/databases/hbase/files/pkg-message.in b/databases/hbase/files/pkg-message.in
new file mode 100644
index 000000000000..42a4e12cfe12
--- /dev/null
+++ b/databases/hbase/files/pkg-message.in
@@ -0,0 +1,4 @@
+********************************************************************************
+* HBase binaries are installed in %%PREFIX%%/hbase/bin/ *
+* Consider adding this directory to your $PATH. *
+********************************************************************************
diff --git a/databases/hbase/pkg-plist b/databases/hbase/pkg-plist
index aa02105e7ec2..362b834e4755 100644
--- a/databases/hbase/pkg-plist
+++ b/databases/hbase/pkg-plist
@@ -14,12 +14,12 @@ hbase/bin/rolling-restart.sh
hbase/bin/start-hbase.sh
hbase/bin/stop-hbase.sh
hbase/bin/zookeepers.sh
-hbase/conf/hadoop-metrics2-hbase.properties
-hbase/conf/hbase-env.sh
-hbase/conf/hbase-policy.xml
-hbase/conf/hbase-site.xml
-hbase/conf/log4j.properties
-hbase/conf/regionservers
+%%EXAMPLESDIR%%/conf/hadoop-metrics2-hbase.properties
+%%EXAMPLESDIR%%/conf/hbase-env.sh
+%%EXAMPLESDIR%%/conf/hbase-policy.xml
+%%EXAMPLESDIR%%/conf/hbase-site.xml
+%%EXAMPLESDIR%%/conf/log4j.properties
+%%EXAMPLESDIR%%/conf/regionservers
hbase/hbase-webapps/master/WEB-INF/web.xml
hbase/hbase-webapps/master/index.html
hbase/hbase-webapps/regionserver/WEB-INF/web.xml
@@ -9947,7 +9947,6 @@ hbase/lib/zookeeper-3.4.6.jar
%%PORTDOCS%%%%DOCSDIR%%/zookeeper/zk.sasl.auth.html
%%PORTDOCS%%%%DOCSDIR%%/zookeeper/zookeeper.html
@dirrm hbase/bin
-@dirrm hbase/conf
@dirrm hbase/hbase-webapps/master/WEB-INF
@dirrm hbase/hbase-webapps/master
@dirrm hbase/hbase-webapps/regionserver/WEB-INF
@@ -10464,6 +10463,8 @@ hbase/lib/zookeeper-3.4.6.jar
%%PORTDOCS%%@dirrm %%DOCSDIR%%/xref-test
%%PORTDOCS%%@dirrm %%DOCSDIR%%/zookeeper
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%/conf
+@dirrm %%EXAMPLESDIR%%
@dirrmtry %%ETCDIR%%
@cwd /
@owner %%HBASE_USER%%