aboutsummaryrefslogtreecommitdiff
path: root/databases/isql-viewer
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-06-23 20:41:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-06-23 20:41:39 +0000
commit3882c2f54aafa11498ab915da2bdba0add79497e (patch)
treed2ffefe31e8ee9347797c8964f1b9555e433b75f /databases/isql-viewer
parent69fe73b7b0f5f3131120e1900ddffec16ee4dd6e (diff)
downloadports-3882c2f54aafa11498ab915da2bdba0add79497e.tar.gz
ports-3882c2f54aafa11498ab915da2bdba0add79497e.zip
Add isql-viewer 2.1.8, jDBC 2.x compliant database front end.
PR: 37904 Submitted by: Stefan Schmidt <stefan.schmidt (at) stadtbuch.de> Remark: isql-viewer depends on IBM's version (2.2) of BSF before it has been donated to the Apache Software Foundation. Therefore this version still uses the package name "com.ibm.bsf". In the current version of BSF, the package name has been changed to "org.apache.org" to reflect the new ownership. Thus, no separate port has been created to install this dated version of BSF.
Notes
Notes: svn path=/head/; revision=137943
Diffstat (limited to 'databases/isql-viewer')
-rw-r--r--databases/isql-viewer/Makefile68
-rw-r--r--databases/isql-viewer/distinfo4
-rw-r--r--databases/isql-viewer/files/iSQL-Viewer.sh5
-rw-r--r--databases/isql-viewer/pkg-descr23
-rw-r--r--databases/isql-viewer/pkg-message11
5 files changed, 111 insertions, 0 deletions
diff --git a/databases/isql-viewer/Makefile b/databases/isql-viewer/Makefile
new file mode 100644
index 000000000000..f7a8b938010b
--- /dev/null
+++ b/databases/isql-viewer/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: iSQL-Viewer
+# Date created: June 19, 2005
+# Whom: Stefan Schmidt <stefan.schmidt@stadtbuch.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= isql-viewer
+PORTVERSION= 2.1.8
+CATEGORIES= databases java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:isql/} \
+ ${MASTER_SITE_APACHE:S/$/:bsf/}
+MASTER_SITE_SUBDIR= isql/:isql \
+ ws/soap/version-2.2/:bsf
+DISTFILES= ${ISQL_JAR}:isql \
+ ${BSF_JAR}:bsf
+EXTRACT_ONLY= # none
+
+MAINTAINER= stefan.schmidt@stadtbuch.de
+COMMENT= JDBC 2.x compliant database front end
+
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper \
+ ${JYTHON_PREFIX}/${JYTHON_JAR}:${PORTSDIR}/lang/jython \
+ ${JAVALIBDIR}/postgresql.jar:${PORTSDIR}/databases/postgresql-jdbc \
+ ${JAVALIBDIR}/mysql-connector-java.jar:${PORTSDIR}/databases/mysql-connector-java
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+ISQL= iSQL-Viewer
+ISQL_JAR= ${ISQL}-${PORTVERSION}.jar
+DEST_ISQL_JAR= ${ISQL}.jar
+
+BSF_JAR= bsf.jar
+DEST_BSF_JAR= ibm-${BSF_JAR}
+
+JYTHON_PORT= ${PORTSDIR}/lang/jython
+JYTHON_PREFIX= ${LOCALBASE}/jython21
+JYTHON_JAR= jython.jar
+
+JARFILES= ${DEST_ISQL_JAR} \
+ ${DEST_BSF_JAR}
+
+PLIST_FILES= bin/iSQL-Viewer \
+ ${JARFILES:S,^,%%JAVAJARDIR%%/,}
+
+JAR_DEPENDS= mysql-connector-java.jar \
+ postgresql.jar
+
+CLASSPATH= "${JARFILES:S,^,${JAVAJARDIR}/,}:${JYTHON_PREFIX}/${JYTHON_JAR}:${JAR_DEPENDS:S,^,${JAVALIBDIR}/,:S| |:|g}"
+
+do-configure:
+ @${SED} -e 's|%%CLASSPATH%%|${CLASSPATH:C,[[:space:]],:,g}|g' \
+ -e 's|%%JAVA_VERSION%%|${JAVA_VERSION}|g' \
+ ${FILESDIR}/iSQL-Viewer.sh > ${WRKDIR}/iSQL-Viewer.sh
+
+do-install:
+ @${INSTALL_DATA} ${_DISTDIR}${ISQL_JAR} ${JAVAJARDIR}/${DEST_ISQL_JAR}
+ @${INSTALL_DATA} ${_DISTDIR}${BSF_JAR} ${JAVAJARDIR}/${DEST_BSF_JAR}
+ @${INSTALL_SCRIPT} ${WRKDIR}/iSQL-Viewer.sh ${PREFIX}/bin/iSQL-Viewer
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/databases/isql-viewer/distinfo b/databases/isql-viewer/distinfo
new file mode 100644
index 000000000000..fe745a89713c
--- /dev/null
+++ b/databases/isql-viewer/distinfo
@@ -0,0 +1,4 @@
+MD5 (iSQL-Viewer-2.1.8.jar) = d80c0984b5b5da63796c605e4ab6aa8d
+SIZE (iSQL-Viewer-2.1.8.jar) = 1137862
+MD5 (bsf.jar) = 2d3bbbbe5841ab7fbae3c8b5fdac4840
+SIZE (bsf.jar) = 105573
diff --git a/databases/isql-viewer/files/iSQL-Viewer.sh b/databases/isql-viewer/files/iSQL-Viewer.sh
new file mode 100644
index 000000000000..f6881037c040
--- /dev/null
+++ b/databases/isql-viewer/files/iSQL-Viewer.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+JAVA_VERSION=%%JAVA_VERSION%% \
+ java -classpath %%CLASSPATH%% \
+ org.isqlviewer.core.Launcher
diff --git a/databases/isql-viewer/pkg-descr b/databases/isql-viewer/pkg-descr
new file mode 100644
index 000000000000..c4fc43ed96db
--- /dev/null
+++ b/databases/isql-viewer/pkg-descr
@@ -0,0 +1,23 @@
+iSQL-Viewer is an open-source JDBC 2.x compliant database front end written
+in Java. It implements across multiple platforms features of the JDBC API.
+It does everything through a single interface.
+
+iSQL-Viewer works with most database platforms, including PostgreSQL, MySQL,
+Oracle, and Informix. iSQL-Viewer provides a variety of tools and features
+to carry out common database tasks. It includes:
+
+ * Scripting support using JPython and the IBM BSF framework
+ * A guided query builder for creating simple and complex SQL queries
+ * Enhanced object viewing for images, HTML, and other binary format files
+ * A friendly SQL console for executing SQL statements
+ * Batch processing of SQL files
+ * Database introspection
+ * "Bookmarks" to store SQL commands you commonly use
+ * Import and export to popular file formats such as Microsoft Excel, XML,
+ HTML and ASCII delimited.
+ * Enhanced interface support across platforms
+
+iSQL-Viewer is designed to meet the needs of JDBC Driver developers and
+database developers who work in single or multi-platform environments.
+
+WWW: http://www.isqlviewer.com/
diff --git a/databases/isql-viewer/pkg-message b/databases/isql-viewer/pkg-message
new file mode 100644
index 000000000000..8c6ec2e08f9e
--- /dev/null
+++ b/databases/isql-viewer/pkg-message
@@ -0,0 +1,11 @@
+=============================================================================
+This port of iSQL-Viewer is configured to automatically detect and use
+the installed JDBC drivers for MySQL and PostgreSQL.
+
+You can add additional JDBC drivers (and dependent JAR files) on a per
+service basis in the tabbed dialog "Resources" which resides inside the
+"Service Manager" dialog.
+
+However, please note that adding JAR files or directories in the preferences
+dialog doesn't have the desired effect in this version.
+=============================================================================