aboutsummaryrefslogtreecommitdiff
path: root/databases/libdbi-drivers
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-26 14:41:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-26 14:41:14 +0000
commitc9061d0309306810dbe645d53d3b2205902bee05 (patch)
tree75109a7a752b42a5ce1f0185bf661f678634f7c5 /databases/libdbi-drivers
parent9f14d91f188e326cee0dee5becc68f9f9d549c78 (diff)
downloadports-c9061d0309306810dbe645d53d3b2205902bee05.tar.gz
ports-c9061d0309306810dbe645d53d3b2205902bee05.zip
- Update to version 0.7.1
PR: ports/64759 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=105332
Diffstat (limited to 'databases/libdbi-drivers')
-rw-r--r--databases/libdbi-drivers/Makefile13
-rw-r--r--databases/libdbi-drivers/distinfo4
-rw-r--r--databases/libdbi-drivers/files/patch-ltmain.sh16
3 files changed, 11 insertions, 22 deletions
diff --git a/databases/libdbi-drivers/Makefile b/databases/libdbi-drivers/Makefile
index 6604a395bf0d..f94360ec5ead 100644
--- a/databases/libdbi-drivers/Makefile
+++ b/databases/libdbi-drivers/Makefile
@@ -7,18 +7,20 @@
#
PORTNAME= libdbi-drivers
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.1
CATEGORIES= databases devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= libdbi drivers
+COMMENT= Drivers for libdbi
LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-dbi-incdir=${LOCALBASE}/include/dbi
+USE_GNOME= gnometarget lthack
+USE_LIBTOOL_VER= 13
+CONFIGURE_ARGS= --disable-static \
+ --with-dbi-incdir=${LOCALBASE}/include/dbi
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
@@ -54,4 +56,7 @@ PLIST_SUB+= SQLITE="@comment "
#PLIST_SUB+= MSQL="@comment "
#.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O20|$$CFLAGS|g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/databases/libdbi-drivers/distinfo b/databases/libdbi-drivers/distinfo
index 6f651064aca8..351c6bf7c5e5 100644
--- a/databases/libdbi-drivers/distinfo
+++ b/databases/libdbi-drivers/distinfo
@@ -1,2 +1,2 @@
-MD5 (libdbi-drivers-0.7.0.tar.gz) = 4a523d28b53934cdd6bf1fadf0bfc6b9
-SIZE (libdbi-drivers-0.7.0.tar.gz) = 306057
+MD5 (libdbi-drivers-0.7.1.tar.gz) = f11020119ceb7a6dee3969cb0589d4bc
+SIZE (libdbi-drivers-0.7.1.tar.gz) = 488642
diff --git a/databases/libdbi-drivers/files/patch-ltmain.sh b/databases/libdbi-drivers/files/patch-ltmain.sh
deleted file mode 100644
index 5efb588c2fe1..000000000000
--- a/databases/libdbi-drivers/files/patch-ltmain.sh
+++ /dev/null
@@ -1,16 +0,0 @@
---- ltmain.sh.orig Thu Oct 30 11:32:24 2003
-+++ ltmain.sh Thu Oct 30 11:32:37 2003
-@@ -3457,11 +3457,13 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- if test "$install_ltlibs" = yes; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
- fi
-
- # Maybe install the static library, too.