aboutsummaryrefslogtreecommitdiff
path: root/databases/libdbi/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-10-14 16:22:53 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-10-14 16:22:53 +0000
commitb3d1423262c0671c2436a7679a91d0b6d8a5e9f9 (patch)
tree26cbd58e65a1afc8163a95414fa5d3270378e7ba /databases/libdbi/Makefile
parentb4abd729c7f0a1163c9abe57a121ac476f25077f (diff)
downloadports-b3d1423262c0671c2436a7679a91d0b6d8a5e9f9.tar.gz
ports-b3d1423262c0671c2436a7679a91d0b6d8a5e9f9.zip
Update to version 0.6.5.
PR: 43782 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=68046
Diffstat (limited to 'databases/libdbi/Makefile')
-rw-r--r--databases/libdbi/Makefile38
1 files changed, 24 insertions, 14 deletions
diff --git a/databases/libdbi/Makefile b/databases/libdbi/Makefile
index fdd703b816bd..a5540b9c3a92 100644
--- a/databases/libdbi/Makefile
+++ b/databases/libdbi/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libdbi
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.5
CATEGORIES= databases devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://linux.ucla.edu/~dap24/%SUBDIR%/
@@ -16,27 +16,37 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_LIBTOOL= yes
-GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-PLIST_SUB= VERSION=${PORTVERSION}
+
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+= --with-mysql \
+ --with-mysql-incdir=${LOCALBASE}/include \
+ --with-mysql-libdir=${LOCALBASE}/lib/mysql
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
+.endif
.if defined(WITH_PGSQL)
LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql
-PLIST_SUB+= WITH_PQ=""
+PLIST_SUB+= PGSQL=""
.else
-PLIST_SUB+= WITH_PQ="@comment "
+PLIST_SUB+= PGSQL="@comment "
.endif
-.if defined(WITH_MYSQL)
-LIB_DEPENDS+= mysqlclient:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+= \
- --with-mysql \
- --with-mysql-incdir=${LOCALBASE}/include \
- --with-mysql-libdir=${LOCALBASE}/lib/mysql
-PLIST_SUB+= WITH_MY=""
-.else
-PLIST_SUB+= WITH_MY="@comment "
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.pdf \
+ ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/driver-guide
+ ${INSTALL_DATA} ${WRKSRC}/doc/driver-guide/*.html \
+ ${DOCSDIR}/driver-guide
+ @${MKDIR} ${DOCSDIR}/programmers-guide
+ ${INSTALL_DATA} ${WRKSRC}/doc/programmers-guide/*.html \
+ ${DOCSDIR}/programmers-guide
.endif
.include <bsd.port.mk>