aboutsummaryrefslogtreecommitdiff
path: root/databases/libgda2
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-01-31 00:35:55 +0000
commit34fa6c853efa04ca648d3d4187d4aec40a00fc0d (patch)
tree3445b3e9b6e7650fd127ec078394a0d7a8e79076 /databases/libgda2
parentae2c26ad44dba87dd1377d70dfb1906132114c7b (diff)
downloadports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.tar.gz
ports-34fa6c853efa04ca648d3d4187d4aec40a00fc0d.zip
Split the postgresql ports into a server and a client part.
All ports depending on postgresql shall use the USE_PGSQL=yes knob defined in Mk/bsd.ports.mk. Bumping portrevisions where needed. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Notes
Notes: svn path=/head/; revision=127737
Diffstat (limited to 'databases/libgda2')
-rw-r--r--databases/libgda2/Makefile29
1 files changed, 6 insertions, 23 deletions
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index a801be2962ad..9028bea115c0 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -48,11 +48,7 @@ WITH_MYSQL= yes
.endif
.if exists(${LOCALBASE}/lib/libpq.so.3)
-WITH_POSTGRES7= yes
-.endif
-
-.if exists(${LOCALBASE}/lib/libpgeasy.so.2)
-WITH_POSTGRES72=yes
+WITH_PGSQL= yes
.endif
.if exists(${LOCALBASE}/lib/libldap.so.2)
@@ -92,21 +88,11 @@ CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
PLIST_SUB+= MYSQL:=""
.endif
-.if !defined(WITHOUT_POSTGRES7) && defined(WITH_POSTGRES7)
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
-CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
-PLIST_SUB+= POSTGRES:=""
-.endif
-
-.if !defined(WITHOUT_POSTGRES72) && defined(WITH_POSTGRES72)
-POSTGRESQL_PORT?= databases/postgresql72
-LIB_DEPENDS+= pgeasy.2:${PORTSDIR}/${POSTGRESQL_PORT}
+.if !defined(WITHOUT_PGSQL) && defined(WITH_PGSQL)
+USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgres=${LOCALBASE}
PLIST_SUB+= POSTGRES:=""
-.endif
-
-.if !defined(WITH_POSTGRES7) && !defined(WITH_POSTGRES72)
+.else
PLIST_SUB+= POSTGRES:="@comment "
CONFIGURE_ARGS+= --without-postgres
.endif
@@ -178,11 +164,8 @@ pre-everything::
.if !defined(WITH_MYSQL)
@${ECHO_MSG} "You can enable support for MySQL databases by defining WITH_MYSQL."
.endif
-.if !defined(WITH_POSTGRES7)
- @${ECHO_MSG} "You can enable support for Postgres 7.0 databases by defining WITH_POSTGRES7."
-.endif
-.if !defined(WITH_POSTGRES72)
- @${ECHO_MSG} "You can enable support for Postgres 7.2 databases by defining WITH_POSTGRES72."
+.if !defined(WITH_PGSQL)
+ @${ECHO_MSG} "You can enable support for PostgreSQL databases by defining WITH_PGSQL."
.endif
.if !defined(WITH_LDAP)
@${ECHO_MSG} "You can enable support for LDAP databases by defining WITH_LDAP."