aboutsummaryrefslogtreecommitdiff
path: root/databases/libgda2
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-01-17 04:15:23 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-01-17 04:15:23 +0000
commit7535020871412ebca856c0bde243555b7a48b647 (patch)
tree31d116cab018d734b2cc634657dac8915051b37f /databases/libgda2
parent02e41fe9e864a4ab39e47f21bfdf59f328fdd4e2 (diff)
downloadports-7535020871412ebca856c0bde243555b7a48b647.tar.gz
ports-7535020871412ebca856c0bde243555b7a48b647.zip
Update to 1.0.3.
Notes
Notes: svn path=/head/; revision=98367
Diffstat (limited to 'databases/libgda2')
-rw-r--r--databases/libgda2/Makefile7
-rw-r--r--databases/libgda2/distinfo2
-rw-r--r--databases/libgda2/files/patch-aa19
-rw-r--r--databases/libgda2/files/patch-libgda::gda-command.c13
4 files changed, 16 insertions, 25 deletions
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index f836b225ae10..d6576a9b207d 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libgda2
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/1.0
@@ -26,6 +26,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier glib20 libxslt
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
@@ -34,6 +35,10 @@ MAN5= gda-config.5
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/2$//}
+post-patch:
+ @${REINPLACE_CMD} -e "/^SUBDIRS =/s/testing//" \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so)
diff --git a/databases/libgda2/distinfo b/databases/libgda2/distinfo
index 18ca55bf3ce3..d43b068df00a 100644
--- a/databases/libgda2/distinfo
+++ b/databases/libgda2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libgda-1.0.2.tar.bz2) = c84cad90fb721c41fc6c47ee2829f4f0
+MD5 (gnome2/libgda-1.0.3.tar.bz2) = eb571389cd7624f362315d5180298263
diff --git a/databases/libgda2/files/patch-aa b/databases/libgda2/files/patch-aa
index a090fe088157..3b1f992512cd 100644
--- a/databases/libgda2/files/patch-aa
+++ b/databases/libgda2/files/patch-aa
@@ -1,11 +1,10 @@
---- Makefile.in.orig Thu Feb 6 23:01:24 2003
-+++ Makefile.in Thu Feb 6 23:01:54 2003
-@@ -164,7 +164,7 @@
- YACC = @YACC@
- cxxflags_set = @cxxflags_set@
+--- Makefile.in.orig Fri Jan 16 23:06:50 2004
++++ Makefile.in Fri Jan 16 23:07:18 2004
+@@ -276,7 +276,6 @@
+ providers \
+ report \
+ tools \
+- testing \
+ data \
+ doc
--SUBDIRS = po libsql libgda providers report tools testing data doc
-+SUBDIRS = po libsql libgda providers report tools data doc
-
-
- EXTRA_DIST = COPYING libgda.spec intltool-extract.in intltool-merge.in intltool-update.in
diff --git a/databases/libgda2/files/patch-libgda::gda-command.c b/databases/libgda2/files/patch-libgda::gda-command.c
deleted file mode 100644
index 55b4d468e563..000000000000
--- a/databases/libgda2/files/patch-libgda::gda-command.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- libgda/gda-command.c.orig Mon Dec 1 14:58:32 2003
-+++ libgda/gda-command.c Mon Dec 1 14:59:30 2003
-@@ -100,8 +100,9 @@
- GdaCommand *
- gda_command_copy (GdaCommand *cmd)
- {
-+ GdaCommand *new_cmd;
- g_return_val_if_fail (cmd != NULL, NULL);
-- GdaCommand *new_cmd = gda_command_new (gda_command_get_text (cmd),
-+ new_cmd = gda_command_new (gda_command_get_text (cmd),
- gda_command_get_command_type (cmd),
- gda_command_get_options (cmd));
- gda_command_set_transaction (new_cmd,