aboutsummaryrefslogtreecommitdiff
path: root/databases/libgda
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-08-06 10:58:00 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-08-06 10:58:00 +0000
commit4d89842b1c12b45d9480d97bc8762f5ca3a31306 (patch)
tree7873dcc8e307b4c69309c34e64d50519a9dc14d6 /databases/libgda
parent8a04d259ee084d0b79df486bb056dbda839abe07 (diff)
downloadports-4d89842b1c12b45d9480d97bc8762f5ca3a31306.tar.gz
ports-4d89842b1c12b45d9480d97bc8762f5ca3a31306.zip
Update to 0.2.90.
Notes
Notes: svn path=/head/; revision=45866
Diffstat (limited to 'databases/libgda')
-rw-r--r--databases/libgda/Makefile14
-rw-r--r--databases/libgda/distinfo2
-rw-r--r--databases/libgda/files/patch-bindings::perl::Makefile.in16
-rw-r--r--databases/libgda/files/patch-configure54
-rw-r--r--databases/libgda/files/patch-providers::gda-default-server::sqlite::tool::lemon.c14
-rw-r--r--databases/libgda/files/patch-tools::gda-buildserver.in14
-rw-r--r--databases/libgda/files/patch-tools::templates::Makefile.in14
-rw-r--r--databases/libgda/pkg-plist101
8 files changed, 76 insertions, 153 deletions
diff --git a/databases/libgda/Makefile b/databases/libgda/Makefile
index d5655f589dee..9d56ac93c295 100644
--- a/databases/libgda/Makefile
+++ b/databases/libgda/Makefile
@@ -6,28 +6,24 @@
#
PORTNAME= libgda
-PORTVERSION= 0.2.10
-PORTREVISION= 1
+PORTVERSION= 0.2.90
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-db
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv \
- gdbm.2:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm \
+ bonobo.2:${PORTSDIR}/devel/bonobo
+USE_X_PREFIX= yes
USE_GNOMECTRL= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -lgdbm"
-MAN3= Gnome::GDA::Client.3 Gnome::GDA::Common.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
diff --git a/databases/libgda/distinfo b/databases/libgda/distinfo
index 3ef9eda29205..5e2402338dd8 100644
--- a/databases/libgda/distinfo
+++ b/databases/libgda/distinfo
@@ -1 +1 @@
-MD5 (libgda-0.2.10.tar.gz) = 07af13d295e15f2b779c8d3909b20846
+MD5 (libgda-0.2.90.tar.gz) = e36b77f0db0ffd60a257e007ea914c5d
diff --git a/databases/libgda/files/patch-bindings::perl::Makefile.in b/databases/libgda/files/patch-bindings::perl::Makefile.in
deleted file mode 100644
index 0822ed6c061c..000000000000
--- a/databases/libgda/files/patch-bindings::perl::Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- bindings/perl/Makefile.in.orig Tue Jun 19 02:01:09 2001
-+++ bindings/perl/Makefile.in Tue Jun 19 02:05:09 2001
-@@ -254,4 +254,4 @@
- all:
-- cd Gnome/GDA/Common && perl Makefile.PL && make
-- cd Gnome/GDA/Client && perl Makefile.PL && make
-+ cd Gnome/GDA/Common && perl Makefile.PL && ${MAKE}
-+ cd Gnome/GDA/Client && perl Makefile.PL && ${MAKE}
-
-@@ -259,4 +259,4 @@
- install-data-local:
-- cd Gnome/GDA/Common && make install
-- cd Gnome/GDA/Client && make install
-+ cd Gnome/GDA/Common && ${MAKE} install
-+ cd Gnome/GDA/Client && ${MAKE} install
-
diff --git a/databases/libgda/files/patch-configure b/databases/libgda/files/patch-configure
index 29982c39abc5..9b06f29c68d6 100644
--- a/databases/libgda/files/patch-configure
+++ b/databases/libgda/files/patch-configure
@@ -1,56 +1,14 @@
$FreeBSD$
---- configure.orig Thu Jul 26 15:51:10 2001
-+++ configure Thu Jul 26 16:09:53 2001
-@@ -6238,7 +6240,7 @@
+--- configure 2001/08/06 08:32:35 1.1
++++ configure 2001/08/06 08:32:59
+@@ -8896,7 +8896,7 @@
--if test $perl_val == true; then
-+if test $perl_val = true; then
- WITH_PERL_TRUE=
- WITH_PERL_FALSE='#'
- else
-@@ -7909,7 +7911,7 @@
- #line 7910 "configure"
- #include "confdefs.h"
- #include <stdlib.h>
--#include <iconv.h>
-+#include <giconv.h>
- int main() {
- iconv_t cd = iconv_open("","");
- iconv(cd,NULL,NULL,NULL,NULL);
-@@ -7926,12 +7928,12 @@
- rm -f conftest*
- if test "$am_cv_func_iconv" != yes; then
- am_save_LIBS="$LIBS"
-- LIBS="$LIBS -liconv"
-+ LIBS="$LIBS -lgiconv"
- cat > conftest.$ac_ext <<EOF
- #line 7932 "configure"
- #include "confdefs.h"
- #include <stdlib.h>
--#include <iconv.h>
-+#include <giconv.h>
- int main() {
- iconv_t cd = iconv_open("","");
- iconv(cd,NULL,NULL,NULL,NULL);
-@@ -7969,7 +7971,7 @@
- #include "confdefs.h"
+-GDA_oafdir=`oaf-config --prefix`/share/oaf
++GDA_oafdir="${prefix}/share/gnome/oaf"
+
- #include <stdlib.h>
--#include <iconv.h>
-+#include <giconv.h>
- extern
- #ifdef __cplusplus
- "C"
-@@ -8007,7 +8009,7 @@
- fi
- LIBICONV=
- if test "$am_cv_lib_iconv" = yes; then
-- LIBICONV="-liconv"
-+ LIBICONV="-lgiconv"
- fi
-
diff --git a/databases/libgda/files/patch-providers::gda-default-server::sqlite::tool::lemon.c b/databases/libgda/files/patch-providers::gda-default-server::sqlite::tool::lemon.c
new file mode 100644
index 000000000000..694313e430ae
--- /dev/null
+++ b/databases/libgda/files/patch-providers::gda-default-server::sqlite::tool::lemon.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- providers/gda-default-server/sqlite/tool/lemon.c.orig Fri Aug 3 17:47:37 2001
++++ providers/gda-default-server/sqlite/tool/lemon.c Mon Aug 6 10:59:21 2001
+@@ -1327,7 +1327,7 @@
+ /*
+ ** Return a pointer to the next structure in the linked list.
+ */
+-#define NEXT(A) (*(char**)(((int)A)+offset))
++#define NEXT(A) (*(char**)(((long)A)+offset))
+
+ /*
+ ** Inputs:
diff --git a/databases/libgda/files/patch-tools::gda-buildserver.in b/databases/libgda/files/patch-tools::gda-buildserver.in
new file mode 100644
index 000000000000..fa75e2dcc31f
--- /dev/null
+++ b/databases/libgda/files/patch-tools::gda-buildserver.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- tools/gda-buildserver.in 2001/08/06 08:16:41 1.1
++++ tools/gda-buildserver.in 2001/08/06 08:16:54
+@@ -7,7 +7,7 @@
+ CC=@CC@
+ shell=@shell@
+
+-TEMPLATES_DIR="${prefix}/share/gda/templates"
++TEMPLATES_DIR="${prefix}/share/gnome/gda/templates"
+ TMPL_C_FILES="gda-srv-command.c gda-srv-connection.c gda-srv-recordset.c main-srv.c"
+ TMPL_H_FILES="gda-srv.h"
+
diff --git a/databases/libgda/files/patch-tools::templates::Makefile.in b/databases/libgda/files/patch-tools::templates::Makefile.in
new file mode 100644
index 000000000000..2ca62bfb551d
--- /dev/null
+++ b/databases/libgda/files/patch-tools::templates::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- tools/templates/Makefile.in 2001/08/06 08:15:18 1.1
++++ tools/templates/Makefile.in 2001/08/06 08:15:53
+@@ -148,7 +148,7 @@
+
+ EXTRA_DIST = $(TEMPLATE_FILES)
+
+-gdatemplatesdir = $(prefix)/share/gda/templates
++gdatemplatesdir = $(prefix)/share/gnome/gda/templates
+ gdatemplates_DATA = $(TEMPLATE_FILES)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../config.h
diff --git a/databases/libgda/pkg-plist b/databases/libgda/pkg-plist
index f66db28d66d2..0c0e37f2c5bd 100644
--- a/databases/libgda/pkg-plist
+++ b/databases/libgda/pkg-plist
@@ -16,6 +16,7 @@ include/gda/gda++/gdaValue.h
include/gda/gda-batch.h
include/gda/gda-client.h
include/gda/gda-command.h
+include/gda/gda-common-defs.h
include/gda/gda-common.h
include/gda/gda-config.h
include/gda/gda-connection-pool.h
@@ -24,15 +25,26 @@ include/gda/gda-corba.h
include/gda/gda-error.h
include/gda/gda-export.h
include/gda/gda-field.h
+include/gda/gda-listener.h
include/gda/gda-log.h
+include/gda/gda-quark-list.h
include/gda/gda-recordset.h
-include/gda/gda-server-impl.h
+include/gda/gda-server-command.h
+include/gda/gda-server-connection.h
+include/gda/gda-server-error.h
+include/gda/gda-server-field.h
+include/gda/gda-server-recordset.h
include/gda/gda-server.h
include/gda/gda-thread.h
include/gda/gda-util.h
include/gda/gda-value.h
+include/gda/gda-xml-atom-item.h
+include/gda/gda-xml-bin-item.h
include/gda/gda-xml-database.h
-include/gda/gda-xml-file.h
+include/gda/gda-xml-document.h
+include/gda/gda-xml-item.h
+include/gda/gda-xml-list-item.h
+include/gda/gda-xml-util.h
lib/libgda-client.a
lib/libgda-client.so
lib/libgda-client.so.0
@@ -45,21 +57,11 @@ lib/libgda-common.so.0
lib/libgda-server.a
lib/libgda-server.so
lib/libgda-server.so.0
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/GDA/Client.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/GDA/Common.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Client/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Client/Client.bs
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Client/Client.so
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Client/autosplit.ix
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Common/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Common/Common.bs
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Common/Common.so
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Common/autosplit.ix
-share/gda/templates/gda-srv-command.c.tmpl
-share/gda/templates/gda-srv-connection.c.tmpl
-share/gda/templates/gda-srv-recordset.c.tmpl
-share/gda/templates/gda-srv.h.tmpl
-share/gda/templates/main-srv.c.tmpl
+share/gnome/gda/templates/gda-srv-command.c.tmpl
+share/gnome/gda/templates/gda-srv-connection.c.tmpl
+share/gnome/gda/templates/gda-srv-recordset.c.tmpl
+share/gnome/gda/templates/gda-srv.h.tmpl
+share/gnome/gda/templates/main-srv.c.tmpl
share/gnome/help/libgda/C/architecture.html
share/gnome/help/libgda/C/clients-building-corba.html
share/gnome/help/libgda/C/clients-building.html
@@ -99,75 +101,22 @@ share/gnome/help/libgda/C/providers-implementation.html
share/gnome/help/libgda/C/providers.html
share/gnome/help/libgda/C/reports.html
share/gnome/help/libgda/C/topic.dat
-share/gnome/help/libgda/es/architecture.html
-share/gnome/help/libgda/es/clients-building-corba.html
-share/gnome/help/libgda/es/clients-building.html
-share/gnome/help/libgda/es/clients.html
-share/gnome/help/libgda/es/docbook.css
-share/gnome/help/libgda/es/gda-client-batch.html
-share/gnome/help/libgda/es/gda-client-meta.html
-share/gnome/help/libgda/es/gda-client-objects.html
-share/gnome/help/libgda/es/gda-client-types.html
-share/gnome/help/libgda/es/gda-client.html
-share/gnome/help/libgda/es/gda-common-logs.html
-share/gnome/help/libgda/es/gda-common-xml-databases.html
-share/gnome/help/libgda/es/gda-common-xml-queries.html
-share/gnome/help/libgda/es/gda-common.html
-share/gnome/help/libgda/es/index.html
-share/gnome/help/libgda/es/installation-configuring.html
-share/gnome/help/libgda/es/installation-installing.html
-share/gnome/help/libgda/es/installation.html
-share/gnome/help/libgda/es/introduction.html
-share/gnome/help/libgda/es/ln47.html
-share/gnome/help/libgda/es/providers-actual-implementation.html
-share/gnome/help/libgda/es/providers-examples.html
-share/gnome/help/libgda/es/providers-implementation.html
-share/gnome/help/libgda/es/providers.html
-share/gnome/help/libgda/es/reports.html
share/gnome/help/libgda/es/topic.dat
-share/gnome/help/libgda/pt_BR/architecture.html
-share/gnome/help/libgda/pt_BR/c162.html
-share/gnome/help/libgda/pt_BR/c182.html
-share/gnome/help/libgda/pt_BR/c323.html
-share/gnome/help/libgda/pt_BR/c350.html
-share/gnome/help/libgda/pt_BR/clients-building-corba.html
-share/gnome/help/libgda/pt_BR/clients-building.html
-share/gnome/help/libgda/pt_BR/docbook.css
-share/gnome/help/libgda/pt_BR/gda-client-batch.html
-share/gnome/help/libgda/pt_BR/gda-client-meta.html
-share/gnome/help/libgda/pt_BR/gda-client-objects.html
-share/gnome/help/libgda/pt_BR/gda-client-types.html
-share/gnome/help/libgda/pt_BR/gda-common-logs.html
-share/gnome/help/libgda/pt_BR/gda-common-xml-databases.html
-share/gnome/help/libgda/pt_BR/gda-common-xml-queries.html
-share/gnome/help/libgda/pt_BR/index.html
-share/gnome/help/libgda/pt_BR/installation-configuring.html
-share/gnome/help/libgda/pt_BR/installation-installing.html
-share/gnome/help/libgda/pt_BR/installation.html
-share/gnome/help/libgda/pt_BR/introduction.html
-share/gnome/help/libgda/pt_BR/libgda.html
-share/gnome/help/libgda/pt_BR/ln38.html
-share/gnome/help/libgda/pt_BR/providers-actual-implementation.html
-share/gnome/help/libgda/pt_BR/providers-examples.html
-share/gnome/help/libgda/pt_BR/providers-implementation.html
share/gnome/help/libgda/pt_BR/topic.dat
-share/gnome/html/libgda-client-decl.txt
share/gnome/html/libgda-client-sections.txt
share/gnome/html/libgda-client.args
share/gnome/html/libgda-client.hierarchy
-share/gnome/html/libgda-client.signals
share/gnome/html/libgda-client.types
-share/gnome/html/libgda-common-decl.txt
share/gnome/html/libgda-common-sections.txt
share/gnome/html/libgda-common.args
share/gnome/html/libgda-common.hierarchy
-share/gnome/html/libgda-common.signals
share/gnome/html/libgda-common.types
share/gnome/idl/GDA.idl
share/gnome/idl/GDA_Command.idl
share/gnome/idl/GDA_Connection.idl
share/gnome/idl/GDA_Error.idl
share/gnome/idl/GDA_Field.idl
+share/gnome/idl/GDA_Listener.idl
share/gnome/idl/GDA_Parameter.idl
share/gnome/idl/GDA_Recordset.idl
share/gnome/oaf/GNOME_GDA_Provider_Default.oaf
@@ -199,13 +148,7 @@ share/locale/uk/LC_MESSAGES/libgda.mo
@dirrm share/gnome/help/libgda/C/images
@dirrm share/gnome/help/libgda/C
@dirrm share/gnome/help/libgda
-@dirrm share/gda/templates
-@dirrm share/gda
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Common
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA/Client
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/GDA
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/GDA
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome
+@dirrm share/gnome/gda/templates
+@dirrm share/gnome/gda
@dirrm include/gda/gda++
@dirrm include/gda