aboutsummaryrefslogtreecommitdiff
path: root/databases/libnvpair/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-09-30 10:28:55 +0000
committerJohn Marino <marino@FreeBSD.org>2015-09-30 10:28:55 +0000
commit5df261c393503a49aab82fe23ebc81f7d4ae1219 (patch)
tree0d7c54ccc27c44c22036ef1b89aa9fd3c7ce37bf /databases/libnvpair/Makefile
parent5513b0c05eef090eb9238f97398de62953cf3307 (diff)
downloadports-5df261c393503a49aab82fe23ebc81f7d4ae1219.tar.gz
ports-5df261c393503a49aab82fe23ebc81f7d4ae1219.zip
Add new port databases/libnvpair
libnvpair is a name-value pair library originating from Solaris The nvpair library was released in OpenSolaris and has been extended by the Illumos project. It exports a set of functions used for managing name-value pairs. This is a base library for Solaris and its descendents. However, the kernel-specific code has been removed thus libnvpair is strictly meant for the userland. The XDR functionality has been masked for now due to RPC differences between *BSD and Illumos.
Notes
Notes: svn path=/head/; revision=398211
Diffstat (limited to 'databases/libnvpair/Makefile')
-rw-r--r--databases/libnvpair/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/databases/libnvpair/Makefile b/databases/libnvpair/Makefile
new file mode 100644
index 000000000000..df65c9cd8728
--- /dev/null
+++ b/databases/libnvpair/Makefile
@@ -0,0 +1,22 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libnvpair
+PORTVERSION= 1.0.2
+CATEGORIES= databases devel
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Illumos name-value pair library
+
+LICENSE= CDDL
+
+GH_ACCOUNT= jrmarino
+USE_GITHUB= yes
+
+MAKE_ARGS= LIBDIR=${PREFIX}/lib
+
+post-install:
+ (cd ${WRKSRC} && ${INSTALL_DATA} libnvpair.h nvpair.h \
+ nvpair_type_compat.h ${STAGEDIR}${PREFIX}/include/)
+
+.include <bsd.port.mk>