aboutsummaryrefslogtreecommitdiff
path: root/databases/mongodb/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-10-29 15:48:39 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-10-29 15:48:39 +0000
commitb5728a5b235d5d228afeeda0e941b596e67d0340 (patch)
treeb028852772f473f24166647ef98b871692ce27fc /databases/mongodb/Makefile
parent43bf815f1612c76ba601905a9de36b14614abdcd (diff)
downloadports-b5728a5b235d5d228afeeda0e941b596e67d0340.tar.gz
ports-b5728a5b235d5d228afeeda0e941b596e67d0340.zip
Update to 2.4.7 release and fix build with clang [1].
PR: ports/182110 [1] Submitted by: Florent Peterschmitt <florent@peterschmitt.fr>
Notes
Notes: svn path=/head/; revision=331962
Diffstat (limited to 'databases/mongodb/Makefile')
-rw-r--r--databases/mongodb/Makefile37
1 files changed, 18 insertions, 19 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 073d7a62d86b..7a58a7f60be0 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mongodb
-PORTVERSION= 2.4.6
+PORTVERSION= 2.4.7
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
@@ -14,11 +14,11 @@ COMMENT= NOSQL distributed document-oriented database
LICENSE= AGPLv3 AL2
LICENSE_COMB= multi
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
- pcre:${PORTSDIR}/devel/pcre \
- snappy:${PORTSDIR}/archivers/snappy
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libsnappy.so:${PORTSDIR}/archivers/snappy
# boost 1.52 from ports make mongod segfaulting with many tests
-# LIB_DEPENDS+= boost_system:${PORTSDIR}/devel/boost-libs
+# LIB_DEPENDS+= libboost_system.so:${PORTSDIR}/devel/boost-libs
# SCONS_ARGS+= --use-system-boost
ONLY_FOR_ARCHS= i386 amd64
@@ -30,7 +30,7 @@ SM_DESC= Use SpiderMonkey instead of V8 for JavaScript
TEST_DESC= Add support for running regression test
USE_SCONS= yes
-SCONS_ARGS= --prefix=${PREFIX} --cc=${CC} --cxx=${CXX} \
+SCONS_ARGS= --prefix=${STAGEDIR}${PREFIX} --cc=${CC} --cxx=${CXX} \
--use-system-pcre --use-system-snappy \
--full --sharedclient
@@ -39,17 +39,14 @@ GROUPS= mongodb
USE_RC_SUBR= mongod
-USE_LDCONFIG= yes
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSM}
SCONS_ARGS+= --usesm --use-system-sm
-LIB_DEPENDS+= js:${PORTSDIR}/lang/spidermonkey17
+LIB_DEPENDS+= libjs.so:${PORTSDIR}/lang/spidermonkey17
.else
SCONS_ARGS+= --usev8 --use-system-v8
-LIB_DEPENDS+= v8:${PORTSDIR}/lang/v8
+LIB_DEPENDS+= libv8.so:${PORTSDIR}/lang/v8
.endif
.if ${PORT_OPTIONS:MSSL}
@@ -59,7 +56,7 @@ SCONS_ARGS+= --ssl
.if ${PORT_OPTIONS:MSASL}
SCONS_ARGS+= --use-sasl-client
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.endif
.if ${PORT_OPTIONS:MTEST}
@@ -73,17 +70,19 @@ SMOKE_TESTS+= smokeSsl
SCONS_TARGET= core tools
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1000024
+EXTRA_PATCHES= ${PATCHDIR}/clang-patch-src_mongo_db_fts_stemmer.cpp \
+ ${PATCHDIR}/clang-patch-src_mongo_platform_unordered_map.h \
+ ${PATCHDIR}/clang-patch-src_mongo_platform_unordered_set.h \
+ ${PATCHDIR}/clang-patch-src_third_party_s2_hash.h
+.endif
+
post-patch:
@${REINPLACE_CMD} 's/\["-O3"\]/"${CFLAGS}"/' \
${WRKSRC}/SConstruct
-post-install:
- @${LN} -s ${PREFIX}/lib/libmongoclient.so \
- ${PREFIX}/lib/libmongoclient.so.0
- @if [ ! -f ${PREFIX}/etc/mongodb.conf ]; then \
- ${TOUCH} ${PREFIX}/etc/mongodb.conf ; \
- fi
-
.if ${PORT_OPTIONS:MTEST}
test: build-depends build
@cd ${BUILD_WRKSRC} && \