aboutsummaryrefslogtreecommitdiff
path: root/databases/mongodb/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-04-23 13:45:28 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-04-23 13:45:28 +0000
commitd9f8ef49a22d310705c4997a74d6d2a0f60c636b (patch)
treeb0a98ea68245893c539c05349840c27672f03566 /databases/mongodb/Makefile
parent41a6f452d82e58cce3e72349ad7a4db0ac731671 (diff)
downloadports-d9f8ef49a22d310705c4997a74d6d2a0f60c636b.tar.gz
ports-d9f8ef49a22d310705c4997a74d6d2a0f60c636b.zip
- Update from 1.6.5 to 1.8.1 [1]
- Attached a patch to fix the TERM handling issue in SConstruct [1] - Added "ldconfig" to the rc.d script to start mongod correctly if running in a jail [1] - Remove unsupported FreeBSD version stuff - Replace pkg-install and pkg-deinstall with USERS and GROUPS in Makefile PR: ports/156297 [1] Submitted by: Mirko Zinn <mail AT derzinn.de> (maintainer)
Notes
Notes: svn path=/head/; revision=273103
Diffstat (limited to 'databases/mongodb/Makefile')
-rw-r--r--databases/mongodb/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index e79d17257441..45ce6b55e502 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= mongodb
-PORTVERSION= 1.6.5
-PORTREVISION= 1
+PORTVERSION= 1.8.1
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/ \
- http://derzinn.de/files/
+ http://files.derzinn.de/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
MAINTAINER= mail@derzinn.de
@@ -31,14 +30,13 @@ USE_SCONS= yes
SCONS_TARGET= all
SCONS_ARGS= --prefix=${PREFIX}
+USERS= mongodb
+GROUPS= mongodb
+
USE_RC_SUBR= mongod
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700042
-BROKEN= Does not build
-.endif
-
.if defined(WITH_DEVEL)
SCONS_ARGS+= --full
PLIST_SUB+= DEVEL=""
@@ -56,6 +54,4 @@ post-install:
${TOUCH} ${PREFIX}/etc/mongodb.conf ; \
fi
- PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
.include <bsd.port.post.mk>