aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql2odbc
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-09-13 11:38:17 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-09-13 11:38:17 +0000
commit78d3b664fcbda9dc627dea8dbd845729e179fd85 (patch)
tree69bc1c2092c5d57e808c2edc23f40f9149260c7b /databases/mysql2odbc
parentf4fca100494cf79f2bc0762dfead33f39879d4b1 (diff)
downloadports-78d3b664fcbda9dc627dea8dbd845729e179fd85.tar.gz
ports-78d3b664fcbda9dc627dea8dbd845729e179fd85.zip
- Fix build on RELENG_4 [1]
- Fix build with iODBC - Bump PORTREVISION Found by: kris (via pointyhat) [1]
Notes
Notes: svn path=/head/; revision=142578
Diffstat (limited to 'databases/mysql2odbc')
-rw-r--r--databases/mysql2odbc/Makefile10
-rw-r--r--databases/mysql2odbc/files/patch-mtest.c12
2 files changed, 17 insertions, 5 deletions
diff --git a/databases/mysql2odbc/Makefile b/databases/mysql2odbc/Makefile
index a6eb3aa04dd1..0f6338836bda 100644
--- a/databases/mysql2odbc/Makefile
+++ b/databases/mysql2odbc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mysql2odbc
PORTVERSION= 0.99.2
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.iodbc.org/downloads/mysql2odbc/
@@ -16,10 +17,16 @@ COMMENT= Openlink MySQL-ODBC Gateway
OPTIONS= UNIXODBC "Build with unixODBC" on \
IODBC "Build with iODBC" off \
+.include <bsd.port.pre.mk>
+
.if !defined(WITH_UNIXODBC) && !defined(WITH_IODBC)
WITH_UNIXODBC= yes
.endif
+.if defined(WITH_UNIXODBC) && defined(WITH_IODBC)
+.error "UNIXODBC and IODBC options are mutually exclusive"
+.endif
+
.if defined(WITH_UNIXODBC)
LIB_DEPENDS= odbc:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS= --with-unixodbc=${LOCALBASE}
@@ -32,9 +39,10 @@ CONFIGURE_ARGS= --with-iodbc
CONFIGURE_ARGS+=--libdir=${PREFIX}/mysql2odbc
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:13
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/mysql2odbc/files/patch-mtest.c b/databases/mysql2odbc/files/patch-mtest.c
index ff3cadcdf7d5..00a90f75e87f 100644
--- a/databases/mysql2odbc/files/patch-mtest.c
+++ b/databases/mysql2odbc/files/patch-mtest.c
@@ -1,6 +1,6 @@
---- mtest.c.orig Sat Aug 20 16:05:55 2005
-+++ mtest.c Sat Aug 20 16:06:01 2005
-@@ -27,7 +27,7 @@
+--- mtest.c.orig Fri Jun 20 21:39:48 2003
++++ mtest.c Tue Sep 13 18:21:18 2005
+@@ -27,10 +27,10 @@
#include <stdio.h>
#include <string.h>
#include <memory.h>
@@ -8,4 +8,8 @@
+#include <stdlib.h>
#ifndef WIN32
- # include <getopt.h>
+-# include <getopt.h>
++# include <unistd.h>
+ #endif
+
+ #ifdef FAKE