aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql40-server
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-03-25 23:39:43 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-03-25 23:39:43 +0000
commitc6a95a3a851f5dd0768d01622aeaa27969881c28 (patch)
treedee2a876923900c14f4b1f66f1b8de23012b0229 /databases/mysql40-server
parent48bb88dc2ed32049d8e5d98d3adf490265f971bc (diff)
downloadports-c6a95a3a851f5dd0768d01622aeaa27969881c28.tar.gz
ports-c6a95a3a851f5dd0768d01622aeaa27969881c28.zip
o Build thread-safe libs by default.
o Fix pkg-plist. o Bump PORTREVISION accordingly. PR: ports/50293 Submitted by: Alex Dupre <sysadmin@alexdupre.com> (maintainer)
Notes
Notes: svn path=/head/; revision=77464
Diffstat (limited to 'databases/mysql40-server')
-rw-r--r--databases/mysql40-server/Makefile6
-rw-r--r--databases/mysql40-server/pkg-plist.client3
2 files changed, 5 insertions, 4 deletions
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index 7366666f55dd..0a519bcc2c15 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -44,7 +44,8 @@ CONFIGURE_ARGS= --localstatedir=${DB_DIR} \
--with-mysqlfs \
--with-vio \
--with-low-memory \
- --with-comment='FreeBSD port: ${PKGNAME}'
+ --with-comment='FreeBSD port: ${PKGNAME}' \
+ --enable-thread-safe-client
.include <bsd.port.pre.mk>
@@ -79,9 +80,6 @@ LIB_DEPENDS+= lthread.3:${PORTSDIR}/devel/linuxthreads
LIB_DEPENDS+= lthread.2:${PORTSDIR}/devel/linuxthreads
.endif
.endif
-.if defined(THREAD_SAFE_CLIENT)
-CONFIGURE_ARGS+=--enable-thread-safe-client
-.endif
CFLAGS+= -O3 -fno-omit-frame-pointer
CXXFLAGS= ${CFLAGS} -felide-constructors -fno-rtti
diff --git a/databases/mysql40-server/pkg-plist.client b/databases/mysql40-server/pkg-plist.client
index b41d52e39413..42c5460fc13e 100644
--- a/databases/mysql40-server/pkg-plist.client
+++ b/databases/mysql40-server/pkg-plist.client
@@ -36,5 +36,8 @@ include/mysql/sslopt-vars.h
lib/mysql/libmysqlclient.a
lib/mysql/libmysqlclient.so
lib/mysql/libmysqlclient.so.12
+lib/mysql/libmysqlclient_r.a
+lib/mysql/libmysqlclient_r.so
+lib/mysql/libmysqlclient_r.so.12
@dirrm include/mysql
@dirrm lib/mysql