aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql51-server
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2007-05-20 08:31:37 +0000
committerAlex Dupre <ale@FreeBSD.org>2007-05-20 08:31:37 +0000
commitc1d34f294df7880a5c4df220cf5152ed91202ce7 (patch)
treef3ee142ae9577e75b83909764cf7546d5b8042ee /databases/mysql51-server
parent7339636d9c936f4f8472b8f498d63b5338f4d0bd (diff)
downloadports-c1d34f294df7880a5c4df220cf5152ed91202ce7.tar.gz
ports-c1d34f294df7880a5c4df220cf5152ed91202ce7.zip
Update to 5.1.18 release and drop support for FreeBSD < 5.
Approved by: portmgr (linimon)
Notes
Notes: svn path=/head/; revision=191566
Diffstat (limited to 'databases/mysql51-server')
-rw-r--r--databases/mysql51-server/Makefile30
-rw-r--r--databases/mysql51-server/distinfo6
-rw-r--r--databases/mysql51-server/files/mysql-server.sh.in2
-rw-r--r--databases/mysql51-server/files/patch-Makefile.in14
-rw-r--r--databases/mysql51-server/files/patch-scripts::Makefile.in18
-rw-r--r--databases/mysql51-server/pkg-plist1
-rw-r--r--databases/mysql51-server/pkg-plist.client6
7 files changed, 25 insertions, 52 deletions
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 88112498a6bb..3a190fea847a 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= mysql
-PORTVERSION= 5.1.17
+PORTVERSION= 5.1.18
PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
@@ -66,35 +66,19 @@ CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE
CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads
-.if ${OSVERSION} > 500000
LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
.else
-LIB_DEPENDS+= lthread.[24]:${PORTSDIR}/devel/linuxthreads
-CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r'
-.endif
-.else
CONFIGURE_ARGS+=--with-named-thread-libs=${PTHREAD_LIBS}
CFLAGS+= ${PTHREAD_CFLAGS}
.endif
-.if ${OSVERSION} < 500000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CXX= ${CC}
-.endif
.if defined(BUILD_OPTIMIZED)
CFLAGS+= -O3 -fno-omit-frame-pointer
-.if ${OSVERSION} > 500000 || (defined(USE_GCC) && (${USE_GCC} == 3.0 || ${USE_GCC} == 3.1 || ${USE_GCC} == 3.2 || ${USE_GCC} == 3.3))
CFLAGS+= -fno-gcse
.endif
-.endif
CXXFLAGS+= ${CFLAGS} -felide-constructors -fno-rtti
-.if ${OSVERSION} >= 400002
CXXFLAGS+= -fno-exceptions
-.endif
# MySQL-Server part
.if !defined(CLIENT_ONLY) && !defined(SCRIPTS_ONLY)
@@ -138,8 +122,7 @@ pre-fetch:
@${ECHO} ""
post-patch:
- @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ @zlib_dir@ @sql_server_dirs@ storage @sql_server@ scripts @man_dirs@ support-files|g" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s|all: config.h|all: config.h all-local|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ sql-common @sql_server_dirs@ storage scripts @sql_server@ @man_dirs@ support-files|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = fill_help_tables.sql mysql_system_tables.sql mysql_system_tables_data.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man1_MANS =|man1_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
@@ -172,16 +155,9 @@ USE_LDCONFIG= ${PREFIX}/lib/mysql
CONFIGURE_ARGS+=--without-server
-.if ${OSVERSION} < 500000
-PLIST_SUB+= ZLIB=""
-.else
-PLIST_SUB+= ZLIB="@comment "
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @zlib_dir@ strings mysys dbug extra regex libmysql_r libmysql client scripts @man_dirs@|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include sql-common scripts strings regex mysys dbug extra libmysql libmysql_r client @man_dirs@|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|install-exec-am: install-pkglibLIBRARIES|install-exec-am:|g" ${WRKSRC}/strings/Makefile.in ${WRKSRC}/mysys/Makefile.in ${WRKSRC}/dbug/Makefile.in
- @${REINPLACE_CMD} -e "s|all: config.h|all: config.h all-local|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = mysql_config mysql_fix_privilege_tables mysqlbug|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = mysql_fix_privilege_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man1_MANS =|man1_MANS = ${MAN1}|g;s|man8_MANS =|man8_MANS = ${MAN8}|g" ${WRKSRC}/man/Makefile.in
diff --git a/databases/mysql51-server/distinfo b/databases/mysql51-server/distinfo
index 8e32b91063a2..872dfba5845e 100644
--- a/databases/mysql51-server/distinfo
+++ b/databases/mysql51-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (mysql-5.1.17-beta.tar.gz) = 9b4db997883f5d9e1c1d4efbe6f112d2
-SHA256 (mysql-5.1.17-beta.tar.gz) = a3c49507f92a191ec0dfd5a2c85ddb819b24de1d5c08046e2fe527a2a394a8ba
-SIZE (mysql-5.1.17-beta.tar.gz) = 22646581
+MD5 (mysql-5.1.18-beta.tar.gz) = 50aace960b9489e5d57be4224755cdf4
+SHA256 (mysql-5.1.18-beta.tar.gz) = da5d8869211fbd0349c287615ec1371a1c38522e0ce3f8d67b61a08b1bdd3e4d
+SIZE (mysql-5.1.18-beta.tar.gz) = 25037302
diff --git a/databases/mysql51-server/files/mysql-server.sh.in b/databases/mysql51-server/files/mysql-server.sh.in
index 3b5439c44407..2caa4dc176e1 100644
--- a/databases/mysql51-server/files/mysql-server.sh.in
+++ b/databases/mysql51-server/files/mysql-server.sh.in
@@ -44,7 +44,7 @@ mysql_install_db_args="--ldata=${mysql_dbdir}"
mysql_create_auth_tables()
{
- eval $mysql_install_db $mysql_install_db_args >/dev/null
+ eval $mysql_install_db $mysql_install_db_args >/dev/null 2>/dev/null
[ $? -eq 0 ] && chown -R ${mysql_user}:${mysql_user} ${mysql_dbdir}
}
diff --git a/databases/mysql51-server/files/patch-Makefile.in b/databases/mysql51-server/files/patch-Makefile.in
index a8c65305f19f..dc92a178a9e8 100644
--- a/databases/mysql51-server/files/patch-Makefile.in
+++ b/databases/mysql51-server/files/patch-Makefile.in
@@ -1,18 +1,18 @@
---- Makefile.in.orig Wed Dec 6 18:07:33 2006
-+++ Makefile.in Sun Dec 31 12:03:09 2006
-@@ -395,14 +395,7 @@
+--- Makefile.in.orig Tue May 8 11:43:16 2007
++++ Makefile.in Thu May 17 09:28:15 2007
+@@ -396,14 +396,7 @@
EXTRA_DIST = INSTALL-SOURCE INSTALL-WIN-SOURCE \
README COPYING EXCEPTIONS-CLIENT CMakeLists.txt
-SUBDIRS = . include @docs_dirs@ @zlib_dir@ \
-- @readline_topdir@ sql-common \
+- @readline_topdir@ sql-common scripts \
- @thread_dirs@ pstack \
- @sql_union_dirs@ unittest storage plugin \
-- @sql_server@ scripts @man_dirs@ tests \
+- @sql_server@ @man_dirs@ tests \
- netware @libmysqld_dirs@ \
- mysql-test support-files sql-bench @tools_dirs@ \
- win
+SUBDIRS =
- DIST_SUBDIRS = $(SUBDIRS) BUILD
-
+ DIST_SUBDIRS = $(SUBDIRS) BUILD debian
+ DISTCLEANFILES = ac_available_languages_fragment
diff --git a/databases/mysql51-server/files/patch-scripts::Makefile.in b/databases/mysql51-server/files/patch-scripts::Makefile.in
index 03f2e5e10008..7881ee6f48dc 100644
--- a/databases/mysql51-server/files/patch-scripts::Makefile.in
+++ b/databases/mysql51-server/files/patch-scripts::Makefile.in
@@ -1,9 +1,9 @@
---- scripts/Makefile.in.orig Wed Apr 4 15:18:49 2007
-+++ scripts/Makefile.in Wed Apr 18 07:47:33 2007
-@@ -381,21 +381,7 @@
- yassl_libs = @yassl_libs@
- yassl_taocrypt_extra_cxxflags = @yassl_taocrypt_extra_cxxflags@
- zlib_dir = @zlib_dir@
+--- scripts/Makefile.in.orig Tue May 8 11:42:25 2007
++++ scripts/Makefile.in Thu May 17 09:30:48 2007
+@@ -399,21 +399,7 @@
+ BUILT_SOURCES = mysql_fix_privilege_tables.sql \
+ mysql_fix_privilege_tables_sql.c
+
-bin_SCRIPTS = @server_scripts@ \
- msql2mysql \
- mysql_config \
@@ -23,9 +23,9 @@
noinst_SCRIPTS = make_binary_distribution \
make_sharedlib_distribution
-@@ -425,11 +411,7 @@
- make_win_bin_dist \
- mysql_system_tables_fix.sql
+@@ -445,11 +431,7 @@
+ mysql_system_tables_fix.sql \
+ CMakeLists.txt
-dist_pkgdata_DATA = fill_help_tables.sql \
- mysql_fix_privilege_tables.sql \
diff --git a/databases/mysql51-server/pkg-plist b/databases/mysql51-server/pkg-plist
index dba505d28403..34575e52f7b3 100644
--- a/databases/mysql51-server/pkg-plist
+++ b/databases/mysql51-server/pkg-plist
@@ -132,7 +132,6 @@ libexec/mysqld
%%DATADIR%%/mysql-log-rotate
%%DATADIR%%/mysql.server
%%DATADIR%%/ndb-config-2-node.ini
-%%NDB%%%%DATADIR%%/ndb_size.tmpl
%%DATADIR%%/norwegian-ny/errmsg.sys
%%DATADIR%%/norwegian/errmsg.sys
%%DATADIR%%/polish/errmsg.sys
diff --git a/databases/mysql51-server/pkg-plist.client b/databases/mysql51-server/pkg-plist.client
index bfae5f4f2395..7a5f116809d1 100644
--- a/databases/mysql51-server/pkg-plist.client
+++ b/databases/mysql51-server/pkg-plist.client
@@ -11,11 +11,13 @@ bin/mysqlimport
bin/mysqlshow
bin/mysqlslap
bin/mysqltest
+include/mysql/decimal.h
include/mysql/errmsg.h
include/mysql/keycache.h
include/mysql/m_ctype.h
include/mysql/m_string.h
include/mysql/my_alloc.h
+include/mysql/my_attribute.h
include/mysql/my_config.h
include/mysql/my_dbug.h
include/mysql/my_dir.h
@@ -49,10 +51,6 @@ lib/mysql/libmysqlclient_r.a
lib/mysql/libmysqlclient_r.la
lib/mysql/libmysqlclient_r.so
lib/mysql/libmysqlclient_r.so.15
-%%ZLIB%%lib/mysql/libz.a
-%%ZLIB%%lib/mysql/libz.la
-%%ZLIB%%lib/mysql/libz.so
-%%ZLIB%%lib/mysql/libz.so.3
share/aclocal/mysql.m4
%%DATADIR%%/mysql_fix_privilege_tables.sql
@dirrm include/mysql