aboutsummaryrefslogtreecommitdiff
path: root/databases/mysqltcl
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-02-06 21:45:56 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-02-06 21:45:56 +0000
commit1917dcd0e778f05016857493ca316ca51cdedd61 (patch)
tree023ac9fa91478d8c2f46487ee5ff142687a45166 /databases/mysqltcl
parent53ad6f3a39ded43cc7a31d37bd783d36c4427ae5 (diff)
downloadports-1917dcd0e778f05016857493ca316ca51cdedd61.tar.gz
ports-1917dcd0e778f05016857493ca316ca51cdedd61.zip
Upgrade from 2.14 to 2.40. Some reorganization of the Makefile, while here.
Prodded by: SoD (at cd.pri.ee)
Notes
Notes: svn path=/head/; revision=100180
Diffstat (limited to 'databases/mysqltcl')
-rw-r--r--databases/mysqltcl/Makefile16
-rw-r--r--databases/mysqltcl/distinfo2
-rw-r--r--databases/mysqltcl/files/Makefile.bsd8
3 files changed, 13 insertions, 13 deletions
diff --git a/databases/mysqltcl/Makefile b/databases/mysqltcl/Makefile
index 82757d45ec43..455d2b9668e2 100644
--- a/databases/mysqltcl/Makefile
+++ b/databases/mysqltcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mysqltcl
-PORTVERSION= 2.14
+PORTVERSION= 2.40
CATEGORIES= databases tcl83
MASTER_SITES= http://www.xdobry.de/mysqltcl/
@@ -16,16 +16,16 @@ COMMENT= TCL module for accessing MySQL databases based on msqltcl
LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql323-client \
${TCL_NODOT}:${PORTSDIR}/lang/${TCL_NODOT}
-TCL_VERSION?= tcl8.3
+TCL_VERSION?= tcl8.4
TCL_NODOT= ${TCL_VERSION:S/.//}
SQL_DIR= ${PREFIX}/lib/${TCL_VERSION}/mysqltcl
PLIST_SUB+= TCL_VERSION=${TCL_VERSION} LIB_NAME=${LIB_NAME}
MANN= mysqltcl.n
-
-do-build:
- cd ${WRKSRC} && ${MAKE} PREFIX="${PREFIX}" \
- TCL_VERSION=${TCL_VERSION} TCL_NODOT=${TCL_NODOT} \
- -f ${FILESDIR}/Makefile.bsd ${LIB_NAME}
+MAKE_ENV+= PORTVERSION="${PORTVERSION}" \
+ TCL_VERSION="${TCL_VERSION}" \
+ TCL_NODOT="${TCL_NODOT}"
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+ALL_TARGET= shlib
do-install:
${MKDIR} ${SQL_DIR}
@@ -36,4 +36,4 @@ do-install:
.include <bsd.port.mk>
-LIB_NAME!= ${MAKE} -f ${FILESDIR}/Makefile.bsd -V SHLIB_NAME
+LIB_NAME!= ${MAKE_ENV} ${MAKE} -f ${FILESDIR}/Makefile.bsd -V SHLIB_NAME
diff --git a/databases/mysqltcl/distinfo b/databases/mysqltcl/distinfo
index 461708e92e2c..88c66607f66a 100644
--- a/databases/mysqltcl/distinfo
+++ b/databases/mysqltcl/distinfo
@@ -1 +1 @@
-MD5 (mysqltcl-2.14.tar.gz) = 9de2de463abd28968692ebb32b012e9d
+MD5 (mysqltcl-2.40.tar.gz) = efd5af57fdcaf22d32e05573e814e4be
diff --git a/databases/mysqltcl/files/Makefile.bsd b/databases/mysqltcl/files/Makefile.bsd
index 6587f847af63..1eef8065a549 100644
--- a/databases/mysqltcl/files/Makefile.bsd
+++ b/databases/mysqltcl/files/Makefile.bsd
@@ -1,8 +1,8 @@
.PATH: ${.CURDIR}/generic
LIB = mysqltcl
-SHLIB_MAJOR= 2
-SHLIB_MINOR= 14
+SHLIB_MAJOR= ${PORTVERSION:R}
+SHLIB_MINOR= ${PORTVERSION:E}
SRCS = mysqltcl.c
CFLAGS += -I${PREFIX}/include/${TCL_VERSION}/
@@ -11,6 +11,6 @@ LDADD += -L${PREFIX}/lib -l${TCL_NODOT}
LDADD += -L${PREFIX}/lib/mysql -lmysqlclient
CFLAGS += -DVERSION='"${SHLIB_MAJOR}.${SHLIB_MINOR}"'
-all: ${SHLIB_NAME}
-
.include <bsd.lib.mk>
+
+shlib: ${SHLIB_NAME}