aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Cache-BDB
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-23 06:51:04 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-23 06:51:04 +0000
commit16acd8f56c99e2f9bd815866412a55b50f0969dd (patch)
treeea130054b82cdac68422337f5c41d5f16435ef06 /databases/p5-Cache-BDB
parent44f1d8b402bf0b1e25f9e03c4673bee3dee99492 (diff)
downloadports-16acd8f56c99e2f9bd815866412a55b50f0969dd.tar.gz
ports-16acd8f56c99e2f9bd815866412a55b50f0969dd.zip
Add p5-Cache-BDB 0.04, an object caching wrapper around BerkeleyDB.
PR: ports/100711 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168535
Diffstat (limited to 'databases/p5-Cache-BDB')
-rw-r--r--databases/p5-Cache-BDB/Makefile30
-rw-r--r--databases/p5-Cache-BDB/distinfo3
-rw-r--r--databases/p5-Cache-BDB/pkg-descr8
-rw-r--r--databases/p5-Cache-BDB/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/databases/p5-Cache-BDB/Makefile b/databases/p5-Cache-BDB/Makefile
new file mode 100644
index 000000000000..7de09975c44e
--- /dev/null
+++ b/databases/p5-Cache-BDB/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Cache-BDB
+# Date created: 2006-07-22
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cache-BDB
+PORTVERSION= 0.04
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Cache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= An object caching wrapper around BerkeleyDB
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
+
+PERL_CONFIGURE= yes
+
+MAN3= Cache::BDB.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500700
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Cache-BDB/distinfo b/databases/p5-Cache-BDB/distinfo
new file mode 100644
index 000000000000..b53284b6f81b
--- /dev/null
+++ b/databases/p5-Cache-BDB/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cache-BDB-0.04.tar.gz) = 34f2de75f4eeb43459e1ddc2682c4f27
+SHA256 (Cache-BDB-0.04.tar.gz) = 1cfe7c4fc3663bad1cd233447f042f01543c8161d3b4b56f03a835965474c049
+SIZE (Cache-BDB-0.04.tar.gz) = 16467
diff --git a/databases/p5-Cache-BDB/pkg-descr b/databases/p5-Cache-BDB/pkg-descr
new file mode 100644
index 000000000000..0a5a259574b7
--- /dev/null
+++ b/databases/p5-Cache-BDB/pkg-descr
@@ -0,0 +1,8 @@
+This module implements a caching layer around BerkeleyDB for object
+persistence. It implements the basic methods necessary to add,
+retrieve, and remove objects. The main advantage over other caching
+modules is performance. I've attempted to stick with a
+Cache::Cache-like interface as much as possible, though it may differ
+here and there.
+
+WWW: http://search.cpan.org/dist/Cache-BDB/
diff --git a/databases/p5-Cache-BDB/pkg-plist b/databases/p5-Cache-BDB/pkg-plist
new file mode 100644
index 000000000000..5666f5ad0f26
--- /dev/null
+++ b/databases/p5-Cache-BDB/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache/BDB/.packlist
+%%SITE_PERL%%/Cache/BDB.pm
+%%SITE_PERL%%/Cache/BDB.pod
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache/BDB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache
+@dirrmtry %%SITE_PERL%%/Cache