aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Pg-13
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-01-03 22:52:45 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-01-03 22:52:45 +0000
commit46c4337a048f5c10f63adc6a1f8b3a414ed6fe49 (patch)
tree94e8d12529920f38211334733cf27d33a444f020 /databases/p5-DBD-Pg-13
parente1c7b062345ceb91853914f03cbe50ef0c360c12 (diff)
downloadports-46c4337a048f5c10f63adc6a1f8b3a414ed6fe49.tar.gz
ports-46c4337a048f5c10f63adc6a1f8b3a414ed6fe49.zip
- fix compiling when PostgreSQL is not installed before building this port
(old layouts are still supported with -DWITH_OLD_LAYOUT) - use ${LOCALBASE} instead of ${PREFIX} when building with old PostgreSQL layout
Notes
Notes: svn path=/head/; revision=72470
Diffstat (limited to 'databases/p5-DBD-Pg-13')
-rw-r--r--databases/p5-DBD-Pg-13/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index a841e4c11758..da5dab47fe33 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -24,15 +24,15 @@ MAN3= DBD::Pg.3 DBD::dbd-pg.3
.include <bsd.port.mk>
-.if exists(${LOCALBASE}/bin/pg_config)
-PG_CONFIG= ${LOCALBASE}/bin/pg_config
-.elif exists(${LOCALBASE}/pgsql/bin/pg_config)
+.if defined(WITH_OLD_LAYOUT)
+CONFIGURE_ENV+= POSTGRES_INCLUDE=${LOCALBASE}/include/pgsql \
+ POSTGRES_LIB=${LOCALBASE}/lib
+.else
+.if exists(${LOCALBASE}/pgsql/bin/pg_config)
PG_CONFIG= ${LOCALBASE}/pgsql/bin/pg_config
+.else
+PG_CONFIG= ${LOCALBASE}/bin/pg_config
.endif
-.if defined(PG_CONFIG)
CONFIGURE_ENV+= POSTGRES_INCLUDE=`${PG_CONFIG} --includedir` \
POSTGRES_LIB=`${PG_CONFIG} --libdir`
-.else
-CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/include/pgsql \
- POSTGRES_LIB=${PREFIX}/lib
.endif