aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-mysql
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-01-18 15:22:11 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-01-18 15:22:11 +0000
commit7efcc28f8e6130c8523286f779ea9e0549c372bf (patch)
treefff1d7df0cb856949824b16cb35cdf9f675feb67 /databases/p5-DBD-mysql
parent19577329353c26c5047b4d13615ef97e3a87090b (diff)
downloadports-7efcc28f8e6130c8523286f779ea9e0549c372bf.tar.gz
ports-7efcc28f8e6130c8523286f779ea9e0549c372bf.zip
Add compatibility with perl-5.00503 to DBD::mysql::GetInfo
PR: ports/60638 Submitted by: Sergey Matveychuk <sem@ciam.ru>
Notes
Notes: svn path=/head/; revision=98476
Diffstat (limited to 'databases/p5-DBD-mysql')
-rw-r--r--databases/p5-DBD-mysql/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index 15a4b17527c1..6c5b4b05387b 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -33,4 +33,10 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
.endif
+post-patch:
+.if ${PERL_LEVEL} < 500600
+ @${PERL} -pi -e 's/(?:use|no) warnings;?//; s/our (%\w+)/use vars qw(\1);\n\1/' \
+ ${WRKSRC}/lib/DBD/mysql/GetInfo.pm
+.endif
+
.include <bsd.port.post.mk>