aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Browse/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 01:57:07 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 01:57:07 +0000
commit7ada3a8cf048ce12f34cb5cda0af38b655d781b6 (patch)
tree580d928b8600d41af2af40e8d74fa915945aac89 /databases/p5-DBIx-Browse/Makefile
parent0399aa7c12240856b5a6615b1b6f3dbce832f483 (diff)
downloadports-7ada3a8cf048ce12f34cb5cda0af38b655d781b6.tar.gz
ports-7ada3a8cf048ce12f34cb5cda0af38b655d781b6.zip
New Port: p5-DBIx-Browse v2.09
The purpose of DBIx::Browse is to handle the browsing of relational tables. DBIx::Browse transparently translates SELECTs, UPDATEs, DELETEs and INSERTs from the desired "human view" to the values needed for the ta- ble. This is the case when you have related tables (1 to n) where the detail table has a reference (FOREIGN KEY) to a generic table (i.e. Customers and Bills) with some index (tipically an integer). PR: ports/47624 Submitted by: Philip M. Gollucci <philip@p6m7g8.com>
Notes
Notes: svn path=/head/; revision=74723
Diffstat (limited to 'databases/p5-DBIx-Browse/Makefile')
-rw-r--r--databases/p5-DBIx-Browse/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Browse/Makefile b/databases/p5-DBIx-Browse/Makefile
new file mode 100644
index 000000000000..bb24ef780759
--- /dev/null
+++ b/databases/p5-DBIx-Browse/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-DBIx-Browse
+# Date created: January 29th 2003
+# Whom: Philip M. Gollucci <philip@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Browse
+PORTVERSION= 2.09
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= philip@p6m7g8.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Browse::CGI.3 \
+ DBIx::Browse.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>