aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Perlish
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-02-22 20:06:54 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-02-22 20:06:54 +0000
commite12fd5f469e8db4a7a8d07691263ae1342c6fa6b (patch)
tree755f70805d94e5bfcbd517f4eb1ba408c5f54e13 /databases/p5-DBIx-Perlish
parent9266c54807628ff046489d142dd63e557d782775 (diff)
downloadports-e12fd5f469e8db4a7a8d07691263ae1342c6fa6b.tar.gz
ports-e12fd5f469e8db4a7a8d07691263ae1342c6fa6b.zip
Add databases/p5-DBIx-Perlish 0.18, a Perl module that
allows one perform queries to SQL databases using Perl syntax.
Notes
Notes: svn path=/head/; revision=185708
Diffstat (limited to 'databases/p5-DBIx-Perlish')
-rw-r--r--databases/p5-DBIx-Perlish/Makefile32
-rw-r--r--databases/p5-DBIx-Perlish/distinfo3
-rw-r--r--databases/p5-DBIx-Perlish/pkg-descr5
-rw-r--r--databases/p5-DBIx-Perlish/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Perlish/Makefile b/databases/p5-DBIx-Perlish/Makefile
new file mode 100644
index 000000000000..2d8a0157df28
--- /dev/null
+++ b/databases/p5-DBIx-Perlish/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: databases/p5-DBIx-Perlish
+# Date created: 22 February 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Perlish
+PORTVERSION= 0.18
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= A perlish interface to SQL databases
+
+BUILD_DEPENDS= p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
+ p5-PadWalker>0:${PORTSDIR}/devel/p5-PadWalker
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Perlish.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500802
+IGNORE= requires perl 5.8.2 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-Perlish/distinfo b/databases/p5-DBIx-Perlish/distinfo
new file mode 100644
index 000000000000..aef3b6609a91
--- /dev/null
+++ b/databases/p5-DBIx-Perlish/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Perlish-0.18.tar.gz) = 3ee58a7b90eccfc7fe6070ed55653ff6
+SHA256 (DBIx-Perlish-0.18.tar.gz) = ad4a69a6a872edb5ba724b6bef51aa0d35dc61a12f6188a7d147dcec9fc58e6b
+SIZE (DBIx-Perlish-0.18.tar.gz) = 38338
diff --git a/databases/p5-DBIx-Perlish/pkg-descr b/databases/p5-DBIx-Perlish/pkg-descr
new file mode 100644
index 000000000000..039ef520fdf5
--- /dev/null
+++ b/databases/p5-DBIx-Perlish/pkg-descr
@@ -0,0 +1,5 @@
+The DBIx::Perlish module provides the ability to work with databases
+supported by the DBI module using Perl's own syntax for four most common
+operations: SELECT, UPDATE, DELETE, and INSERT.
+
+WWW: http://search.cpan.org/dist/DBIx-Perlish/
diff --git a/databases/p5-DBIx-Perlish/pkg-plist b/databases/p5-DBIx-Perlish/pkg-plist
new file mode 100644
index 000000000000..aabcc575cd2a
--- /dev/null
+++ b/databases/p5-DBIx-Perlish/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DBIx/Perlish.pm
+%%SITE_PERL%%/DBIx/Perlish/Parse.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Perlish/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Perlish
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/DBIx/Perlish
+@dirrmtry %%SITE_PERL%%/DBIx