aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Simple
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-18 09:33:37 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-18 09:33:37 +0000
commit55bca005592443f9707a34760bac17cd1ab5c9d1 (patch)
tree6def6caa1baf186c7f8e57f532e7dbb0a47b7c8a /databases/p5-DBIx-Simple
parent52a77d1e27cda622feecf19d63264092769325ec (diff)
downloadports-55bca005592443f9707a34760bac17cd1ab5c9d1.tar.gz
ports-55bca005592443f9707a34760bac17cd1ab5c9d1.zip
Add OPTIONS
PR: 90509 Submitted by: parv@pair.com (maintainer)
Notes
Notes: svn path=/head/; revision=151467
Diffstat (limited to 'databases/p5-DBIx-Simple')
-rw-r--r--databases/p5-DBIx-Simple/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/databases/p5-DBIx-Simple/Makefile b/databases/p5-DBIx-Simple/Makefile
index 001b40271237..c8cca8fb8889 100644
--- a/databases/p5-DBIx-Simple/Makefile
+++ b/databases/p5-DBIx-Simple/Makefile
@@ -18,6 +18,20 @@ COMMENT= Simplified object oriented interface to Perl DBI
RUN_DEPENDS= p5-DBI>=1.21:${PORTSDIR}/databases/p5-DBI \
p5-Data-Swap>=0.02:${PORTSDIR}/devel/p5-Data-Swap
+OPTIONS= \
+ SQL_ABSTRACT "Generate SQL from Perl data structures" off \
+ DBIX_XHTML_TABLE "Create XHTML tables from SQL queries" off \
+ TEXT_TABLE "Create plain text table from data" off
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Simple.3 \
+ DBIx::Simple::Examples.3 \
+ DBIx::Simple::Comparison.3 \
+ DBIx::Simple::SQE.3
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_SQL_ABSTRACT)
RUN_DEPENDS+= p5-SQL-Abstract>=0:${PORTSDIR}/databases/p5-SQL-Abstract
.endif
@@ -30,15 +44,6 @@ RUN_DEPENDS+= p5-DBIx-XHTML_Table>=0:${PORTSDIR}/databases/p5-DBIx-XHTML_Table
RUN_DEPENDS+= p5-Text-Table>=0:${PORTSDIR}/textproc/p5-Text-Table
.endif
-PERL_CONFIGURE= yes
-
-MAN3= DBIx::Simple.3 \
- DBIx::Simple::Examples.3 \
- DBIx::Simple::Comparison.3 \
- DBIx::Simple::SQE.3
-
-.include <bsd.port.pre.mk>
-
.if ${PERL_LEVEL} < 500600
IGNORE= need at least Perl 5.6; install lang/perl or lang/perl5.8
.endif