aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Tree
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
commit6b470bae86247b8cb79b0dc6e43078df2f84c4ae (patch)
treee1545740f8801646e19c181252cb4c4e39df9ca8 /databases/p5-DBIx-Tree
parentb63d72fe5f0a821fa729c344f9b44de714603abc (diff)
downloadports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.tar.gz
ports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Notes
Notes: svn path=/head/; revision=89001
Diffstat (limited to 'databases/p5-DBIx-Tree')
-rw-r--r--databases/p5-DBIx-Tree/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/databases/p5-DBIx-Tree/Makefile b/databases/p5-DBIx-Tree/Makefile
index 94ea8b181e8b..34574ac1218b 100644
--- a/databases/p5-DBIx-Tree/Makefile
+++ b/databases/p5-DBIx-Tree/Makefile
@@ -15,10 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= philip@p6m7g8.com
COMMENT= Perl module for generating a tree from a self-referential table
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-
PERL_CONFIGURE= yes
MAN3= DBIx::Tree.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>