aboutsummaryrefslogtreecommitdiff
path: root/databases/pear-DB_DataObject
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-03-03 21:07:10 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-03-03 21:07:10 +0000
commit7237df5e07f7ab6b7711eb8fc24e995e1dbabcef (patch)
treed525555bb59ff8965a407b5f43bf42c3507fb8ac /databases/pear-DB_DataObject
parent415bbcb012ea6d420014182d128d2e1eea73c692 (diff)
downloadports-7237df5e07f7ab6b7711eb8fc24e995e1dbabcef.tar.gz
ports-7237df5e07f7ab6b7711eb8fc24e995e1dbabcef.zip
Upgrade to 1.7.5.
Changelog at <http://pear.php.net/package/DB_DataObject/download/1.7.5/>. PR: ports/78298 Submitted by: Antônio Carlos Venâncio Júnior (maintainer)
Notes
Notes: svn path=/head/; revision=130291
Diffstat (limited to 'databases/pear-DB_DataObject')
-rw-r--r--databases/pear-DB_DataObject/Makefile25
-rw-r--r--databases/pear-DB_DataObject/distinfo4
-rw-r--r--databases/pear-DB_DataObject/pkg-descr11
3 files changed, 17 insertions, 23 deletions
diff --git a/databases/pear-DB_DataObject/Makefile b/databases/pear-DB_DataObject/Makefile
index 4c89edb690e2..b7fbc61bcf39 100644
--- a/databases/pear-DB_DataObject/Makefile
+++ b/databases/pear-DB_DataObject/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DB_DataObject
-PORTVERSION= 1.7.2
+PORTVERSION= 1.7.5
CATEGORIES= databases www pear
MAINTAINER= antonio@php.net
@@ -16,28 +16,23 @@ BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PHP= yes
+USE_REINPLACE= yes
CATEGORY= DB
-FILES= DataObject.php DataObject/Cast.php DataObject/Error.php \
- DataObject/Generator.php DataObject/createTables.php
-
+FILES= DataObject.php DataObject/Cast.php DataObject/Generator.php \
+ DataObject/createTables.php DataObject/Error.php
DOCS= example.ini
-LATEST_LINK= pear-DB_DataObject
-OPTIONS= PEAR_VALIDATE "PEAR::Validate support" off
-
-.include <bsd.port.pre.mk>
-
-PHP_VERS= ${PHP_VERSION:S/.//g}
+LATEST_LINK= pear-DB_DataObject
+OPTIONS= PEAR_VALIDATE "PEAR::Validate support" off
-.if defined(PHP_VERS) && ${PHP_VERS} < 420
-IGNORE= "You need PHP 4.2.0 or later to install PEAR::DB_DataObject"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/DataObject.php
.if defined(WITH_PEAR_VALIDATE)
-BUILD_DEPENDS+= ${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
+RUN_DEPENDS+= ${PEARDIR}/Validate.php:${PORTSDIR}/devel/pear-Validate
.endif
+.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_DataObject/distinfo b/databases/pear-DB_DataObject/distinfo
index 4d33153dd9b6..cfcbc762e522 100644
--- a/databases/pear-DB_DataObject/distinfo
+++ b/databases/pear-DB_DataObject/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/DB_DataObject-1.7.2.tgz) = f6961fb5f9976bb2492e7c87942fc7b0
-SIZE (PEAR/DB_DataObject-1.7.2.tgz) = 45244
+MD5 (PEAR/DB_DataObject-1.7.5.tgz) = ad4cd9e6c544aeb2f3391bfb84c3c77f
+SIZE (PEAR/DB_DataObject-1.7.5.tgz) = 48592
diff --git a/databases/pear-DB_DataObject/pkg-descr b/databases/pear-DB_DataObject/pkg-descr
index bc4da30923ea..3fcbad59f073 100644
--- a/databases/pear-DB_DataObject/pkg-descr
+++ b/databases/pear-DB_DataObject/pkg-descr
@@ -1,9 +1,8 @@
PEAR::DB_DataObject performs 2 tasks:
-1. Builds SQL statements based on the objects vars and the buiLder methods.
+1. Builds SQL statements based on the objects vars and the builder methods.
2. acts as a datastore for a table row.
+The core class is designed to be extended for each of your tables so that you
+put the data logic inside the data classes.
+included is a Generator to make your configuration files and your base classes.
-The core class is designed to be extended for each of your tables so that you
- put the data logic inside the data classes.
-Included is a Generator to make your configuration files and your base classes.
-
-WWW: http://pear.php.net/package/DB_DataObject
+WWW: http://pear.php.net/package/DB_DataObject/