aboutsummaryrefslogtreecommitdiff
path: root/databases/percona55-server/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-03-08 08:58:24 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-03-08 08:58:24 +0000
commit16c0520e22a524e69221934c03573742322d1703 (patch)
treedc52ab4a3b2aae426ef3303dfacd51d88422d1c8 /databases/percona55-server/Makefile
parent496a81e4986d0fdf014345095edb47a533612575 (diff)
downloadports-16c0520e22a524e69221934c03573742322d1703.tar.gz
ports-16c0520e22a524e69221934c03573742322d1703.zip
Fix mysql default db installation.
Noticed by: many
Notes
Notes: svn path=/head/; revision=103278
Diffstat (limited to 'databases/percona55-server/Makefile')
-rw-r--r--databases/percona55-server/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 69e50464de8c..9db3fbe2ce7f 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mysql
PORTVERSION= 5.0.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= databases
MASTER_SITES= ftp://planetmirror.com/pub/mysql/Downloads/MySQL-5.0/ \
http://www.softagency.co.jp/MySQL/Downloads/MySQL-5.0/ \
@@ -142,7 +142,7 @@ pre-fetch:
post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ @sql_server_dirs@ scripts man support-files|g" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@|g" ${WRKSRC}/scripts/Makefile.in
+ @${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@ mysql_create_system_tables|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = fill_help_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
@${REINPLACE_CMD} -e "s|install: install-am|install:|g" ${WRKSRC}/include/Makefile.in
@@ -221,8 +221,7 @@ MAN1= mysql_zap.1 mysqlaccess.1 mysqld_multi.1 mysql_fix_privilege_tables.1
SCRIPTS= msql2mysql mysql_fix_extensions mysql_setpermission \
mysql_secure_installation mysql_zap mysqlaccess \
mysql_convert_table_format mysql_find_rows mysqlhotcopy \
- mysqldumpslow mysql_explain_log mysql_tableinfo mysqld_multi \
- mysql_create_system_tables
+ mysqldumpslow mysql_explain_log mysql_tableinfo mysqld_multi
post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = scripts man|g" ${WRKSRC}/Makefile.in