aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-devel/Makefile
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-27 23:22:02 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-27 23:22:02 +0000
commit926df101427278fd74626032c0a5ba7b6c2aa97f (patch)
treeae256ccb635d4f09ed1eafba8b51b7ee341798d1 /databases/postgresql-devel/Makefile
parent01cd67a1618e64e40d48d9582e50dd2e012c5004 (diff)
downloadports-926df101427278fd74626032c0a5ba7b6c2aa97f.tar.gz
ports-926df101427278fd74626032c0a5ba7b6c2aa97f.zip
Update to a a 2003-01-26 snapshot of PostgreSQL. Documentation is not
included in this port at the moment, please see the developer docs online. http://developer.postgresql.org/docs/postgres/ For a list of changes (mostly significant improvements for large queries): http://developer.postgresql.org/docs/postgres/release.html#RELEASE-DEVEL
Notes
Notes: svn path=/head/; revision=74112
Diffstat (limited to 'databases/postgresql-devel/Makefile')
-rw-r--r--databases/postgresql-devel/Makefile161
1 files changed, 64 insertions, 97 deletions
diff --git a/databases/postgresql-devel/Makefile b/databases/postgresql-devel/Makefile
index 5b21edd77451..135f9236373c 100644
--- a/databases/postgresql-devel/Makefile
+++ b/databases/postgresql-devel/Makefile
@@ -6,63 +6,42 @@
#
PORTNAME?= postgresql
-PORTVERSION?= 7.3.1
-PORTREVISION= 1
-PKGNAMESUFFIX= -devel
+PORTVERSION?= 7.4.2003.01.26
CATEGORIES?= databases
-MASTER_SITES= ftp://ftp9.us.postgresql.org/pub/mirrors/postgresql/%SUBDIR%/ \
- ftp://ftp5.us.postgresql.org/pub/PostgreSQL/%SUBDIR%/ \
- ftp://ftp3.us.postgresql.org/pub/postgresql/%SUBDIR%/ \
- ftp://ftp13.us.postgresql.org/mirror/postresql/%SUBDIR%/ \
- ftp://ftp8.us.postgresql.org/pub/pgsql/%SUBDIR%/ \
- ftp://ftp10.us.postgresql.org/pub/postgresql/%SUBDIR%/ \
- ftp://ftp.se.postgresql.org/pub/database/relational/postgresql/%SUBDIR%/ \
- ftp://ftp2.ch.postgresql.org/mirror/postgresql/%SUBDIR%/ \
- ftp://ftp.de.postgresql.org/mirror/postgresql/%SUBDIR%/ \
- ftp://ftp.chg.ru/pub/databases/postgresql/%SUBDIR%/ \
- ftp://ftp.sunet.se/pub/unix/databases/relational/postgresql/%SUBDIR%/ \
- ftp://ftp.jaist.ac.jp/pub/dbms/PostgreSQL/%SUBDIR%/ \
- ftp://ftp.us.postgresql.org/%SUBDIR%/ \
- ftp://ftp.postgresql.org/pub/%SUBDIR%/
-MASTER_SITE_SUBDIR= source/v${PORTVERSION}
-DISTFILES= postgresql-base-${PORTVERSION}${EXTRACT_SUFX} \
- postgresql-opt-${PORTVERSION}${EXTRACT_SUFX} \
- postgresql-test-${PORTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= http://freebsd.sean.chittenden.org/ports/
+PKGNAMESUFFIX= -devel
MAINTAINER?= seanc@FreeBSD.org
-WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
+USE_BZIP2= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
.if defined(POSTGRESQL_SUBPORT)
## the POSTGRESQL_SUBPORTS use this port's distinfo
-MD5_FILE= ${.CURDIR}/../postgresql-devel/distinfo
+MD5_FILE= ${.CURDIR}/../postgresql7/distinfo
.else
+## POSTGRESQL_SUBPORTS stops here
## The rest of this file is for normal base installation
INSTALLS_SHLIB= YES
-CONFIGURE_ARGS= --docdir=${PREFIX}/share/doc --with-libdir=${LOCALBASE}/lib \
- --with-includes=${LOCALBASE}/include
+CONFIGURE_ARGS= --with-libraries=${LOCALBASE}/lib \
+ --with-includes=${LOCALBASE}/include \
+ --with-docdir=${LOCALBASE}/share/doc/$PORTNAME}${PKGNAMESUFFIX}
.if !defined(WITHOUT_GNUGETOPT)
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
.endif
-# if you want localized messages, make -DWITH_GETTEXT
-# WARNING: this seems to require relinking binaries depending on
-# libpq.so, including for example mod_php and tcl.
-.if defined(WITHOUT_GETTEXT)
-CONFIGURE_ARGS+=--disable-nls
+.if !defined(WITHOUT_GETTEXT)
+CONFIGURE_ARGS+=--enable-nls
+LIB_DEPENDS+= intl.4:${PORTSDIR}/devel/gettext
PLIST_SUB+= GETTEXT=""
.else
-CONFIGURE_ENV+= "LDFLAGS=-L${LOCALBASE}/lib"
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --enable-nls
-LIB_DEPENDS+= intl.4:${PORTSDIR}/devel/gettext
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
.endif
@@ -80,39 +59,32 @@ CFLAGS+= -O3 -funroll-loops
CONFIGURE_ARGS+= --enable-debug
.endif
-.if defined(WITH_STRIPBIN)
-INSTALL_TARGET= install-strip
-.endif
-
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
.endif
-.if defined(WITH_MIT_KRB5) && defined(WITH_HEIMDAL_KRB5)
- @${ECHO} "WITH_MIT_KRB5 and WITH_HEIMDAL_KRB5 are mutually exclusive."
- @${ECHO} "Please choose one or the other."
- @exit 1
+.if defined(WITHOUT_SERVER)
+PKGMESSAGE= ${PKGDIR}/pkg-message.client
+PLIST_SUB+= SERVER="@comment "
+PKGNAMESUFFIX= -client
+.else
+PLIST_SUB+= SERVER=""
+INSTALL_TARGET= install-all-headers
+.if defined(WITH_STRIPBIN)
+INSTALL_TARGET+= install-strip
+.else
+INSTALL_TARGET+= install
+.endif
.endif
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
-.if !exists(${KRB5CONFIG})
- @${ECHO} "Unable to find krb5-config in your local base, please verify that"
- @${ECHO} "security/krb5 is installed or undefine the WITH_MIT_KRB5 tunable."
- @exit 1
-.endif
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-.if !exists(${KRB5CONFIG})
- @${ECHO} "Unable to find krb5-config in the base system. Undefine"
- @${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
- @exit 1
-.endif
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -122,47 +94,54 @@ CONFIGURE_ARGS+= --with-krb5="`${KRB5CONF} --prefix krb5`"
LDFLAGS+= `${KRB5CONF} --libs krb5`
.endif
-.if defined(WITHOUT_SERVER)
-PKGMESSAGE= ${PKGDIR}/pkg-message.client
-PLIST_SUB+= SERVER="@comment "
-.else
-PLIST_SUB+= SERVER=""
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -funroll-loops
.endif
pre-everything::
+ @${SH} ${PKGDIR}/pkg-install ${PORTNAME} BACKUPWARNING
@${ECHO} ""
- @${ECHO} "CAUTION!!!!!"
- @${ECHO} ""
- @${ECHO} " This is a development port! You will have to re-initdb between"
- @${ECHO} " upgrades as the system catalogs have changed between snapshots."
- @${ECHO} ""
- @${ECHO} " Running this version of the port implies a large degree of"
- @${ECHO} " familiarity with the PostgreSQL development cycle and process."
- @${ECHO} " You should _always_ backup your data using pg_dump(all) before"
- @${ECHO} " every upgrade. If you have not backed up your data yet, exit"
- @${ECHO} " this installation and backup your data now!!!!"
+ @${ECHO} "${PORTNAME} has several tunables that can be used to configure PostgreSQL:"
@${ECHO} ""
+ @${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
+ @${ECHO} " still be used if already installed)"
+ @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " internationalized error messages"
+ @${ECHO} " WITHOUT_SERVER Installs the headers and libraries for"
+ @${ECHO} " PostgreSQL clients"
+ @${ECHO} " WITHOUT_SSL Builds without OpenSSL support"
+ @${ECHO} " WITH_MIT_KRB5 Builds with MIT's kerberos support"
+ @${ECHO} " WITH_HEIMDAL_KRB5 Builds with Heimdal's kerberos support"
+ @${ECHO} " WITH_OPTIMIZED_CFLAGS Builds with compiler optimizations (-O3)"
+ @${ECHO} " WITH_DEBUG Builds with debugging symbols"
+ @${ECHO} " WITH_STRIPBIN Installs stripped binaries"
@${ECHO} ""
- @${ECHO} "${PORTNAME} has several tunables that used to configure PostgreSQL:"
- @${ECHO} ""
- @${ECHO} " WITHOUT_GNUGETOPT=yes Skips building with GNU getopt"
- @${ECHO} " WITHOUT_GETTEXT=yes Skips building with support for"
- @${ECHO} " internationalized error messages"
- @${ECHO} " WITH_DEBUG=yes Builds with debugging symbols"
- @${ECHO} " WITH_STRIPBIN=yes Installs stripped binaries"
- @${ECHO} " WITHOUT_SSL=yes Builds without OpenSSL support"
- @${ECHO} " WITHOUT_SERVER=yes Installs the headers and libraries for"
- @${ECHO} " PostgreSQL clients"
- @${ECHO} " WITH_MIT_KRB5=yes Builds with MIT's kerberos support"
- @${ECHO} " WITH_HEIMDAL_KRB5=yes Builds with Heimdal's kerberos support"
- @${ECHO} " WITH_OPTIMIZED_CFLAGS=yes Builds with compiler optimizations (-O3)"
- @${ECHO} ""
-.if !defined(BATCH)
- @sleep 5
+.if defined(WITH_MIT_KRB5) && defined(WITH_HEIMDAL_KRB5)
+ @${ECHO} "WITH_MIT_KRB5 and WITH_HEIMDAL_KRB5 are mutually exclusive."
+ @${ECHO} "Please choose one or the other."
+ @exit 1
+.endif
+.if defined(WITH_MIT_KRB5) && !exists(${KRB5CONFIG})
+ @${ECHO} "Unable to find krb5-config in your local base, please verify that"
+ @${ECHO} "security/krb5 is installed or undefine the WITH_MIT_KRB5 tunable."
+ @exit 1
+.endif
+.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONFIG})
+ @${ECHO} "Unable to find krb5-config in the base system. Undefine"
+ @${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
+ @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @exit 1
.endif
+.if defined(WITHOUT_SERVER)
+do-install:
+ @ cd ${WRKSRC}; \
+ ${GMAKE} -C src/bin ${INSTALL_TARGET} ;\
+ ${GMAKE} -C src/include ${INSTALL_TARGET} ;\
+ ${GMAKE} -C src/interfaces ${INSTALL_TARGET} ;\
+ ${GMAKE} -C doc ${INSTALL_TARGET}
+
pre-install:
-.if !defined(WITHOUT_SERVER)
@ ${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/pkg-install ${PORTNAME} PRE-INSTALL
.endif
@@ -172,14 +151,8 @@ post-install:
${CAT} ${FILESDIR}/post-install-notes ${PKGMESSAGE} |\
${SED} "s|/usr/local|${PREFIX}|g" |\
tee ${PREFIX}/share/postgresql/post-install-notes
-.if !defined(DEBUG_FLAGS)
-.for file in ecpg pg_dump pg_id pg_restore psql
- @ strip ${PREFIX}/bin/${file}
-.endfor
-.endif
.if !defined(WITHOUT_SERVER)
# install shell defaults for pgsql user
- @ strip ${PREFIX}/bin/postgres
.for i in profile cshrc
@ ${SED} "s|%%PREFIX%%|${PREFIX}|g" \
< ${FILESDIR}/dot.$i.in \
@@ -198,12 +171,6 @@ post-install:
${CHOWN} -R pgsql:pgsql ~pgsql/. ;\
${INSTALL_DATA} ${FILESDIR}/502.pgsql \
${PREFIX}/share/postgresql
-.else
-do-install:
- @ cd ${WRKSRC}; \
- ${GMAKE} -C src/bin ${INSTALL_TARGET} ;\
- ${GMAKE} -C src/include ${INSTALL_TARGET} ;\
- ${GMAKE} -C src/interfaces ${INSTALL_TARGET}
.endif
check: