aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx30
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-05 00:11:39 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-05 00:11:39 +0000
commitff0e3c1bf78d707984b226ae4decf29207ccb650 (patch)
tree0e3d7af9417992a48b9c5c54feb203218e329f9d /databases/postgresql-libpqxx30
parent063ec41e826c49ddc5bb848fea41f10fadd44e31 (diff)
downloadports-ff0e3c1bf78d707984b226ae4decf29207ccb650.tar.gz
ports-ff0e3c1bf78d707984b226ae4decf29207ccb650.zip
Add libpqxx. libpqxx is no longer hosted under the main PostgreSQL tree and
is now a project on gborg. libpqxx is still a supported interface. PR: ports/45944 Submitted by: Palle Girgensohn <girgen@pingpong.net>
Notes
Notes: svn path=/head/; revision=72542
Diffstat (limited to 'databases/postgresql-libpqxx30')
-rw-r--r--databases/postgresql-libpqxx30/Makefile27
-rw-r--r--databases/postgresql-libpqxx30/distinfo1
-rw-r--r--databases/postgresql-libpqxx30/pkg-comment1
-rw-r--r--databases/postgresql-libpqxx30/pkg-descr18
-rw-r--r--databases/postgresql-libpqxx30/pkg-plist20
5 files changed, 67 insertions, 0 deletions
diff --git a/databases/postgresql-libpqxx30/Makefile b/databases/postgresql-libpqxx30/Makefile
new file mode 100644
index 000000000000..5b6442355736
--- /dev/null
+++ b/databases/postgresql-libpqxx30/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: PostgreSQL Pgaccess
+# Date created: December 1st, 2002
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpqxx
+PORTVERSION= 1.1.4
+CATEGORIES= databases
+MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqxx/stable/
+DIST_SUBDIR= postgresql
+
+MAINTAINER= girgen@pingpong.net
+
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+USE_GMAKE= YES
+GNU_CONFIGURE= YES
+USE_REINPLACE= YES
+INSTALLS_SHLIB= YES
+
+CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
+ --with-postgres-include=${LOCALBASE}/include/postgresql
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-libpqxx30/distinfo b/databases/postgresql-libpqxx30/distinfo
new file mode 100644
index 000000000000..6b86400f7ca7
--- /dev/null
+++ b/databases/postgresql-libpqxx30/distinfo
@@ -0,0 +1 @@
+MD5 (postgresql/libpqxx-1.1.4.tar.gz) = cb14bdcc2d6a702f0e902e7b20c7c4b2
diff --git a/databases/postgresql-libpqxx30/pkg-comment b/databases/postgresql-libpqxx30/pkg-comment
new file mode 100644
index 000000000000..54c0291b96d1
--- /dev/null
+++ b/databases/postgresql-libpqxx30/pkg-comment
@@ -0,0 +1 @@
+A new C++ interface for PostgreSQL
diff --git a/databases/postgresql-libpqxx30/pkg-descr b/databases/postgresql-libpqxx30/pkg-descr
new file mode 100644
index 000000000000..783a2761c86a
--- /dev/null
+++ b/databases/postgresql-libpqxx30/pkg-descr
@@ -0,0 +1,18 @@
+Welcome to libpqxx, a C++ API to the PostgreSQL database management
+system.
+
+There are many similar libraries for PostgreSQL and for other
+databases, some of them database-independent. Most of these, however,
+are fairly C-like in their programming style, and fail to take
+advantage of the full power of the C++ language as it has matured
+since the acceptance of the Standard in 1996. What libpqxx brings you
+is effective use of templates to reduce the inconvenience of dealing
+with type conversions; of standard C++ strings to keep you from having
+to worry about buffer allocation and overflow attacks; of exceptions
+to take the tedious and error-prone plumbing around error handling out
+of your hands; of constructors and destructors to bring resource
+management under control; and even basic object-orientation to give
+you some extra reliability features that would be hard to get with
+most other database interfaces.
+
+WWW: http://gborg.postgresql.org/project/libpqxx/
diff --git a/databases/postgresql-libpqxx30/pkg-plist b/databases/postgresql-libpqxx30/pkg-plist
new file mode 100644
index 000000000000..2ab5835286a1
--- /dev/null
+++ b/databases/postgresql-libpqxx30/pkg-plist
@@ -0,0 +1,20 @@
+include/pqxx/compiler.h
+include/pqxx/config.h
+include/pqxx/connection.h
+include/pqxx/cursor.h
+include/pqxx/nontransaction.h
+include/pqxx/result.h
+include/pqxx/robusttransaction.h
+include/pqxx/tablereader.h
+include/pqxx/tablestream.h
+include/pqxx/tablewriter.h
+include/pqxx/transaction.h
+include/pqxx/transactionitf.h
+include/pqxx/transactor.h
+include/pqxx/trigger.h
+include/pqxx/util.h
+lib/libpqxx.a
+lib/libpqxx.la
+lib/libpqxx.so
+lib/libpqxx.so.0
+@dirrm include/pqxx