aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-pllua
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2008-03-21 07:42:59 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2008-03-21 07:42:59 +0000
commit9fa9aaa223e02b27d84aba96751d59536adb70c7 (patch)
treecdc38719edd5ca57f52b9f8403a761bda20ad710 /databases/postgresql-pllua
parent4d7e0d666aededfaf8d27ce75fb9048f8898358a (diff)
downloadports-9fa9aaa223e02b27d84aba96751d59536adb70c7.tar.gz
ports-9fa9aaa223e02b27d84aba96751d59536adb70c7.zip
Add postgresql-pllua 0.2.2, PL/Lua procedural language for PostgreSQL
database. PR: ports/121139 Submitted by: sunghyuk
Notes
Notes: svn path=/head/; revision=209512
Diffstat (limited to 'databases/postgresql-pllua')
-rw-r--r--databases/postgresql-pllua/Makefile33
-rw-r--r--databases/postgresql-pllua/distinfo3
-rw-r--r--databases/postgresql-pllua/files/patch-Makefile13
-rw-r--r--databases/postgresql-pllua/files/pkg-message.in3
-rw-r--r--databases/postgresql-pllua/pkg-descr5
-rw-r--r--databases/postgresql-pllua/pkg-plist5
6 files changed, 62 insertions, 0 deletions
diff --git a/databases/postgresql-pllua/Makefile b/databases/postgresql-pllua/Makefile
new file mode 100644
index 000000000000..a40878e55a23
--- /dev/null
+++ b/databases/postgresql-pllua/Makefile
@@ -0,0 +1,33 @@
+# New Ports collection makefile for: postgresql-pllua
+# Date created: 27 Feb 2008
+# Whom: sunghyuk
+#
+# $FreeBSD$
+#
+
+PORTNAME= pllua
+PORTVERSION= 0.2.2
+CATEGORIES= databases
+MASTER_SITES= http://pgfoundry.org/frs/download.php/1602/
+PKGNAMEPREFIX= postgresql-
+
+MAINTAINER= sunghyuk@gmail.com
+COMMENT= PL/Lua procedural language for PostgreSQL database
+
+USE_PGSQL= yes
+USE_GMAKE= yes
+USE_LUA= 5.1+
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%LUA_INC%|${LUA_INCDIR}|g' \
+ -e 's|%LUA_LIB%|${LUA_LIBDIR}|g' \
+ ${WRKSRC}/Makefile
+post-install:
+ @${ECHO_MSG} ''
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} ''
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-pllua/distinfo b/databases/postgresql-pllua/distinfo
new file mode 100644
index 000000000000..e6bdd8c77e6d
--- /dev/null
+++ b/databases/postgresql-pllua/distinfo
@@ -0,0 +1,3 @@
+MD5 (pllua-0.2.2.tar.gz) = 5d68a539fec0ea49bd08fa91698b9c8a
+SHA256 (pllua-0.2.2.tar.gz) = 2e7a5b970d2ea3b50ff1814460a0703ffb4cdd3a8e19a79a2e30fa82cbdf03ed
+SIZE (pllua-0.2.2.tar.gz) = 22345
diff --git a/databases/postgresql-pllua/files/patch-Makefile b/databases/postgresql-pllua/files/patch-Makefile
new file mode 100644
index 000000000000..0804c55360df
--- /dev/null
+++ b/databases/postgresql-pllua/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2008-02-27 11:29:32.000000000 +0900
++++ Makefile 2008-02-27 11:30:16.000000000 +0900
+@@ -4,8 +4,8 @@
+ # Lua specific
+
+ # General
+-LUAINC =
+-LUALIB = -llua
++LUAINC = -I%LUA_INC%
++LUALIB = -L%LUA_LIB% -llua
+
+ # Debian/Ubuntu
+ #LUAINC = -I/usr/include/lua5.1
diff --git a/databases/postgresql-pllua/files/pkg-message.in b/databases/postgresql-pllua/files/pkg-message.in
new file mode 100644
index 000000000000..b94e61ae9124
--- /dev/null
+++ b/databases/postgresql-pllua/files/pkg-message.in
@@ -0,0 +1,3 @@
+Use the following sql script to create PL/Lua
+
+ ex) psql -f %%PREFIX%%/share/postgresql/contrib/pllua.sql <database>
diff --git a/databases/postgresql-pllua/pkg-descr b/databases/postgresql-pllua/pkg-descr
new file mode 100644
index 000000000000..cfae0a7041b3
--- /dev/null
+++ b/databases/postgresql-pllua/pkg-descr
@@ -0,0 +1,5 @@
+PL/Lua is an implementation of Lua as a loadable procedural language
+for PostgreSQL: with PL/Lua you can use PostgreSQL functions and
+triggers written in the Lua programming language.
+
+WWW: http://pllua.projects.postgresql.org/
diff --git a/databases/postgresql-pllua/pkg-plist b/databases/postgresql-pllua/pkg-plist
new file mode 100644
index 000000000000..1f9a69d77b20
--- /dev/null
+++ b/databases/postgresql-pllua/pkg-plist
@@ -0,0 +1,5 @@
+lib/postgresql/pllua.so
+share/postgresql/contrib/pllua.sql
+@dirrmtry lib/postgresql
+@dirrmtry share/postgresql/contrib
+@dirrmtry share/postgresql