aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-plruby
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2011-09-12 09:51:35 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2011-09-12 09:51:35 +0000
commit82d34a5fdfcb75b56beaf8fc93dff555549dae46 (patch)
treeaa72d43e5d48f1e5c1a05ab6392e0ea79efe865e /databases/postgresql-plruby
parent03bf3b24da1171dde31852738518fc323266d482 (diff)
downloadports-82d34a5fdfcb75b56beaf8fc93dff555549dae46.tar.gz
ports-82d34a5fdfcb75b56beaf8fc93dff555549dae46.zip
Fix docs not beeing installed
Patch to handle PostgreSQL 9.1
Notes
Notes: svn path=/head/; revision=281658
Diffstat (limited to 'databases/postgresql-plruby')
-rw-r--r--databases/postgresql-plruby/Makefile5
-rw-r--r--databases/postgresql-plruby/files/patch-bitand-bitor16
2 files changed, 18 insertions, 3 deletions
diff --git a/databases/postgresql-plruby/Makefile b/databases/postgresql-plruby/Makefile
index a753e28f484b..d3dfd7baf7a1 100644
--- a/databases/postgresql-plruby/Makefile
+++ b/databases/postgresql-plruby/Makefile
@@ -41,7 +41,7 @@ CONFIGURE_ARGS= --with-pg-config="${LOCALBASE}/bin/pg_config" \
#CONFIGURE_ARGS+= --with-timeout=30
INSTALL_TARGET= site-install
-DOCS= Changes README.en plruby.html plruby.rd docs/doc
+DOCS= Changes plruby.html plruby.rd
PKGMESSAGE= ${WRKDIR}/createlang.sql
@@ -62,8 +62,7 @@ post-install:
${MKDIR} ${RUBY_MODEXAMPLESDIR}/
${INSTALL_DATA} ${WRKDIR}/createlang.sql ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
- @(cd ${WRKSRC}/ && ${COPYTREE_SHARE} ${DOCS} ${RUBY_MODDOCDIR}/)
-
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} docs/doc ${RUBY_MODDOCDIR}/ README.en && ${INSTALL_DATA} ${DOCS} ${RUBY_MODDOCDIR}/)
@${FIND} -ds ${RUBY_MODDOCDIR} -type f -print | ${SED} -E -e \
's,^${PREFIX}/?,,' >> ${TMPPLIST}
@${FIND} -ds ${RUBY_MODDOCDIR} -type d -print | ${SED} -E -e \
diff --git a/databases/postgresql-plruby/files/patch-bitand-bitor b/databases/postgresql-plruby/files/patch-bitand-bitor
new file mode 100644
index 000000000000..469efaaa1a51
--- /dev/null
+++ b/databases/postgresql-plruby/files/patch-bitand-bitor
@@ -0,0 +1,16 @@
+--- src/conversions/bitstring/plruby_bitstring.c.orig 2011-09-12 10:59:01.000000000 +0200
++++ src/conversions/bitstring/plruby_bitstring.c 2011-09-12 11:01:31.000000000 +0200
+@@ -195,8 +195,13 @@
+ }
+
+ BIT_OPERATOR(pl_bit_add, bitcat);
++#if PG_PL_VERSION >= 91
++BIT_OPERATOR(pl_bit_and, bit_and);
++BIT_OPERATOR(pl_bit_or, bit_or);
++#else
+ BIT_OPERATOR(pl_bit_and, bitand);
+ BIT_OPERATOR(pl_bit_or, bitor);
++#endif
+ BIT_OPERATOR(pl_bit_xor, bitxor);
+
+ static VALUE