aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-pltcl/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-03-25 23:27:56 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-03-25 23:27:56 +0000
commit28a6ecbe17226107ba9c8f6f0c676b2b6baf9252 (patch)
tree7da80b774ba8cc8302d634ca1a8bc1e9be899ee9 /databases/postgresql-pltcl/Makefile
parentbb8871ec1b2b4a5be7b7a13f4ff8a535f933c15d (diff)
downloadports-28a6ecbe17226107ba9c8f6f0c676b2b6baf9252.tar.gz
ports-28a6ecbe17226107ba9c8f6f0c676b2b6baf9252.zip
- Use bsd.tcl.mk (implemented suggestion from [1])
- Use system-default PostgreSQL version (82) - Bump PORTREVISION PR: ports/143740 [1] Submitted by: Dan Lukes <dan@obluda.cz> Approved by: maintainer (timeout)
Notes
Notes: svn path=/head/; revision=251515
Diffstat (limited to 'databases/postgresql-pltcl/Makefile')
-rw-r--r--databases/postgresql-pltcl/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
index 0e2c6189caff..e8adabdcc7d2 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql-pltcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgresql
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases tcl
PKGNAMESUFFIX= -pltcl
@@ -16,9 +16,8 @@ COMMENT= A module for using Tcl to write SQL functions
MASTERDIR= ${.CURDIR}/../postgresql${PGSQL_VER}-server
RUN_DEPENDS= postgres:${MASTERDIR}
-LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
-DEFAULT_PGSQL_VER?=74
+DEFAULT_PGSQL_VER?=82
# can't include <bsd.port.pre.mk> in a slave port
# so set these instead:
@@ -34,15 +33,14 @@ PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]
PGSQL_VER= ${DEFAULT_PGSQL_VER}
.endif
-# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
-TCLVERSION?= 8.4
+# you can use "make WITH_TCL_VER=84" or similar for your favourite tcl version
+USE_TCL= 84+
CONFIGURE_ARGS= --with-tcl --without-tk \
- --with-tclconfig="${TCLCONFIG}" \
- --with-includes="${TCL_INCDIR}"
+ --with-tclconfig="${TCL_LIBDIR}" \
+ --with-includes="${TCL_INCLUDEDIR}"
-TCL_INCDIR= ${LOCALBASE}/include/tcl${TCLVERSION}
-TCLCONFIG= ${LOCALBASE}/lib/tcl${TCLVERSION}
-MAKE_ENV+= TCL_INCDIR=${TCL_INCDIR}
+CONFIGURE_ENV+= TCLSH="${TCLSH}"
+MAKE_ENV+= TCL_INCDIR="${TCL_INCLUDEDIR}"
BUILD_DIRS= src/pl/tcl
SLAVE_ONLY= yes