aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql81-server
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2000-05-25 09:35:25 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2000-05-25 09:35:25 +0000
commit989d7f9fd3534f9dd26e1d8e97d91869b7b6e784 (patch)
tree45ca91c134b704b4a12fa00afb54745cdfed8b84 /databases/postgresql81-server
parent7607e6564a32759932e6bb2df767cb1c2be214dd (diff)
downloadports-989d7f9fd3534f9dd26e1d8e97d91869b7b6e784.tar.gz
ports-989d7f9fd3534f9dd26e1d8e97d91869b7b6e784.zip
make startup script work (start/stop)
Obtained from: Palle Girgensohn <girgen@partitur.se>
Notes
Notes: svn path=/head/; revision=28745
Diffstat (limited to 'databases/postgresql81-server')
-rw-r--r--databases/postgresql81-server/Makefile3
-rw-r--r--databases/postgresql81-server/files/patch-bc5
-rw-r--r--databases/postgresql81-server/files/pgsql.sh.tmpl38
3 files changed, 26 insertions, 20 deletions
diff --git a/databases/postgresql81-server/Makefile b/databases/postgresql81-server/Makefile
index 180af73b7e23..0d4f2a236977 100644
--- a/databases/postgresql81-server/Makefile
+++ b/databases/postgresql81-server/Makefile
@@ -182,6 +182,9 @@ post-install:
@ ${ECHO_MSG} "Putting postgresql.jar in"
@ ${ECHO_MSG} "${PREFIX}/share/java/classes/postgresql.jar"
@ ${ECHO_MSG} "Add this to your CLASSPATH!"
+ @ ${ECHO_MSG} "ALSO NOTE: path inside jar file modified from 6.5.x:"
+ @ ${ECHO_MSG} " 'postgresql.*' -> 'org.postgresql.*'!"
+ @ ${ECHO_MSG} "You will need to modify you applications' props files."
@ ${ECHO_MSG} "---------------------------------------------------------"
@ ${CAT} ${PKGDIR}/PLIST.jdbc >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
diff --git a/databases/postgresql81-server/files/patch-bc b/databases/postgresql81-server/files/patch-bc
new file mode 100644
index 000000000000..ff747fb84a2f
--- /dev/null
+++ b/databases/postgresql81-server/files/patch-bc
@@ -0,0 +1,5 @@
+--- bin/pg_ctl/postmaster.opts.default.sample~ Mon Apr 17 05:45:17 2000
++++ bin/pg_ctl/postmaster.opts.default.sample Tue May 23 02:46:30 2000
+@@ -1 +1 @@
+-
++-i -o "-F"
diff --git a/databases/postgresql81-server/files/pgsql.sh.tmpl b/databases/postgresql81-server/files/pgsql.sh.tmpl
index 4f3575cd23cf..e1673b4850c2 100644
--- a/databases/postgresql81-server/files/pgsql.sh.tmpl
+++ b/databases/postgresql81-server/files/pgsql.sh.tmpl
@@ -1,36 +1,34 @@
#!/bin/sh
# $FreeBSD$
-
-# pgsql.sh - postgresql startup file for FreeBSD and possibly *BSD (untested)
-
-# Changes:
-# - renamed startup script to be in sync with INSTALL file
-# - merged ldconfig start sequence from former postgrsql.sh script (andreas)
-# - modified the postmaster startup sequence as suggested in the
-# INSTALL file which was given as example for FreeBSD 2.2 (andreas)
-# - removed the commandline option
-# -D!!PREFIX!!/pgsql/data \
-# because the postmaster process, which starts up under the
-# environment of the pgsql user, sets this with the PGDATA
-# environment variable in !!PREFIX!!/pgsql/.profile
-# - added (ugly) support for shutting down (girgen)
-# - moved 2>&1 to end of line, so it'll actually work [if -S is removed] (girgen)
+#
+# For postmaster startup options, edit $PGDATA/postmaster.opts.default
+# Preinstalled options are -i -o "-F"
case $1 in
start)
[ -d !!PREFIX!!/pgsql/lib ] && /sbin/ldconfig -m !!PREFIX!!/pgsql/lib
- [ -x !!PREFIX!!/pgsql/bin/postmaster ] && {
- su -l pgsql -c 'exec !!PREFIX!!/pgsql/bin/postmaster -i -S -o -F \
- > !!PREFIX!!/pgsql/errlog 2>&1'
+ [ -x !!PREFIX!!/pgsql/bin/pg_ctl ] && {
+ su -l pgsql -c \
+ 'exec !!PREFIX!!/pgsql/bin/pg_ctl -w start > !!PREFIX!!/pgsql/errlog 2>&1'
echo -n ' pgsql'
}
;;
+
stop)
- /usr/bin/killall postgres
+ [ -x !!PREFIX!!/pgsql/bin/pg_ctl ] && {
+ su -l pgsql -c 'exec !!PREFIX!!/pgsql/bin/pg_ctl -w -m fast stop'
+ }
;;
+
+status)
+ [ -x !!PREFIX!!/pgsql/bin/pg_ctl ] && {
+ su -l pgsql -c 'exec !!PREFIX!!/pgsql/bin/pg_ctl status'
+ }
+ ;;
+
*)
- echo "usage: `basename $0` {start|stop}" >&2
+ echo "usage: `basename $0` {start|stop|status}" >&2
exit 64
;;
esac