aboutsummaryrefslogtreecommitdiff
path: root/databases/py-python-swiftclient
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-12-18 15:44:45 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-12-18 15:44:45 +0000
commit74dcfe4548c25b48f2325355bdb05b5fe7a07a7e (patch)
treefa7d854a83bf2299ea0b17f2c5d10e41ae0cc89c /databases/py-python-swiftclient
parent20ee13c88256b3f0fd4139dc4503c18b0b4cacd1 (diff)
downloadports-74dcfe4548c25b48f2325355bdb05b5fe7a07a7e.tar.gz
ports-74dcfe4548c25b48f2325355bdb05b5fe7a07a7e.zip
databases/py-swiftclient: rename to py-python-swiftclient
- Rename to py-python-swiftclient to follow naming convention for Python port available on pypi to match pypi name - Update dependencies for databases/py-swift and net/py-python-heatclient and bump PORTREVISION for these ports PR: 215374 Approved by: trociny (maintainer)
Notes
Notes: svn path=/head/; revision=428875
Diffstat (limited to 'databases/py-python-swiftclient')
-rw-r--r--databases/py-python-swiftclient/Makefile29
-rw-r--r--databases/py-python-swiftclient/distinfo3
-rw-r--r--databases/py-python-swiftclient/pkg-descr8
-rw-r--r--databases/py-python-swiftclient/pkg-plist1
4 files changed, 41 insertions, 0 deletions
diff --git a/databases/py-python-swiftclient/Makefile b/databases/py-python-swiftclient/Makefile
new file mode 100644
index 000000000000..c1c55c6721ac
--- /dev/null
+++ b/databases/py-python-swiftclient/Makefile
@@ -0,0 +1,29 @@
+# Created by: Mikolaj Golub <trociny@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-swiftclient
+PORTVERSION= 3.2.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= trociny@FreeBSD.org
+COMMENT= Python client library for OpenStack Object Storage (Swift)
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=0.5.21:devel/py-pbr
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>=3.0:devel/py-futures \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}requests>=1.1:www/py-requests
+
+USES= python:2
+USE_PYTHON= distutils autoplist
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/manpages/swift.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/databases/py-python-swiftclient/distinfo b/databases/py-python-swiftclient/distinfo
new file mode 100644
index 000000000000..bbb5db8867fa
--- /dev/null
+++ b/databases/py-python-swiftclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1480260205
+SHA256 (python-swiftclient-3.2.0.tar.gz) = 8761697584ab060520d6094e8394242ee3b94c643ed1f3fe1dbc67df585ab3fa
+SIZE (python-swiftclient-3.2.0.tar.gz) = 161727
diff --git a/databases/py-python-swiftclient/pkg-descr b/databases/py-python-swiftclient/pkg-descr
new file mode 100644
index 000000000000..f8c8be3aa3f8
--- /dev/null
+++ b/databases/py-python-swiftclient/pkg-descr
@@ -0,0 +1,8 @@
+This is a python client for the Swift API. There's a Python API (the
+``swiftclient`` module), and a command-line script (``swift``).
+
+This code is based on the original client previously included with
+OpenStack's swift -- a highly available, distributed, eventually
+consistent object/blob store.
+
+WWW: http://launchpad.net/python-swiftclient
diff --git a/databases/py-python-swiftclient/pkg-plist b/databases/py-python-swiftclient/pkg-plist
new file mode 100644
index 000000000000..ff38fac69677
--- /dev/null
+++ b/databases/py-python-swiftclient/pkg-plist
@@ -0,0 +1 @@
+man/man1/swift.1.gz