aboutsummaryrefslogtreecommitdiff
path: root/databases/py-sqlalchemy
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2011-03-19 13:39:57 +0000
committerNicola Vitale <nivit@FreeBSD.org>2011-03-19 13:39:57 +0000
commit046af3450d31644a58f092651f25e5e0811c8a05 (patch)
tree31552c379d8e744bf9b69907a93dfab920102427 /databases/py-sqlalchemy
parent1bda2b27257c283e17a4a91482d5fa535c2ab5a7 (diff)
downloadports-046af3450d31644a58f092651f25e5e0811c8a05.tar.gz
ports-046af3450d31644a58f092651f25e5e0811c8a05.zip
- Add option WITH_NOSE (default off) for unit tests
- Fix a typo PR: ports/154891 Submitted by: Olivier Duchateau <duchateau.olivier at gmail.com>
Notes
Notes: svn path=/head/; revision=271310
Diffstat (limited to 'databases/py-sqlalchemy')
-rw-r--r--databases/py-sqlalchemy/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/databases/py-sqlalchemy/Makefile b/databases/py-sqlalchemy/Makefile
index e23deca40ead..815bad32864d 100644
--- a/databases/py-sqlalchemy/Makefile
+++ b/databases/py-sqlalchemy/Makefile
@@ -1,5 +1,5 @@
# Ports collection makefile for: py-sqlalchemy
-# Date created: 12 Auguest 2004
+# Date created: 12 August 2004
# Whom: Dryice Dong Liu <dryice@dryice.name>
#
# $FreeBSD$
@@ -27,6 +27,7 @@ OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
OPTIONS= FIREBIRD "support FireBird" off
OPTIONS+= MSSQL "support MS SQL Server" off
OPTIONS+= MYSQL "support MySql" on
+OPTIONS+= NOSE "install Nose for unit tests" off
OPTIONS+= POSTGRE "support PostGreSQL" on
OPTIONS+= SQLITE "support Sqlite" on
OPTIONS+= SYBASE "support Sybase" off
@@ -53,6 +54,10 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pymssql.py:${PORTSDIR}/databases/py-mssql
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
.endif
+.if defined(WITH_NOSE)
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}nose-1.0.0:${PORTSDIR}/devel/py-nose
+.endif
+
.if !defined(WITHOUT_POSTGRE)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:${PORTSDIR}/databases/py-psycopg2
.endif